]> git.pld-linux.org Git - packages/hhvm.git/blobdiff - hhvm.spec
system libafdt needs more work
[packages/hhvm.git] / hhvm.spec
index c9d92df7e1198d1abd1d605d4768d92905460339..6f1de1e585b6e4a1190a777a47448487b7858295 100644 (file)
--- a/hhvm.spec
+++ b/hhvm.spec
@@ -4,7 +4,7 @@
 %bcond_without system_sqlite   # system sqlite3
 %bcond_without system_lz4              # system lz4
 %bcond_without system_fastlz   # system fastlz
-%bcond_without system_libafdt  # system libafdt
+%bcond_with    system_libafdt  # system libafdt
 %bcond_without system_libzip   # system libzip
 # cotire breaks sqlite3 on builders: https://github.com/facebook/hhvm/issues/4524
 %bcond_with    cotire                  # cotire (compile time reducer): Speed up the build by precompiling headers
@@ -13,7 +13,6 @@
 # - system xhp
 # - system proxygen
 # - system thrift
-# - system LIBAFDT_LIBRARY
 
 # NOTES:
 # - hphp/runtime/base/runtime-option.cpp evalJitDefault enables jit if /.hhvm-jit exists (yes, in filesystem root)
@@ -54,6 +53,7 @@ Patch2:               hphpize.patch
 Patch3:                MAX.patch
 Patch4:                system-thirdparty.patch
 Patch5:                cmake.patch
+Patch6:                system-fastlz.patch
 URL:           https://github.com/facebook/hhvm/wiki
 BuildRequires: ImageMagick-devel
 BuildRequires: a52dec-libs-devel
@@ -75,7 +75,6 @@ BuildRequires:        glog-devel >= 0.3.2
 BuildRequires: imap-devel >= 1:2007
 #BuildRequires:        jemalloc-devel >= 3.0.0
 %{?with_system_libafdt:BuildRequires:  libafdt-devel >= 0.1.0}
-%{?with_system_libzip:BuildRequires:   libzip-devel >= 0.11.2}
 BuildRequires: libcap-devel
 BuildRequires: libdwarf-devel >= 20130729
 BuildRequires: libicu-devel >= 4.2
@@ -86,6 +85,7 @@ BuildRequires:        libstdc++-devel >= 6:4.8
 BuildRequires: libunwind-devel
 BuildRequires: libxml2-devel
 BuildRequires: libxslt-devel
+%{?with_system_libzip:BuildRequires:   libzip-devel >= 0.11.2}
 %{?with_system_lz4:BuildRequires:      lz4-devel >= 0.0-1.r119}
 BuildRequires: mysql-devel
 BuildRequires: ocaml-findlib
@@ -101,7 +101,7 @@ BuildRequires:      zlib-devel
 # check later, seem unused
 #BuildRequires:        bison >= 2.3
 #BuildRequires:        flex >= 2.5.35
-#BuildRequires:        libafdt-devel >= 0.1.0
+BuildRequires: libafdt-devel >= 0.1.0
 #BuildRequires:        re2c >= 0.13.0
 Provides:      %{name}(api) = %{hhvm_api_version}
 Provides:      php(core) = %{php_version}
@@ -259,7 +259,8 @@ mv folly-* third-party/folly/src
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
+#%patch5 -p1
+%patch6 -p1
 
 # prefer ones from system
 rm CMake/FindBISON.cmake
@@ -267,10 +268,9 @@ rm CMake/FindFLEX.cmake
 rm CMake/FindFreetype.cmake
 
 # ensure system libs get used
-# NOTE: keep sqlite dir, build breaks with 3.8.5.0
-
 cd third-party
 rm -r pcre \
+       %{?with_system_sqlite:libsqlite3} \
        %{?with_system_lz4:lz4} \
        %{?with_system_dconv:double-conversion} \
        %{?with_system_fastlz:fastlz} \
@@ -311,13 +311,6 @@ fi
        -DUSE_JEMALLOC=OFF \
        -DUSE_TCMALLOC=OFF \
        -DTEST_BIN=OFF \
-       -DPCRE_LIBRARY=OFF \
-       %{?with_system_sqlite:-DLIBSQLITE3_LIBRARY=OFF} \
-       %{?with_system_lz4:-DLZ4_LIBRARY=OFF} \
-       %{?with_system_dconv:-DDOUBLE_CONVERSION_LIBRARY=OFF} \
-       %{?with_system_fastlz:-DFASTLZ_LIBRARY=OFF} \
-       %{?with_system_libafdt:-DSYSTEM_LIBAFDT=ON} \
-       %{?with_system_libzip:-DLIBZIP_LIBRARY=OFF} \
        -DENABLE_COTIRE=%{!?with_cotire:OFF}%{?with_cotire:ON} \
        .
 
This page took 0.068476 seconds and 4 git commands to generate.