]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- package ka/LC_TIME locale dir (for coreutils 9.2); release 3
[packages/glibc.git] / glibc.spec
index c2505a2be88e996f8cd8166f04fb040d4d3980d4..eeac4037be1b3b2442ed19d59f7bd2594b8f0037 100644 (file)
@@ -9,7 +9,7 @@
 # - math/{test-fenv,test-tgmath,test-float,test-ifloat}, debug/backtrace-tst(SEGV)  fail on alpha
 #
 # Conditional build:
-# min_kernel   (default is 3.4.0 except for x86/x86_64 where 3.2.0 suffices)
+# min_kernel   (default is 3.2.0 with arch specific values x32 (3.4.0) aarch64 (3.7.0) ia64 (3.2.18))
 %bcond_without memusage        # don't build memusage utility
 %bcond_without selinux         # without SELinux support (in nscd)
 %bcond_with    tests           # perform "make test"
 %bcond_without nss_crypt       # disable crypt features based on Mozilla NSS library
 %bcond_with    bash_nls        # use bash NLS in shell scripts (ldd, sotruss); restores /bin/bash dep
 %bcond_without cet             # Intel Control-flow Enforcement Technology (CET)
-%bcond_without crypt           # don't build obsolete libcrypt
-%bcond_without static_pie      # disable static PIE support
+%bcond_with    crypt           # don't build obsolete libcrypt
 #
-%ifarch %{ix86} %{x8664}
-%{!?min_kernel:%global         min_kernel      3.2.0}
-%else
+%ifarch aarch64
+%{!?min_kernel:%global         min_kernel      3.7.0}
+%endif
+%ifarch ia64
+%{!?min_kernel:%global         min_kernel      3.2.18}
+%endif
+%ifarch x32
 %{!?min_kernel:%global         min_kernel      3.4.0}
 %endif
+%ifnarch aarch64 ia64 x32
+%{!?min_kernel:%global         min_kernel      3.2.0}
+%endif
 
 %ifarch sparc64
 %undefine      with_memusage
 %ifnarch i686 %{x8664} x32
 %undefine      with_cet
 %endif
-%ifarch %{arm}
-%undefine              with_static_pie
+%ifnarch %{arm}
+%define                with_static_pie         1
 %endif
 
-%define                core_version    2.34
+%define                core_version    2.37
 %define                llh_version     7:2.6.32.1-1
 
 Summary:       GNU libc
@@ -51,12 +57,12 @@ Summary(tr.UTF-8):  GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
 Version:       %{core_version}
-Release:       5
+Release:       3
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       https://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: 31998b53fb39cb946e96abc310af1c89
+# Source0-md5: e89cf3dcb64939d29f04b4ceead5cc4e
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
@@ -67,14 +73,13 @@ Source6:    %{name}-localedb-gen
 Source7:       %{name}-LD-path.c
 Source9:       nscd.tmpfiles
 # use branch.sh to update glibc-git.patch
-#Patch0:               glibc-git.patch
-## Patch0-md5: d41d8cd98f00b204e9800998ecf8427e
+Patch0:                glibc-git.patch
+# Patch0-md5:  86773bb487a8ee4c7b9a8194ee0f3b96
 # against GNU TP (libc domain)
 #Patch1:               %{name}-pl.po-update.patch
 Patch2:                %{name}-pld.patch
 Patch3:                %{name}-crypt-blowfish.patch
 Patch4:                %{name}-no-bash-nls.patch
-
 Patch6:                %{name}-paths.patch
 
 Patch10:       %{name}-info.patch
@@ -82,7 +87,7 @@ Patch11:      %{name}-autoconf.patch
 
 Patch14:       %{name}-sparc-errno_fix.patch
 Patch15:       %{name}-new-charsets.patch
-Patch16:       %{name}-tzfile-noassert.patch
+
 # additions pending for upstream merge or taken from other distros
 Patch17:       %{name}-morelocales.patch
 # fixes mostly pending for upstream merge
@@ -91,16 +96,13 @@ Patch19:    %{name}-ZA_collate.patch
 
 Patch23:       %{name}-pt_pax.patch
 
-# http://pkgs.fedoraproject.org/cgit/rpms/glibc.git/plain/glibc-c-utf8-locale.patch
-Patch27:       %{name}-c-utf8-locale.patch
-
-Patch29:       %{name}-arm-alignment-fix.patch
 Patch30:       glibc-rh1124987.patch
+Patch31:       arm-widevine-compat.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
-BuildRequires: binutils >= 2:2.29
+BuildRequires: binutils >= 4:2.29
 BuildRequires: bison >= 2.7
 %{!?with_cross:BuildRequires:  dietlibc-static}
 BuildRequires: gawk >= 3.1.2
@@ -111,6 +113,7 @@ BuildRequires:      gcc >= 6:6.2
 %endif
 %{?with_memusage:BuildRequires:        gd-devel >= 2.0.1}
 BuildRequires: gettext-tools >= 0.10.36
+%{?with_selinux:BuildRequires: libcap-devel}
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
 BuildRequires: linux-libc-headers >= %{llh_version}
 BuildRequires: make >= 1:4.0
@@ -136,7 +139,7 @@ Provides:   glibc(nptl)
 Provides:      glibc(tls)
 Provides:      rtld(GNU_HASH)
 Obsoletes:     glibc-common
-Obsoletes:     glibc-debug
+Obsoletes:     glibc-debug < 2.1
 Obsoletes:     glibc-ld < 6:2.33-2
 %ifarch %{x8664} sparc64 ppc64
 Provides:      glibc64
@@ -146,7 +149,7 @@ Suggests:   localedb
 Suggests:      tzdata
 Conflicts:     %{name}-misc < %{epoch}:%{version}-%{release}
 Conflicts:     SysVinit < 2.86-11
-Conflicts:     kernel < %{min_kernel}
+Conflicts:     kernel < 3:%{min_kernel}
 Conflicts:     kernel24
 Conflicts:     kernel24-smp
 Conflicts:     ld.so < 1.9.9-10
@@ -500,7 +503,7 @@ Requires:   %{name}-headers = %{epoch}:%{version}-%{release}
 %if %{with crypt}
 Requires:      %{name}-libcrypt(%{_target_cpu}) = %{epoch}:%{version}-%{release}
 %else
-Requires:      libxcrypt-devel
+Requires:      libxcrypt-devel >= 4.0.0
 %endif
 Provides:      %{name}-devel(%{_target_cpu}) = %{epoch}:%{version}-%{release}
 %ifarch %{ix86}
@@ -706,7 +709,7 @@ Summary(ru.UTF-8):  Статические библиотеки glibc
 Summary(uk.UTF-8):     Статичні бібліотеки glibc
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
-%{!?with_crypt:Requires:       libxcrypt-static}
+%{!?with_crypt:Requires:       libxcrypt-static >= 4.0.0}
 Provides:      %{name}-static(%{_target_cpu}) = %{epoch}:%{version}-%{release}
 %ifarch %{ix86}
 Provides:      %{name}-static(ix86) = %{epoch}:%{version}-%{release}
@@ -741,7 +744,7 @@ Summary(tr.UTF-8):  Ölçüm desteği olan glibc
 Summary(uk.UTF-8):     GNU libc з підтримкою профайлера
 Group:         Development/Libraries/Libc
 Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
-Obsoletes:     libc-profile
+Obsoletes:     libc-profile < 6
 
 %description profile
 When programs are being profiled using gprof, they must use these
@@ -949,7 +952,7 @@ echo "Minimal supported kernel is 3.2.0" >&2
 exit 1
 %endif
 
-#%patch0 -p1
+%patch0 -p1
 
 %patch2 -p1
 %patch3 -p1
@@ -962,17 +965,17 @@ exit 1
 
 %patch14 -p1
 %patch15 -p1
-%patch16 -p1
+
 %patch17 -p1
 %patch18 -p1
 %patch19 -p1
 
 %patch23 -p0
 
-%patch27 -p1
-
-%patch29 -p1
 %patch30 -p1
+%ifarch %{arm} aarch64
+%patch31 -p1
+%endif
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
@@ -1015,7 +1018,6 @@ AWK="gawk" \
        --enable-profile \
        --enable-stack-protector=strong \
        --enable-stackguard-randomization \
-       %{?with_static_pie:--enable-static-pie} \
        --enable-tunables \
        --with-binutils=$(pwd)/alt-tools \
        --with-bugurl=http://bugs.pld-linux.org/ \
@@ -1089,8 +1091,8 @@ cd ..
 install -p glibc-postinst                              $RPM_BUILD_ROOT/sbin
 %endif
 
-%{?with_memusage:mv -f $RPM_BUILD_ROOT/%{_lib}/libmemusage.so $RPM_BUILD_ROOT%{_libdir}}
-mv -f $RPM_BUILD_ROOT/%{_lib}/libpcprofile.so  $RPM_BUILD_ROOT%{_libdir}
+%{?with_memusage:%{__mv} $RPM_BUILD_ROOT/%{_lib}/libmemusage.so $RPM_BUILD_ROOT%{_libdir}}
+%{__mv} $RPM_BUILD_ROOT/%{_lib}/libpcprofile.so        $RPM_BUILD_ROOT%{_libdir}
 
 # make symlinks across top-level directories absolute
 for l in BrokenLocale anl %{?with_crypt:crypt} c_malloc_debug\
@@ -1106,6 +1108,9 @@ done
 # linking nss modules directly is not supported
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libnss_*.so
 
+# avoid conflict on multilib
+%{__mv} $RPM_BUILD_ROOT%{_bindir}/ld.so{,-%{_target_cpu}}
+
 install -p %{SOURCE2}          $RPM_BUILD_ROOT/etc/rc.d/init.d/nscd
 cp -a %{SOURCE3}               $RPM_BUILD_ROOT/etc/sysconfig/nscd
 cp -a %{SOURCE4}               $RPM_BUILD_ROOT/etc/logrotate.d/nscd
@@ -1114,6 +1119,9 @@ cp -a posix/gai.conf              $RPM_BUILD_ROOT%{_sysconfdir}
 sed -e 's#\([ \t]\)db\([ \t]\)#\1#g' nss/nsswitch.conf > $RPM_BUILD_ROOT%{_sysconfdir}/nsswitch.conf
 
 xz -dc %{SOURCE5} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
+# catchsegv was removed in glibc 2.35
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/catchsegv.1
+
 : > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.cache
 install -d $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
 echo 'include ld.so.conf.d/*.conf' > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf
@@ -1158,7 +1166,6 @@ done
 #   tlh - Klingon (bzflag)
 #
 # To be added when they become supported by glibc:
-#   ab     (at-spi2-core)
 #   ace    (iso-codes)
 #   ach    (iso-codes, libreport, vlc)
 #   aln    (libreport, vlc)
@@ -1174,14 +1181,14 @@ done
 #   haw    (iso-codes, stellarium)
 #   hrx    (stellarium)
 #   hye    (xfce)
-#   ie     (xfce, cinnamon)
+#   ie     (GNOME, xfce, cinnamon)
 #   ilo    (kudzu, libosinfo, libreport)
 #   io     (alacarte, gtk+2, gnome, iso-codes)
 #   jam    (iso-codes)
 #   jv     (avant-window-navigator, gmpc, kdesudo, mate, cinnamon)
 #   ki     (iso-codes)
 #   kok@latin  (inkscape)
-#   kmr    (vlc)
+#   kmr    (iso-codes, vlc)
 #   ksw    (cinnamon)
 #   ku_IQ  (mate)
 #   kv     (iso-codes)
@@ -1203,9 +1210,9 @@ done
 #   son    (gtkspell3, iso-codes)
 #   su     (terminator)
 #   swg    (sim)
-#   syr    (iso-codes)
 #   tet    (vlc)
 #   tw     (libosinfo)
+#   tzm    (iso-codes)
 #   vec    (mate-applet-indicator)
 #   wba    (libosinfo)
 #   zgh    (cinnamon, xapps)
@@ -1216,6 +1223,7 @@ done
 #
 # Short forms (omitted country code, used instead of long form) for ambiguous or unclear cases:
 # aa=aa_ER
+# ab=ab_GE
 # ak=ak_GH
 # anp=anp_IN
 # ar=common? (AE, BH, DZ, EG, IQ, JO, KW, LB, LY, MA, OM, QA, SA, SD, SY, TN, YE)
@@ -1279,7 +1287,7 @@ done
 #   be ca cs da de el en_GB es fi fr gl hr hu it ja ko nb nl pl pt_BR ru rw sk
 #   sv tr zh_CN zh_TW
 #
-for i in aa aa@saaho af ak am an ang anp ar ar_TN as ast az az_IR \
+for i in aa aa@saaho ab af ak am an ang anp ar ar_TN as ast az az_IR \
        be@latin be@tarask bem ber bg bho bn bn_IN bo br brx bs byn \
        ca@valencia ce chr ckb cmn crh csb cv cy de_AT de_CH doi dv dz \
        en en@boldquot en@quot en@shaw en_AU en_CA en_IE en_NZ en_US en_ZA eo \
@@ -1290,7 +1298,7 @@ for i in aa aa@saaho af ak am an ang anp ar ar_TN as ast az az_IR \
        mai mg mhr mi mjw mk ml mn mni mr ms mt my nds ne nl_BE nn nr nso oc om or os \
        pa pap ps pt ps quz rm ro \
        sa sat sc sd sd@devanagari se shn si sid sl so sq \
-       sr sr@Latn sr@ije sr@ijekavian sr@ijekavianlatin sr@latin ss st sw szl \
+       sr sr@Latn sr@ije sr@ijekavian sr@ijekavianlatin sr@latin ss st sw syr szl \
        ta te tg th ti tig tk tl tlh tn tpi ts tt tt@iqtelif \
        ug uk ur uz uz@cyrillic ve vi wa wal wo xh yi yo zh_HK zu; do
        if [ ! -d $RPM_BUILD_ROOT%{_localedir}/$i/LC_MESSAGES ]; then
@@ -1302,7 +1310,7 @@ for i in aa aa@saaho af ak am an ang anp ar ar_TN as ast az az_IR \
 done
 
 # LC_TIME category, used for localized date formats (at least by coreutils)
-for i in af be bg ca cs da de el en eo es et eu fi fr ga gl hr hu ia id it ja kk ko lg lt \
+for i in af be bg ca cs da de el en eo es et eu fi fr ga gl hr hu ia id it ja ka kk ko lg lt \
        ms nb nl pl pt pt_BR ro ru rw sk sl sr sv tr uk vi zh_CN zh_TW; do
        if [ ! -d $RPM_BUILD_ROOT%{_localedir}/$i ]; then
                echo "%lang($lang) %{_localedir}/$i" >> glibc.lang
@@ -1454,7 +1462,6 @@ fi
 %else
 %attr(755,root,root) /%{_lib}/libBrokenLocale.so.1
 %endif
-%attr(755,root,root) /%{_lib}/libSegFault.so
 %attr(755,root,root) /%{_lib}/libanl.so.1
 %ifarch alpha ia64
 %attr(755,root,root) /%{_lib}/libc.so.6.1
@@ -1516,6 +1523,7 @@ fi
 %attr(755,root,root) %{_bindir}/getconf
 %attr(755,root,root) %{_bindir}/getent
 %attr(755,root,root) %{_bindir}/iconv
+%attr(755,root,root) %{_bindir}/ld.so-%{_target_cpu}
 %attr(755,root,root) %{_bindir}/locale
 %attr(755,root,root) %{_bindir}/zdump
 %attr(755,root,root) %{_sbindir}/zic
@@ -1768,17 +1776,15 @@ fi
 
 %files misc
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/catchsegv
 %attr(755,root,root) %{_bindir}/ldd
 %attr(755,root,root) %{_bindir}/pldd
-%ifarch %{ix86} m68k sparc sparcv9
+%ifarch m68k sparc sparcv9
 %attr(755,root,root) %{_bindir}/lddlibc4
 %endif
 %attr(755,root,root) %{_bindir}/sotruss
 %dir %{_libdir}/audit
 %attr(755,root,root) %{_libdir}/audit/sotruss-lib.so
 
-%{_mandir}/man1/catchsegv.1*
 %{_mandir}/man1/ldd.1*
 %{_mandir}/man1/pldd.1*
 %lang(cs) %{_mandir}/cs/man1/ldd.1*
This page took 0.08847 seconds and 4 git commands to generate.