]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- deUcoded ascii characters in morelocales patch (following glibc upstream) + few...
[packages/glibc.git] / glibc.spec
index 7398c373442b93b65f2771400c107a8ac941f497..7d17d232f1840d1b82df2229df5a81d52d3fbe01 100644 (file)
@@ -8,7 +8,7 @@
 # - math/{test-fenv,test-tgmath,test-float,test-ifloat}, debug/backtrace-tst(SEGV)  fail on alpha
 #
 # Conditional build:
-# min_kernel   (default is 3.4.0 except for x86/x86_64 where 2.6.32 suffices)
+# min_kernel   (default is 3.4.0 except for x86/x86_64 where 3.2.0 suffices)
 %bcond_without memusage        # don't build memusage utility
 %bcond_without selinux         # without SELinux support (in nscd)
 %bcond_with    tests           # perform "make test"
@@ -18,7 +18,7 @@
 %bcond_with    bash_nls        # use bash NLS in shell scripts (ldd, sotruss); restores /bin/bash dep
 #
 %ifarch %{ix86} %{x8664}
-%{!?min_kernel:%global         min_kernel      2.6.32} 
+%{!?min_kernel:%global         min_kernel      3.2.0}
 %else
 %{!?min_kernel:%global         min_kernel      3.4.0}
 %endif
@@ -27,7 +27,7 @@
 %undefine      with_memusage
 %endif
 
-%define                core_version    2.25
+%define                core_version    2.27
 %define                llh_version     7:2.6.32.1-1
 
 Summary:       GNU libc
@@ -41,12 +41,12 @@ Summary(tr.UTF-8):  GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
 Version:       %{core_version}
-Release:       1
+Release:       3
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: 1496c3bf41adf9db0ebd0af01f202eed
+# Source0-md5: 898cd5656519ffbc3a03fe811dd89e82
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
@@ -58,7 +58,7 @@ Source7:      %{name}-LD-path.c
 Source9:       nscd.tmpfiles
 # use branch.sh to update glibc-git.patch
 #Patch0:               glibc-git.patch
-## Patch0-md5: d41d8cd98f00b204e9800998ecf8427e
+# Patch0-md5:  d41d8cd98f00b204e9800998ecf8427e
 # against GNU TP (libc domain)
 #Patch1:               %{name}-pl.po-update.patch
 Patch2:                %{name}-pld.patch
@@ -80,7 +80,6 @@ Patch17:      %{name}-morelocales.patch
 # fixes mostly pending for upstream merge
 Patch18:       %{name}-locale_fixes.patch
 Patch19:       %{name}-ZA_collate.patch
-Patch20:       %{name}-thread_start.patch
 
 Patch23:       %{name}-pt_pax.patch
 
@@ -89,17 +88,12 @@ Patch27:    %{name}-c-utf8-locale.patch
 
 Patch29:       %{name}-arm-alignment-fix.patch
 Patch30:       glibc-rh1124987.patch
-
-Patch38:       1055_all_glibc-resolv-dynamic.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
-%ifarch alpha
-BuildRequires: binutils >= 2:2.17.50.0.7
-%else
-BuildRequires: binutils >= 2:2.15.90.0.3
-%endif
+BuildRequires: binutils >= 2:2.29
+BuildRequires: bison >= 2.7
 %{!?with_cross:BuildRequires:  dietlibc-static}
 BuildRequires: gawk
 BuildRequires: gcc >= 6:4.7
@@ -181,6 +175,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _noautoprov             .*\(GLIBC_PRIVATE\)
 %define                _noautoreq              .*\(GLIBC_PRIVATE\)
 
+# to avoid multi-arch conflicts on getconf/* files
+%define                _libexecdir             %{_libdir}
+
 %description
 Contains the standard libraries that are used by multiple programs on
 the system. In order to save disk space and memory, as well as to ease
@@ -949,8 +946,8 @@ kodowania danych z poziomu dowolnego programu.
 %prep
 %setup -q
 
-%if "%{min_kernel}" < "2.6.32"
-echo "Minimal supported kernel is 2.6.32" >&2
+%if "%{min_kernel}" < "3.2.0"
+echo "Minimal supported kernel is 3.2.0" >&2
 exit 1
 %endif
 
@@ -963,7 +960,7 @@ exit 1
 %patch6 -p1
 
 %patch8 -p1
-%patch9 -p0
+%patch9 -p1
 
 %patch10 -p1
 %patch11 -p1
@@ -974,7 +971,6 @@ exit 1
 %patch17 -p1
 %patch18 -p1
 %patch19 -p1
-%patch20 -p1
 
 %patch23 -p0
 
@@ -983,8 +979,6 @@ exit 1
 %patch29 -p1
 %patch30 -p1
 
-%patch38 -p1
-
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
@@ -1018,10 +1012,12 @@ AWK="gawk" \
        --enable-hidden-plt \
        --enable-kernel="%{min_kernel}" \
        --enable-nss-crypt%{!?with_nss_crypt:=no} \
+       --enable-obsolete-nsl \
        --enable-obsolete-rpc \
        --enable-profile \
        --enable-stack-protector=strong \
        --enable-stackguard-randomization \
+       --enable-static-pie \
        --enable-tunables \
        --with-binutils=$(pwd)/alt-tools \
        --with-bugurl=http://bugs.pld-linux.org/ \
@@ -1134,7 +1130,7 @@ cp -p %{SOURCE9} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/nscd.conf
 rm -rf documentation
 install -d documentation
 
-for f in ChangeLog.old DESIGN-systemtap-probes.txt TODO{,-kernel,-testing}; do
+for f in DESIGN-systemtap-probes.txt TODO{,-kernel,-testing}; do
        cp -af nptl/$f documentation/$f.nptl
 done
 cp -af crypt/README.ufc-crypt ChangeLog* documentation
@@ -1162,7 +1158,7 @@ done
 #   aln    (vlc, libreport)
 #   bal    (libosinfo, libreport, newt, pessulus)
 #   cgg    (vlc)
-#   co     (vlc)
+#   co     (FileZilla, vlc)
 #   frp    (xfce, lxlauncher, mate)
 #   gn     (gn_BR in gnome, maybe gn_PY)
 #   guc    (gtk-vnc)
@@ -1171,14 +1167,18 @@ done
 #   ilo    (kudzu, libosinfo, libreport)
 #   io     (gtk+2, gnome, alacarte)
 #   jv     (gmpc, avant-window-navigator, kdesudo, mate)
+#   kab    (FileZilla)
+#   kok@latin  (inkscape)
 #   kmr    (vlc)
 #   ku_IQ  (mate)
 #   kw@kkcor, kw@uccor (libosinfo - currently empty) - add as supported variants when non-empty?
 #   man    (ccsm; incorrectly named md)
+#   mni@beng[ali]  (inkscape)
 #   mus    (bluez-gnome)
 #   nah    (mate)
 #   nqo           (mate)
 #   pms    (deluge, mate-tweak)
+#   sat@deva[nagari]  (inkscape)
 #   sco    (gnomad2, picard, stellarium, mate)
 #   son    (gtkspell3)
 #   su     (terminator)
@@ -1216,8 +1216,12 @@ done
 # fy=fy_NL
 # gez=gez_ET (?)
 # it=it_IT
+# ks=ks_IN
+# ks@devanagari=ks_IN@devanagari
 # ku=ku_TR
 # li=li_NL
+# ln=ln_CD
+# lo=lo_LA
 # nds=nds_DE
 # nl=nl_NL
 # om=om_ET
@@ -1227,6 +1231,7 @@ done
 # quz=quz_PE
 # ru=ru_RU
 # sd=sd_IN
+# sd@devanagari=sd_IN@devanagari
 # shn=shn_MM
 # so=so_SO
 # sr=sr_RS [cyrillic]
@@ -1251,9 +1256,9 @@ for i in aa aa@saaho af ak am an ang anp ar ar_TN as ast az az_IR be@latin be@ta
        en@boldquot en@quot en@shaw en_AU en_CA en_NZ en_US eo es_AR es_CL es_CO es_CR \
        es_DO es_EC es_GT es_HN es_MX es_NI es_PA es_PE es_PR es_SV es_UY \
        es_VE et eu fa ff fil fo fr_BE fr_CA fr_CH fur fy ga gd gez gu gv ha he \
-       hi hne hsb hy ia id ig ik is it_CH iu ka kg kk kl km kn kok ks ku kw ky la lb \
-       lg li lo lt lv mai mg mhr mi mk ml mn mni mr ms mt my nds ne nl_BE nn nr nso \
-       oc om or pa pap ps pt ps quz rm ro sa sat sc sd se shn si sid sl so sq sr sr@Latn szl tl \
+       hi hne hsb hy ia id ig ik is it_CH iu ka kg kk kl km kn kok ks ks@devanagari ku kw ky la lb \
+       lg li ln lo lt lv mai mg mhr mi mk ml mn mni mr ms mt my nds ne nl_BE nn nr nso \
+       oc om or pa pap ps pt ps quz rm ro sa sat sc sd sd@devanagari se shn si sid sl so sq sr sr@Latn szl tl \
        sr@ije sr@ijekavian sr@ijekavianlatin sr@latin ss st sw ta te tg th ti \
        tig tk tl tlh tn ts tt tt@iqtelif ug uk ur uz uz@cyrillic ve vi wa wal wo xh yi yo \
        zh_HK zu; do
@@ -1377,7 +1382,7 @@ fi
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README NEWS BUGS CONFORMANCE
+%doc README NEWS
 %if %{without cross}
 %attr(755,root,root) /sbin/glibc-postinst
 %endif
@@ -1829,7 +1834,8 @@ fi
 %attr(755,root,root) %{_libdir}/libthread_db.so
 %attr(755,root,root) %{_libdir}/libutil.so
 %{_libdir}/crt[1in].o
-%{_libdir}/[MSg]crt1.o
+%{_libdir}/[MSgr]crt1.o
+%{_libdir}/grcrt1.o
 # ld scripts
 %{_libdir}/libc.so
 %{_libdir}/libpthread.so
@@ -1839,7 +1845,6 @@ fi
 %endif
 %{_libdir}/libc_nonshared.a
 %{_libdir}/libg.a
-%{_libdir}/libieee.a
 %ifarch alpha ppc sparc
 %{_libdir}/libnldbl_nonshared.a
 %endif
This page took 0.041634 seconds and 4 git commands to generate.