]> git.pld-linux.org Git - packages/gitlab-ce.git/blobdiff - gitlab-ce.spec
solve deps for install
[packages/gitlab-ce.git] / gitlab-ce.spec
index 17f2034466c63e8f1baac0ec4c5039dbfb59ce25..ecbec4b0d31a9e51ad70910f9dd04156150415f1 100644 (file)
@@ -3,21 +3,25 @@
 #  mode (i.e. into isolated directory inside application). That's not PLD Linux
 #  way how it should be done, but GitLab has too many dependencies that it will
 #  be too difficult to maintain them via distro packages.
+#
+# install notes: https://gitlab.com/gitlab-org/gitlab-ce/blob/v8.6.6/doc/install/installation.md
+#
 # TODO
 # - [timfel-krb5-auth] doesn't build with heimdal (https://github.com/timfel/krb5-auth/issues/8)
 #
 #
 # Conditional build:
 %bcond_with    krb5            # build with kerberos support
+%bcond_with    gem_cache       # build from local gem cache only (avoids network)
 
 Summary:       A Web interface to create projects and repositories, manage access and do code reviews
 Name:          gitlab-ce
-Version:       8.5.8
-Release:       0.1
+Version:       8.6.6
+Release:       0.2
 License:       MIT
 Group:         Applications/WWW
+# md5 deliberately omitted until this package is useful
 Source0:       https://github.com/gitlabhq/gitlabhq/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: d8514dee6e06eb222da814873b567e5e
 URL:           https://www.gitlab.com/gitlab-ce/
 Source1:       gitlab.target
 Source2:       gitlab-sidekiq.service
@@ -25,17 +29,20 @@ Source3:    gitlab-unicorn.service
 Source4:       gitlab.logrotate
 Source5:       gitlab.tmpfiles.d
 Source6:       gitlab-apache-conf
+BuildRequires: gmp-devel
 BuildRequires: ruby-bundler
+BuildRequires: ruby-devel >= 1:2.1.0
 Obsoletes:     gitlab <= 8.1.4
 Requires(pre): gitlab-shell
 Requires:      apache-base
-Requires:      git-core
+Requires:      git-core >= 2.7.4
 Requires:      ruby-bundler
 Suggests:      mysql
 Suggests:      redis-server
-BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define        _noautoreqfiles redcloth_scan.jar primitives.jar
+
 %define gitlab_uid 65434
 %define gitlab_gid 65434
 
@@ -66,14 +73,19 @@ sed -e "s|username: git|username: gitlab|" \
 
 rm .flayignore
 rm .gitignore
+rm .csscomb.json
 find -name .gitkeep | xargs rm
                
 %build
 bundle install %{_smp_mflags} \
        --verbose \
+       %{?with_gem_cache:--local} \
        %{?debug:--no-cache --no-prune} \
         --deployment --without development test aws %{!?with_krb5:kerberos}
 
+# avoid bogus ruby dep
+chmod a-x vendor/bundle/ruby/gems/unicorn-*/bin/unicorn*
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d \
@@ -158,6 +170,8 @@ fi
 %config(noreplace) %{_sysconfdir}/gitlab/database.yml
 %config(noreplace) %{_sysconfdir}/gitlab/gitlab.yml
 %config(noreplace) %{_sysconfdir}/gitlab/unicorn.rb
+%dir /etc/httpd
+%dir /etc/httpd/httpd.d
 %config(noreplace) %{_sysconfdir}/httpd/httpd.d/gitlab.conf
 /etc/logrotate.d/gitlab.logrotate
 %{systemdunitdir}/gitlab-sidekiq.service
This page took 0.055409 seconds and 4 git commands to generate.