]> git.pld-linux.org Git - packages/gdb.git/blobdiff - gdb.spec
- x32 patch no longer needed
[packages/gdb.git] / gdb.spec
index b5e7ae85e73e422f5d70d8d4ca2c40400ce15f44..b1d2688e21db3504ec6b9d8a81694cc5e30a7437 100644 (file)
--- a/gdb.spec
+++ b/gdb.spec
@@ -1,6 +1,7 @@
 # NOTE: -lib package is used by fpc.spec
 
 # TODO
+# - rpm5 librpm support (gdb/configure.ac checks for 4.x or so)
 # - change install msg to poldek in buildid-locate-rpm-pld.patch when poldek allows it. LP#493922
 #
 # Conditional build:
@@ -18,14 +19,13 @@ Summary(tr.UTF-8):  C ve diğer diller için sembolik hata ayıklayıcı
 Summary(uk.UTF-8):     Символьний відладчик для С та інших мов
 Summary(zh_CN.UTF-8):  [开发]C和其他语言的调试器
 Summary(zh_TW.UTF-8):  [.-A開發]C和.$)B其.-A他語.$)B言的調試器
-%define                snap    20120926
 Name:          gdb
-Version:       7.9
-Release:       2
+Version:       8.1
+Release:       1
 License:       GPL v3+
 Group:         Development/Debuggers
 Source0:       http://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.xz
-# Source0-md5: e6279f26559d839f0b4218a482bcb43e
+# Source0-md5: f46487561f9a16916a8102316f7fd105
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 2e8a48939ae282c12bbacdd54e398247
 Source3:       %{name}-gstack.man
@@ -35,13 +35,14 @@ Patch102:   gdb-6.6-buildid-locate-rpm.patch
 Patch103:      gdb-6.6-buildid-locate-core-as-arg.patch
 Patch104:      gdb-6.6-buildid-locate-rpm-librpm-workaround.patch
 Patch105:      gdb-6.6-buildid-locate-misleading-warning-missing-debuginfo-rhbz981154.patch
+Patch106:      gdb-6.6-buildid-locate-rpm-scl.patch
 Patch110:      gdb-6.3-gstack-20050411.patch
 Patch111:      gdb-gdb-add-index-script.patch
 Patch112:      gdb-archer-vla-tests.patch
-Patch113:      gdb-vla-intel.patch
-Patch114:      gdb-vla-intel-04of23-fix.patch
-Patch115:      gdb-vla-intel-stringbt-fix.patch
-Patch116:      gdb-vla-intel-logical-not.patch
+Patch113:      gdb-vla-intel-fortran-strides.patch
+Patch114:      gdb-vla-intel-stringbt-fix.patch
+Patch115:      gdb-vla-intel-fortran-vla-strings.patch
+Patch116:      gdb-vla-intel-tests.patch
 Patch1000:     %{name}-readline.patch
 Patch1001:     %{name}-info.patch
 Patch1002:     %{name}-passflags.patch
@@ -51,18 +52,21 @@ URL:                http://www.gnu.org/software/gdb/
 BuildRequires: autoconf >= 2.69
 BuildRequires: automake
 BuildRequires: bison
-BuildRequires: babeltrace-devel
+BuildRequires: babeltrace-devel >= 1.1.0
 BuildRequires: expat-devel
-BuildRequires: flex
-BuildRequires: gettext-tools
+BuildRequires: flex >= 2.6.4
+BuildRequires: gettext-tools >= 0.12.1
 %{?with_guile:BuildRequires:   guile-devel >= 2.0}
 BuildRequires: libselinux-devel
+BuildRequires: libstdc++-devel >= 6:4.8
 BuildRequires: libtool
+BuildRequires: make >= 3.81
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: pkgconfig
 BuildRequires: readline-devel
 BuildRequires: rpmbuild(macros) >= 1.219
 BuildRequires: texinfo >= 4.4
+BuildRequires: xz-devel
 BuildRequires: zlib-devel
 %if %{with python}
 BuildRequires: python-devel
@@ -71,7 +75,7 @@ Obsoletes:    python-gdb
 # for traceback module
 Requires:      python-modules
 %endif
-%{?with_guile:Requires:        guile >= 2.0}
+%{?with_guile:Requires:        guile >= 2.0.12}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -182,6 +186,7 @@ rm -f gdb/jv-exp.c gdb/m2-exp.c gdb/objc-exp.c gdb/p-exp.c
 %patch103 -p1
 %patch104 -p1
 %patch105 -p1
+%patch106 -p1
 %patch110 -p1
 %patch111 -p1
 %patch112 -p1
@@ -266,20 +271,21 @@ install -d $RPM_BUILD_ROOT%{_infodir}
 %{__make} -j1 install install-info \
        DESTDIR=$RPM_BUILD_ROOT
 
-# gdbtui seems all identical to gdb except when invoked as gdbtio, ncurses
+cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
+
+# gdbtui seems all identical to gdb except when invoked as gdbtui, ncurses
 # window is created too.
 echo ".so gdb.1" > $RPM_BUILD_ROOT%{_mandir}/man1/gdbtui.1
 ln -f $RPM_BUILD_ROOT%{_bindir}/{gdb,gdbtui}
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
-cp -a gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
 
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
-rm -f $RPM_BUILD_ROOT%{_mandir}/README.gdb-non-english-man-pages
 
 %if %{with python}
 # Temporarily now:
-for LIB in lib lib64; do
+for LIB in lib lib64 libx32; do
        LIBPATH="$RPM_BUILD_ROOT%{_datadir}/gdb/auto-load%{_prefix}/$LIB"
        install -d $LIBPATH
 done
@@ -322,8 +328,9 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/gdb/auto-load
 %dir %{_datadir}/gdb/auto-load%{_prefix}
 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib
-%ifarch %{x8664}
+%ifarch %{x8664} x32
 %dir %{_datadir}/gdb/auto-load%{_prefix}/lib64
+%dir %{_datadir}/gdb/auto-load%{_prefix}/libx32
 %endif
 %{?with_guile:%{_datadir}/gdb/guile}
 %{_datadir}/gdb/syscalls
This page took 0.033167 seconds and 4 git commands to generate.