]> git.pld-linux.org Git - packages/gcc.git/blobdiff - gcc.spec
package mwaitintrin.h on x86; rel 3
[packages/gcc.git] / gcc.spec
index b8503cde6ae0568d1ea4a70d7b091f45b7e0137d..6c9f38d5a6b14d8824d8dadc061c7655264e4c00 100644 (file)
--- a/gcc.spec
+++ b/gcc.spec
@@ -99,7 +99,7 @@
 # Stable is: any major_ver and minor_ver >= 1.0
 # For PLD we usually use gcc when minor_ver >= 2.0 (first bugfix release or later)
 %define                major_ver       11
-%define                minor_ver       1.0
+%define                minor_ver       2.0
 
 Summary:       GNU Compiler Collection: the C compiler and shared files
 Summary(es.UTF-8):     Colección de compiladores GNU: el compilador C y ficheros compartidos
@@ -107,19 +107,19 @@ Summary(pl.UTF-8):        Kolekcja kompilatorów GNU: kompilator C i pliki współdziel
 Summary(pt_BR.UTF-8):  Coleção dos compiladores GNU: o compilador C e arquivos compartilhados
 Name:          gcc
 Version:       %{major_ver}.%{minor_ver}
-Release:       1
+Release:       3
 Epoch:         6
 License:       GPL v3+
 Group:         Development/Languages
 Source0:       https://gcc.gnu.org/pub/gcc/releases/%{name}-%{version}/%{name}-%{version}.tar.xz
-# Source0-md5: 77f6252be0861ab918042acf42bc10ff
+# Source0-md5: 31c86f2ced76acac66992eeedce2fce2
 Source1:       %{name}-optimize-la.pl
 # check libffi version with libffi/configure.ac
 Source3:       libffi.pc.in
 Source4:       branch.sh
 # use branch.sh to update gcc-branch.diff
 Patch100:      %{name}-branch.diff
-# Patch100-md5:        9e6d33449b31b2dcc0283844dbd683be
+# Patch100-md5:        e4e0ccce73627de0bf6564d11c54b603
 Patch0:                %{name}-info.patch
 Patch2:                %{name}-nodebug.patch
 Patch3:                %{name}-ada-link.patch
@@ -241,7 +241,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # receiving non constant format strings
 %define                Werror_cflags   %{nil}
 
-%define                skip_post_check_so      '.*(libasan|libcc1plugin|libcp1plugin|libgo|libitm|libxmlj|libubsan|lib-gnu-awt-xlib)\.so.*'
+%define                skip_post_check_so      '.*(libasan|libcc1plugin|libcp1plugin|libgnat-%{major_ver}|libgo|libitm|libxmlj|libubsan|lib-gnu-awt-xlib)\.so.*'
 # private symbols
 %define                _noautoreq              .*\(GLIBC_PRIVATE\)
 
@@ -2668,11 +2668,30 @@ TEXCONFIG=false \
 %endif
        --with-system-zlib \
        --without-x \
+%ifarch armv6l
+       --with-arch=armv6 \
+%endif
 %ifarch armv6hl
        --with-arch=armv6 \
        --with-float=hard \
        --with-fpu=vfp \
 %endif
+%ifarch armv7l
+       --with-arch=armv7 \
+       --with-mode=thumb \
+%endif
+%ifarch armv7hl
+       --with-arch=armv7-a \
+       --with-float=hard \
+       --with-fpu=vfpv3-d16 \
+       --with-mode=thumb \
+%endif
+%ifarch armv7hnl
+       --with-arch=armv7-a \
+       --with-float=hard \
+       --with-fpu=neon-vfpv3 \
+       --with-mode=thumb \
+%endif
 %if %{with cxx}
        --enable-__cxa_atexit \
        --enable-libstdcxx-allocator=new \
@@ -3237,6 +3256,7 @@ rm -rf $RPM_BUILD_ROOT
 %{gcclibdir}/include/mmintrin.h
 %{gcclibdir}/include/mm_malloc.h
 %{gcclibdir}/include/movdirintrin.h
+%{gcclibdir}/include/mwaitintrin.h
 %{gcclibdir}/include/mwaitxintrin.h
 %{gcclibdir}/include/nmmintrin.h
 %{gcclibdir}/include/pconfigintrin.h
This page took 0.065751 seconds and 4 git commands to generate.