]> git.pld-linux.org Git - packages/electron.git/blobdiff - electron.spec
build invocation
[packages/electron.git] / electron.spec
index 515fc5bb5f950e2875b0eb955918c6531542d3e8..a79b3aa417223d055cb60516bd849d26c71dd944 100644 (file)
@@ -1,6 +1,9 @@
-
 # TODO:
-#      - build from source (the process and deps look like hell)
+# - build from source (the process and deps look like hell)
+#   https://github.com/atom/electron/blob/v0.36.0/docs/development/build-instructions-linux.md
+# NOTES:
+# - space considerations: ~25GiB for build
+#
 
 Summary:       Framework cross-platform desktop applications using JavaScript, HTML and CSS
 Name:          electron
@@ -8,14 +11,10 @@ Version:     0.36.0
 Release:       0.1
 License:       MIT, BSD
 Group:         Applications
-#Source0:      https://github.com/atom/electron/archive/v%{version}/%{name}-%{version}.tar.gz
-## Source0-md5:        0c20e4676d7aef091521c9264d58939a
-Source1:       https://github.com/atom/electron/releases/download/v%{version}/%{name}-v%{version}-linux-ia32.zip
-# Source1-md5: 1272f2a7330341f86cd8be1cce14afc9
-Source2:       https://github.com/atom/electron/releases/download/v%{version}/%{name}-v%{version}-linux-x64.zip
-# Source2-md5: 1c77028a12330b4883fe93eea82c0b63
 URL:           https://github.com/atom/electron
-BuildRequires: unzip
+BuildRequires: git-core
+BuildRequires: ncurses
+BuildRequires: npm
 ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -29,29 +28,30 @@ and Chromium and is used in the Atom editor.
 
 %prep
 %setup -qcT
+git clone https://github.com/atom/electron.git -b v%{version} --depth 1 .
+
+./script/bootstrap.py -v
 
-%ifarch %{ix86}
-unzip %{SOURCE1}
-%endif
-%ifarch %{x8664}
-unzip %{SOURCE2}
-%endif
+install -d lib
+ln -s %{_libdir}/libncurses.so.5 lib/libtinfo.so.5
 
 %build
+export LD_LIBRARY_PATH=`pwd`/lib
+
+./script/build.py -c R
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 # make install repeatable
-rm -f debug*.list 2>/dev/null || :
+rm -f debug*.list
 
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}}
-cp -a * $RPM_BUILD_ROOT%{_libdir}/%{name}
-
-rm $RPM_BUILD_ROOT%{_libdir}/%{name}/LICENSE*
-rm $RPM_BUILD_ROOT%{_libdir}/%{name}/libgcrypt*
+cp -a . $RPM_BUILD_ROOT%{_libdir}/%{name}
+ln -s %{_libdir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
 
-ln -sf %{_libdir}/%{name}/%{name} $RPM_BUILD_ROOT%{_bindir}/%{name}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/LICENSE*
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/libgcrypt*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
This page took 0.187166 seconds and 4 git commands to generate.