]> git.pld-linux.org Git - packages/ekg.git/blobdiff - ekg.spec
- one tab too much in bcond description for pthread
[packages/ekg.git] / ekg.spec
index 042a79cf67e8ff279243bf141945dd43f66844e6..281b19bf8c02d49dd432b90adec4fb1b2bf1557b 100644 (file)
--- a/ekg.spec
+++ b/ekg.spec
@@ -1,11 +1,13 @@
 #
 # Conditional build:
+%bcond_without aspell          # without spell checking
 %bcond_without voip            # without VoIP support
-%bcond_with    python          # with python support
+%bcond_without python          # with python support
+%bcond_with    pthread         # build with Posix threads support
 %bcond_with    ioctl_daemon    # with ioctl_daemon (suid root)
 #
-%define snap    20040417
-
+%define                _snap   20050318
+#
 Summary:       A client compatible with Gadu-Gadu
 Summary(de):   Ein Cliente kompatibel mit Gadu-Gadu
 Summary(es):   Un cliente compatible con Gadu-Gadu
@@ -13,15 +15,15 @@ Summary(it):        Un cliente compatibile con Gadu-Gadu
 Summary(pl):   Klient kompatybilny z Gadu-Gadu
 Name:          ekg
 Version:       1.5
-Release:       0.%{snap}.1
+Release:       6.%{_snap}.1
 Epoch:         4
 License:       GPL v2
 Group:         Applications/Communications
-Source0:       http://dev.null.pl/ekg/%{name}-%{snap}.tar.gz
-# Source0-md5: 0d6cded4ff4883a2c4dc8b2cd7fa92f6
+Source0:       http://dev.null.pl/ekg/%{name}-%{_snap}.tar.gz
+# Source0-md5: a25337b88263f808d2044e3f3b33673c
 Source1:       %{name}.conf
-Patch0:                %{name}-kadu-0_3_6.patch
 URL:           http://dev.null.pl/ekg/
+%{?with_aspell:BuildRequires:  aspell-devel}
 BuildRequires: autoconf
 BuildRequires: automake
 %{?with_voip:BuildRequires:    libgsm-devel}
@@ -35,7 +37,22 @@ BuildRequires:       zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-A client compatible with Gadu-Gadu.
+EKG ("Eksperymentalny Klient Gadu-Gadu") is an open source gadu-gadu
+client for UNIX systems. Gadu-Gadu is an instant messaging program,
+very popular in Poland.
+
+EKG features include:
+  - irssi-like ncurses interface
+  - sending and receiving files
+  - voice conversations
+  - launching shell commands on certain events
+  - reading input from pipe
+  - python scripting support
+  - speech synthesis (using an external program)
+  - encryption support
+
+Please note that the program is not internationalized and all messages
+are in Polish (although the commands are in English). 
 
 %description -l de
 Ein Cliente kompatibel mit Gadu-Gadu.
@@ -47,7 +64,22 @@ Un cliente compatible con Gadu-Gadu.
 Un cliente compatibile con Gadu-Gadu.
 
 %description -l pl
-Klient kompatybilny z Gadu-Gadu.
+EKG ("Eksperymentalny Klient Gadu-Gadu") jest open source'owym
+klientem gadu-gadu dla systemów uniksowych. Gadu-Gadu to popularny w
+polsce komunikator internetowy.
+
+Mo¿liwo¶ci EKG:
+  - interfejs u¿ytkownika podobny do irssi,
+  - wysy³anie i odbieranie plików,
+  - rozmowy g³osowe,
+  - uruchamianie poleceñ pow³oki w okre¶lonych sytuacjach,
+  - wczytywanie wej¶cia z potoku,
+  - wsparcie dla skryptów w jêzyku Python,
+  - synteza mowy (z u¿yciem zewnêtrznego programu),
+  - wsparcie dla szyfrowania.
+
+Program nie jest umiêdzynarodowiony i wszystkie komunikaty s± po
+polsku (jednak komendy s± w jêzyku angielskim).
 
 %package -n libgadu
 Summary:       libgadu library
@@ -79,7 +111,7 @@ Summary(es): Biblioteca de desarrollo de libgadu
 Summary(pl):   Czê¶æ biblioteki libgadu dla programistów
 License:       LGPL v2.1
 Group:         Development/Libraries
-Requires:      libgadu = %{epoch}:%{version}
+Requires:      libgadu = %{epoch}:%{version}-%{release}
 Requires:      openssl-devel
 Obsoletes:     libgg-devel
 
@@ -107,7 +139,7 @@ Summary(es):        Biblioteca libgadu est
 Summary(pl):   Statyczna biblioteka libgadu
 License:       LGPL v2.1
 Group:         Development/Libraries
-Requires:      libgadu-devel = %{epoch}:%{version}
+Requires:      libgadu-devel = %{epoch}:%{version}-%{release}
 Obsoletes:     libgg-static
 
 %description -n libgadu-static
@@ -123,8 +155,7 @@ Biblioteca libgadu est
 Statyczna biblioteka libgadu.
 
 %prep
-%setup -q -n %{name}-%{snap}
-#%patch0 -p1
+%setup -q -n %{name}-%{_snap}
 
 %build
 rm -f missing
@@ -134,14 +165,19 @@ rm -f missing
 %configure \
        --enable-shared \
        --enable-static \
+%if %{with pthread}
        --with-pthread \
+%else
+       --without-pthread \
+%endif
        --without-bind \
        %{?with_python:--with-python} \
        %{!?with_voip:--without-libgsm} \
-       %{!?with_ioctl_daemon:--disable-ioctld}
+       %{?with_aspell:--enable-aspell} \
+       %{?with_ioctl_daemon:--enable-ioctld}
 
 %{__make} \
-       CC="%{__cc} %{rpmcflags} -Wall -I/usr/include/ncurses"
+       CC="%{__cc} %{rpmcflags} -Wall -I%{_includedir}/ncurses"
 
 %if %{with ioctl_daemon}
 %{__make} -C src ioctld
@@ -158,11 +194,11 @@ install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
 
 # For libgadu-devel
 
-rm examples/Makefile examples/Makefile.in examples/.cvsignore
-rm -r examples/CVS
+rm -f examples/Makefile examples/Makefile.in examples/.cvsignore
+rm -rf examples/CVS
 
 install -d $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
-mv examples/* $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
+cp -af examples/* $RPM_BUILD_ROOT%{_examplesdir}/libgadu-%{version}
 
 %if %{with ioctl_daemon}
 install src/ioctld $RPM_BUILD_ROOT%{_bindir}
@@ -180,6 +216,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc docs/{7thguard,dcc,files,gdb,python,sim,themes,ui-ncurses,vars,voip}.txt
+%{?with_aspell:%doc docs/slownik.txt}
 %doc ChangeLog docs/{FAQ,README,TODO,ULOTKA} docs/emoticons.{ansi,sample}
 %attr(755,root,root) %{_bindir}/e*
 %{?with_ioctl_daemon:%attr(4755,root,root) %{_bindir}/ioctld}
@@ -196,13 +233,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc docs/{7thguard,ui,devel-hints,przenosny-kod}.txt docs/protocol.html
 %doc ChangeLog docs/{README,TODO}
-%{_libdir}/libgadu.so
+%attr(755,root,root) %{_libdir}/libgadu.so
 %{_includedir}/libgadu.h
 %{_includedir}/libgadu-config.h
 %{_pkgconfigdir}/*
-%dir %{_examplesdir}/libgadu-%{version}
-%{_examplesdir}/libgadu-%{version}/*
+%{_examplesdir}/libgadu-%{version}
 
 %files -n libgadu-static
 %defattr(644,root,root,755)
-%attr(644,root,root) %{_libdir}/libgadu.a
+%{_libdir}/libgadu.a
This page took 0.02829 seconds and 4 git commands to generate.