]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
up to 7.83.0
[packages/curl.git] / curl.spec
index cf4463c9ab2743639818c439b08ef8fa0c5dddd8..f1f72feef7896a48e24cdb5f84034ca55eca8d61 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,4 +1,4 @@
-# TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
+# TODO: ngtpc2/nghttp3 or quiche or msh3 for HTTP3?
 #
 # Conditional build:
 %bcond_without ssh             # SSH support
@@ -8,6 +8,7 @@
 %bcond_without kerberos5       # Heimdal Kerberos 5 support
 %bcond_without ldap            # LDAP support
 %bcond_without http2           # HTTP/2.0 support (nghttp2 based)
+%bcond_with    http3           # HTTP/3.0 support (nghttp3/ngtcp2 based)
 %if "%{pld_release}" != "ac"
 %bcond_without ares            # c-ares (asynchronous DNS operations) library support
 %bcond_without rtmp            # Real Time Media Protocol support
@@ -23,18 +24,18 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.79.1
-Release:       2
+Version:       7.83.0
+Release:       1
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       https://curl.haxx.se/download/%{name}-%{version}.tar.xz
-# Source0-md5: 74d3c4ca8aaa6c0619806d6e246e65fb
+# Source0-md5: b7924acdea33dedc3150a044789ed0bb
 Patch0:                %{name}-ac.patch
 Patch1:                %{name}-krb5flags.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
-%{?with_ares:BuildRequires:    c-ares-devel >= 1.7.0}
+%{?with_ares:BuildRequires:    c-ares-devel >= 1.17.0}
 %{?with_gsasl:BuildRequires:   gsasl-devel}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: libbrotli-devel >= 1.0.0
@@ -45,6 +46,9 @@ BuildRequires:        libpsl-devel
 BuildRequires: libtool
 BuildRequires: nettle-devel
 %{?with_http2:BuildRequires:   nghttp2-devel >= 1.12.0}
+%{?with_http3:BuildRequires:   nghttp3-devel}
+# with gnutls or openssl crypto, conforming to chosen curl crypto library
+%{?with_http3:BuildRequires:   ngtcp2-devel}
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
@@ -118,7 +122,7 @@ curl п╕дтриму╓ багато корисних можливостей,
 Summary:       curl library
 Summary(pl.UTF-8):     Biblioteka curl
 Group:         Libraries
-%{?with_ares:Requires: c-ares >= 1.7.0}
+%{?with_ares:Requires: c-ares >= 1.17.0}
 %{?with_gnutls:Requires:       gnutls-libs >= 3.1.10}
 %{?with_ssh:Requires:  libssh2 >= 1.2.8}
 %{?with_http2:Requires:        nghttp2-libs >= 1.12.0}
@@ -252,6 +256,7 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
        ac_cv_header_gss_h=no \
        %{__enable_disable ares} \
        %{__enable_disable gsasl} \
+       --enable-headers-api \
        --enable-ipv6 \
        %{__enable_disable ldap} \
        %{__enable_disable ldap ldaps} \
@@ -270,6 +275,8 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
        %{__with_without kerberos5 gssapi %{_prefix}} \
        %{__with_without rtmp librtmp} \
        %{__with_without http2 nghttp2} \
+       %{__with_without http3 nghttp3} \
+       %{__with_without http3 ngtcp2} \
        %{__with_without ssh libssh2}
 
 %{__make}
@@ -321,6 +328,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/CURLINFO_*.3*
 %{_mandir}/man3/CURLOPT_*.3*
 %{_mandir}/man3/CURLMOPT_*.3*
+%{_mandir}/man3/CURLSHOPT_*.3*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.039929 seconds and 4 git commands to generate.