]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
up to 7.83.0
[packages/curl.git] / curl.spec
index 5c1a3abde46a9278f3e46e448e44f30ffbba7ca9..f1f72feef7896a48e24cdb5f84034ca55eca8d61 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,4 +1,4 @@
-# TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
+# TODO: ngtpc2/nghttp3 or quiche or msh3 for HTTP3?
 #
 # Conditional build:
 %bcond_without ssh             # SSH support
@@ -8,7 +8,7 @@
 %bcond_without kerberos5       # Heimdal Kerberos 5 support
 %bcond_without ldap            # LDAP support
 %bcond_without http2           # HTTP/2.0 support (nghttp2 based)
-%bcond_without metalink        # metalink support
+%bcond_with    http3           # HTTP/3.0 support (nghttp3/ngtcp2 based)
 %if "%{pld_release}" != "ac"
 %bcond_without ares            # c-ares (asynchronous DNS operations) library support
 %bcond_without rtmp            # Real Time Media Protocol support
@@ -24,29 +24,31 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.77.0
+Version:       7.83.0
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       https://curl.haxx.se/download/%{name}-%{version}.tar.xz
-# Source0-md5: 3cf78c539cae019cf96ba38571706e06
+# Source0-md5: b7924acdea33dedc3150a044789ed0bb
 Patch0:                %{name}-ac.patch
 Patch1:                %{name}-krb5flags.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
-%{?with_ares:BuildRequires:    c-ares-devel >= 1.7.0}
+%{?with_ares:BuildRequires:    c-ares-devel >= 1.17.0}
 %{?with_gsasl:BuildRequires:   gsasl-devel}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: libbrotli-devel >= 1.0.0
 BuildRequires: libidn2-devel
-%{?with_metalink:BuildRequires:        libmetalink-devel >= 0.1.0}
 BuildRequires: libpsl-devel
 %{?with_rtmp:BuildRequires:    librtmp-devel}
 %{?with_ssh:BuildRequires:     libssh2-devel >= 1.2.8}
 BuildRequires: libtool
 BuildRequires: nettle-devel
 %{?with_http2:BuildRequires:   nghttp2-devel >= 1.12.0}
+%{?with_http3:BuildRequires:   nghttp3-devel}
+# with gnutls or openssl crypto, conforming to chosen curl crypto library
+%{?with_http3:BuildRequires:   ngtcp2-devel}
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
@@ -120,7 +122,7 @@ curl п╕дтриму╓ багато корисних можливостей,
 Summary:       curl library
 Summary(pl.UTF-8):     Biblioteka curl
 Group:         Libraries
-%{?with_ares:Requires: c-ares >= 1.7.0}
+%{?with_ares:Requires: c-ares >= 1.17.0}
 %{?with_gnutls:Requires:       gnutls-libs >= 3.1.10}
 %{?with_ssh:Requires:  libssh2 >= 1.2.8}
 %{?with_http2:Requires:        nghttp2-libs >= 1.12.0}
@@ -254,6 +256,7 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
        ac_cv_header_gss_h=no \
        %{__enable_disable ares} \
        %{__enable_disable gsasl} \
+       --enable-headers-api \
        --enable-ipv6 \
        %{__enable_disable ldap} \
        %{__enable_disable ldap ldaps} \
@@ -261,18 +264,19 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
 %if %{with ssl}
        --with-ca-bundle=/etc/certs/ca-certificates.crt \
 %if %{with gnutls}
-       --with-gnutls --without-ssl \
+       --with-gnutls --without-openssl \
 %else
-       --with-ssl=%{_prefix} \
+       --with-openssl=%{_prefix} \
 %endif
 %else
-       --without-ssl --without-gnutls \
+       --without-ssl \
 %endif
        --with-fish-functions-dir=%{fish_compdir} \
        %{__with_without kerberos5 gssapi %{_prefix}} \
-       %{__with_without metalink libmetalink} \
        %{__with_without rtmp librtmp} \
        %{__with_without http2 nghttp2} \
+       %{__with_without http3 nghttp3} \
+       %{__with_without http3 ngtcp2} \
        %{__with_without ssh libssh2}
 
 %{__make}
@@ -324,6 +328,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/CURLINFO_*.3*
 %{_mandir}/man3/CURLOPT_*.3*
 %{_mandir}/man3/CURLMOPT_*.3*
+%{_mandir}/man3/CURLSHOPT_*.3*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.04481 seconds and 4 git commands to generate.