]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
up to 7.79.0 (fixes CVE-2021-22945 CVE-2021-22946 CVE-2021-22947)
[packages/curl.git] / curl.spec
index 63f3e232e03249d0579384c85912a5c213f8ec1f..160dcd43314597fcfb9f9eb8ef54d87294c15310 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -4,10 +4,10 @@
 %bcond_without ssh             # SSH support
 %bcond_without ssl             # SSL support
 %bcond_with    gnutls          # GnuTLS instead of OpenSSL
+%bcond_without gsasl           # SCRAM support with gsasl
 %bcond_without kerberos5       # Heimdal Kerberos 5 support
 %bcond_without ldap            # LDAP support
 %bcond_without http2           # HTTP/2.0 support (nghttp2 based)
-%bcond_without metalink        # metalink support
 %if "%{pld_release}" != "ac"
 %bcond_without ares            # c-ares (asynchronous DNS operations) library support
 %bcond_without rtmp            # Real Time Media Protocol support
@@ -23,22 +23,22 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.71.1
+Version:       7.79.0
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       https://curl.haxx.se/download/%{name}-%{version}.tar.xz
-# Source0-md5: b54b386057846ce3edd3584b19741569
+# Source0-md5: 24408ce0068de0ae7871039451ad6f97
 Patch0:                %{name}-ac.patch
 Patch1:                %{name}-krb5flags.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 %{?with_ares:BuildRequires:    c-ares-devel >= 1.7.0}
+%{?with_gsasl:BuildRequires:   gsasl-devel}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: libbrotli-devel >= 1.0.0
 BuildRequires: libidn2-devel
-%{?with_metalink:BuildRequires:        libmetalink-devel >= 0.1.0}
 BuildRequires: libpsl-devel
 %{?with_rtmp:BuildRequires:    librtmp-devel}
 %{?with_ssh:BuildRequires:     libssh2-devel >= 1.2.8}
@@ -48,6 +48,7 @@ BuildRequires:        nettle-devel
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 1.527
 %if %{with ssl}
 %if %{with gnutls}
@@ -57,7 +58,9 @@ BuildRequires:        openssl-devel >= 1.0.1
 %endif
 %endif
 BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 BuildRequires: zlib-devel
+BuildRequires: zstd-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -141,6 +144,7 @@ Summary(uk.UTF-8):  Файли для розробки з використанн
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 %{?with_ares:Requires: c-ares-devel}
+%{?with_gsasl:Requires:        gsasl-devel}
 %{?with_kerberos5:Requires:    heimdal-devel}
 Requires:      libbrotli-devel >= 1.0.0
 Requires:      libidn2-devel
@@ -157,6 +161,7 @@ Requires:   openssl-devel >= 0.9.7c
 %endif
 %endif
 Requires:      zlib-devel
+Requires:      zstd-devel
 Obsoletes:     libcurl2-devel
 
 %description devel
@@ -208,6 +213,7 @@ Summary(pl.UTF-8):  Dopełnianie parametrów w fish dla polecenia curl
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      fish
+BuildArch:     noarch
 
 %description -n fish-completion-%{name}
 Fish completion for curl command.
@@ -221,6 +227,7 @@ Summary(pl.UTF-8):  Dopełnianianie parametrów w ZSH dla polecenia curl
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      zsh
+BuildArch:     noarch
 
 %description -n zsh-completion-curl
 ZSH completion for curl command.
@@ -244,6 +251,7 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
 %configure \
        ac_cv_header_gss_h=no \
        %{__enable_disable ares} \
+       %{__enable_disable gsasl} \
        --enable-ipv6 \
        %{__enable_disable ldap} \
        %{__enable_disable ldap ldaps} \
@@ -251,16 +259,15 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
 %if %{with ssl}
        --with-ca-bundle=/etc/certs/ca-certificates.crt \
 %if %{with gnutls}
-       --with-gnutls --without-ssl \
+       --with-gnutls --without-openssl \
 %else
-       --with-ssl=%{_prefix} \
+       --with-openssl=%{_prefix} \
 %endif
 %else
-       --without-ssl --without-gnutls \
+       --without-ssl \
 %endif
        --with-fish-functions-dir=%{fish_compdir} \
        %{__with_without kerberos5 gssapi %{_prefix}} \
-       %{__with_without metalink libmetalink} \
        %{__with_without rtmp librtmp} \
        %{__with_without http2 nghttp2} \
        %{__with_without ssh libssh2}
@@ -269,12 +276,16 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__make} -C scripts install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcurl.la
+
 # no longer in upstream but a lot of apps tries to include it so we create fake one
 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
@@ -287,7 +298,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting}
+%doc CHANGES COPYING README docs/{BUGS.md,FAQ,FEATURES.md,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting.md}
 %attr(755,root,root) %{_bindir}/curl
 %{_mandir}/man1/curl.1*
 
@@ -298,10 +309,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%doc docs/{CONTRIBUTE.md,INTERNALS.md,LICENSE-MIXING.md,RESOURCES}
+%doc docs/{CONTRIBUTE.md,INTERNALS.md}
 %attr(755,root,root) %{_bindir}/curl-config
 %attr(755,root,root) %{_libdir}/libcurl.so
-%{_libdir}/libcurl.la
 %{_includedir}/curl
 %{_pkgconfigdir}/libcurl.pc
 %{_aclocaldir}/libcurl.m4
@@ -318,7 +328,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n fish-completion-%{name}
 %defattr(644,root,root,755)
-%{fish_compdir}/%{name}.fish
+%{fish_compdir}/curl.fish
 
 %files -n zsh-completion-curl
 %defattr(644,root,root,755)
This page took 0.080637 seconds and 4 git commands to generate.