]> git.pld-linux.org Git - packages/clementine.git/blobdiff - clementine.spec
rebuild with built in debug
[packages/clementine.git] / clementine.spec
index d3ae25d828ec3acf69db998b91e5cb25bc8a2b6b..2ef78289f9a071887e5fc82ee18d5ebb67f63a2c 100644 (file)
@@ -1,17 +1,25 @@
 # TODO:
 # - Gstreamer error: "A text/uri-list decoder plugin is required to play this stream, but not installed."
 # - apply patches to libprojectM.spec and use
+# - checking for module 'libspotify>=12.1.45' - Spotify support: non-GPL binary helper (missing libspotify)
+# - checking for module 'libchromaprint'
+# - Google Drive support (missing Google sparsehash)
+# - package for kde4 stuff (or nuke them):
+#        /usr/share/kde4/services/clementine-feed.protocol
+#        /usr/share/kde4/services/clementine-itms.protocol
+#        /usr/share/kde4/services/clementine-itpc.protocol
+#        /usr/share/kde4/services/clementine-zune.protocol
 #
 # Conditional build:
 %bcond_without static_sqlite   # with static sqlite3
 %bcond_with    static_projectm # with static projectM
 
-%define        qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
+%define                qtver   %(pkg-config --silence-errors --modversion QtCore 2>/dev/null || echo ERROR)
 Summary:       A music player and library organiser
 Summary(hu.UTF-8):     Egy zenelejátszó és gyűjtemény-kezelő
 Name:          clementine
 Version:       1.1.1
-Release:       3
+Release:       5
 License:       GPL v3 and GPL v2+
 Group:         Applications/Multimedia
 URL:           http://www.clementine-player.org/
@@ -102,11 +110,15 @@ rm -rf 3rdparty/qtiocompressor
 sed -i -e '/add_subdirectory(tests)/d' CMakeLists.txt
 # remove -Wall
 sed -i -e 's/-Wall//' src/CMakeLists.txt
+# ...and -Werror
+sed -i -e 's/-Werror//' src/CMakeLists.txt
 
 %build
 install -d build
 install -d build/src/translations
 cd build
+# as our buildtype is not Release, need to pass these manually. see CMakeLists.txt ~125
+CXXFLAGS="%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG_OUTPUT"
 %cmake \
        -DBUNDLE_PROJECTM_PRESETS=OFF \
        -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON \
This page took 0.051347 seconds and 4 git commands to generate.