]> git.pld-linux.org Git - packages/chef.git/blobdiff - chef.spec
up to 11.8.2
[packages/chef.git] / chef.spec
index 493ff5afd3daa299895f43e419fc142c226765ec..92e8dcdf56da7fce136a6210cd1cd6e105e09589 100644 (file)
--- a/chef.spec
+++ b/chef.spec
@@ -1,26 +1,31 @@
 #
+# NOTE:
+# - check releases here: https://github.com/opscode/chef/releases
+
 # Conditional build:
 %bcond_with    tests           # build without tests
 
 Summary:       A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure
 Name:          chef
 Version:       11.8.2
-Release:       0.14
+Release:       0.15
 License:       Apache v2.0
 Group:         Development/Languages
 Source0:       http://rubygems.org/downloads/%{name}-%{version}.gem
 # Source0-md5: 7d3c2e8b98ec8df050d92686f1429d8f
 Source1:       %{name}.rb
 Source2:       %{name}.tmpfiles
+Source3:       https://raw.github.com/stevendanna/knife-hacks/master/shell/knife_completion.sh
+# Source3-md5: a4c1e41370be8088a59ddb3b2e7ea397
 Patch0:                platform-pld.patch
 Patch1:                FHS.patch
 Patch2:                https://github.com/glensc/chef/compare/poldek.patch
 # Patch2-md5:  5a0fc35de33910b41cba4e87dcb4bf9a
 Patch3:                https://github.com/glensc/chef/compare/pld-knife-boostrap.patch
 # Patch3-md5:  bfc884469fad7b5aa46341402be5fccd
-URL:           http://wiki.opscode.com/display/chef
+URL:           https://wiki.opscode.com/display/chef/
 BuildRequires: rpm-rubyprov
-BuildRequires: rpmbuild(macros) >= 1.656
+BuildRequires: rpmbuild(macros) >= 1.673
 BuildRequires: sed >= 4.0
 %if %{with tests}
 BuildRequires: ruby-abstract
@@ -39,6 +44,7 @@ BuildRequires:        ruby-rspec-mocks >= 2.13.0
 #BuildRequires:        ruby-rspec_junit_formatter
 #BuildRequires:        ruby-sdoc
 %endif
+Requires:      iproute2
 Requires:      lsb-release
 Requires:      poldek >= 0.30
 Requires:      ruby >= 1:1.9.3.429-4
@@ -74,6 +80,19 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 A systems integration framework, built to bring the benefits of
 configuration management to your entire infrastructure.
 
+%package -n bash-completion-knife
+Summary:       bash-completion for knife
+Summary(pl.UTF-8):     bashowe uzupełnianie nazw dla knifea
+Group:         Applications/Shells
+Requires:      %{name} >= 0.10
+Requires:      bash-completion >= 2.0
+
+%description -n bash-completion-knife
+This package provides bash-completion for knife.
+
+%description -n bash-completion-knife -l pl.UTF-8
+Pakiet ten dostarcza bashowe uzupełnianie nazw dla knifea.
+
 %package -n knife
 Summary:       knife - Chef Server API client utility
 Group:         Development/Languages
@@ -104,7 +123,7 @@ rspec spec
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir},%{_mandir}/man1,%{systemdtmpfilesdir}} \
-       $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments}}}
+       $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},/var/{run/%{name},cache/%{name},lib/%{name}/{roles,data_bags,environments,backup}}}
 
 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
@@ -114,6 +133,9 @@ cp -a distro/common/man/* $RPM_BUILD_ROOT%{_mandir}
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/chef.rb
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
 
+install -d $RPM_BUILD_ROOT%{bash_compdir}
+cp -p %{SOURCE3} $RPM_BUILD_ROOT%{bash_compdir}/knife
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -182,3 +204,16 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/knife-user.1*
 %{_mandir}/man1/knife-xargs.1*
 %{_mandir}/man1/knife.1*
+
+%dir /var/lib/%{name}
+%dir /var/lib/%{name}/roles
+%dir /var/lib/%{name}/data_bags
+%dir /var/lib/%{name}/environments
+%dir %attr(750,root,root) /var/lib/%{name}/backup
+
+%dir /var/cache/%{name}
+%dir /var/run/%{name}
+
+%files -n bash-completion-knife
+%defattr(644,root,root,755)
+%{bash_compdir}/knife
This page took 0.117074 seconds and 4 git commands to generate.