]> git.pld-linux.org Git - packages/boa.git/blobdiff - boa.spec
- patch for 0.94.12pre1
[packages/boa.git] / boa.spec
index eb785d74d6e463e33a2cb0697f860cf9bf717a0b..fff40e61636e0b6e22dc7944b2d1c04f3555fe74 100644 (file)
--- a/boa.spec
+++ b/boa.spec
@@ -1,7 +1,7 @@
 Summary:       Boa high speed HTTP server
 Summary(pl):   Boa - szybki serwer HTTP
 Name:          boa
-Version:       0.94.8.3
+Version:       0.94.9
 Release:       2
 License:       GPL
 Group:         Networking/Daemons
@@ -17,9 +17,11 @@ Prereq:              %{_sbindir}/groupadd
 Prereq:                %{_sbindir}/groupdel
 Prereq:                %{_sbindir}/useradd
 Prereq:                %{_sbindir}/userdel
+Prereq:                rc-scripts
+Prereq:                /sbin/chkconfig
 BuildRequires: flex
 BuildRequires: sgml-tools
-Prereq:                rc-scripts
+BuildRequires: autoconf
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     apache
 
@@ -45,6 +47,7 @@ systemowych.
 %build
 cd src
 CFLAGS="%{rpmcflags} -DINET6"
+autoconf
 %configure
 %{__make}
 (cd ../docs; make boa.html )
@@ -73,18 +76,49 @@ gzip -9nf README
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-GROUP=http; GID=51; %groupadd
-USER=http; UID=51; HOMEDIR=/home/httpd; COMMENT="HTTP User"; %useradd
+if [ -n "`getgid http`" ]; then
+        if [ "`getgid http`" != "51" ]; then
+                echo "Warning:group http haven't gid=51. Correct this before install boa" 1>&2
+                exit 1
+        fi
+else
+       echo "Creating group http GID=51"
+        /usr/sbin/groupadd -g 51 -r -f http
+fi
+if [ -n "`id -u http 2>/dev/null`" ]; then
+        if [ "`id -u http`" != "51" ]; then
+                echo "Warning:user http haven't uid=51. Correct this before install boa" 1>&2
+                exit 1
+        fi
+else
+       echo "Creating user http UID=51"
+        /usr/sbin/useradd -u 51 -r -d /home/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
+fi
 
 %postun
-USER=http; %userdel
-GROUP=http; %groupdel
+if [ "$1" = "0" ]; then
+       echo "Removing user http UID=51"
+       %{_sbindir}/userdel http > /dev/null 2>&1
+       echo "Removing group http GID=51"
+       %{_sbindir}/groupdel http > /dev/null 2>&1
+fi
 
 %post
-DESC="boa http daemon"; %chkconfig_post
+/sbin/chkconfig --add %{name}
+
+if [ -f /var/lock/subsys/httpd ]; then
+        /etc/rc.d/init.d/httpd restart 1>&2
+else
+        echo "Run \"/etc/rc.d/init.d/boa start\" to start boa http daemon."
+fi
 
 %preun
-%chkconfig_preun
+if [ "$1" = "0" ]; then
+        if [ -f /var/lock/subsys/boa ]; then
+                /etc/rc.d/init.d/boa stop 1>&2
+        fi
+        /sbin/chkconfig --del boa
+fi
 
 %files
 %defattr(644,root,root,755)
This page took 0.043144 seconds and 4 git commands to generate.