]> git.pld-linux.org Git - packages/boa.git/blobdiff - boa.spec
- patch for 0.94.12pre1
[packages/boa.git] / boa.spec
index acd2bfae4376936678232787d3d47f606c9e9988..fff40e61636e0b6e22dc7944b2d1c04f3555fe74 100644 (file)
--- a/boa.spec
+++ b/boa.spec
@@ -1,8 +1,8 @@
 Summary:       Boa high speed HTTP server
 Summary(pl):   Boa - szybki serwer HTTP
 Name:          boa
-Version:       0.94.8.3
-Release:       1
+Version:       0.94.9
+Release:       2
 License:       GPL
 Group:         Networking/Daemons
 Group(de):     Netzwerkwesen/Server
@@ -17,9 +17,11 @@ Prereq:              %{_sbindir}/groupadd
 Prereq:                %{_sbindir}/groupdel
 Prereq:                %{_sbindir}/useradd
 Prereq:                %{_sbindir}/userdel
+Prereq:                rc-scripts
+Prereq:                /sbin/chkconfig
 BuildRequires: flex
 BuildRequires: sgml-tools
-Requires:      rc-scripts
+BuildRequires: autoconf
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     apache
 
@@ -44,7 +46,8 @@ systemowych.
 
 %build
 cd src
-CFLAGS="%{?debug:-O -g}%{!?debug:$RPM_OPT_FLAGS} -DINET6"
+CFLAGS="%{rpmcflags} -DINET6"
+autoconf
 %configure
 %{__make}
 (cd ../docs; make boa.html )
@@ -73,17 +76,41 @@ gzip -9nf README
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-%{_sbindir}/groupadd -g 51 -f http > /dev/null 2>&1
-%{_sbindir}/useradd -u 51 -f http -g http > /dev/null 2>&1
+if [ -n "`getgid http`" ]; then
+        if [ "`getgid http`" != "51" ]; then
+                echo "Warning:group http haven't gid=51. Correct this before install boa" 1>&2
+                exit 1
+        fi
+else
+       echo "Creating group http GID=51"
+        /usr/sbin/groupadd -g 51 -r -f http
+fi
+if [ -n "`id -u http 2>/dev/null`" ]; then
+        if [ "`id -u http`" != "51" ]; then
+                echo "Warning:user http haven't uid=51. Correct this before install boa" 1>&2
+                exit 1
+        fi
+else
+       echo "Creating user http UID=51"
+        /usr/sbin/useradd -u 51 -r -d /home/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
+fi
 
 %postun
 if [ "$1" = "0" ]; then
+       echo "Removing user http UID=51"
        %{_sbindir}/userdel http > /dev/null 2>&1
+       echo "Removing group http GID=51"
        %{_sbindir}/groupdel http > /dev/null 2>&1
 fi
 
 %post
-/sbin/chkconfig -add %{name}
+/sbin/chkconfig --add %{name}
+
+if [ -f /var/lock/subsys/httpd ]; then
+        /etc/rc.d/init.d/httpd restart 1>&2
+else
+        echo "Run \"/etc/rc.d/init.d/boa start\" to start boa http daemon."
+fi
 
 %preun
 if [ "$1" = "0" ]; then
This page took 0.057114 seconds and 4 git commands to generate.