]> git.pld-linux.org Git - packages/boa.git/blobdiff - boa.spec
- removed http group - working fine on my server
[packages/boa.git] / boa.spec
index 4144b57ec73fba9fb99e6cb8ea5fb628e466118e..b0c6d7a046b3fe4da4abe68e7bb5f6c66c458512 100644 (file)
--- a/boa.spec
+++ b/boa.spec
@@ -1,27 +1,37 @@
+#
+# Conditional build:
+# _without_ipv6        - IPv4-only version (doesn't require IPv6 in kernel)
+#
 Summary:       Boa high speed HTTP server
 Summary(pl):   Boa - szybki serwer HTTP
 Name:          boa
-Version:       0.94.8.3
-Release:       1
-License:       GPL
+Version:       0.94.12
+Release:       3
+Epoch:         1
+License:       GPL v2
 Group:         Networking/Daemons
-Group(de):     Netzwerkwesen/Server
-Group(pl):     Sieciowe/Serwery
 Source0:       http://www.boa.org/%{name}-%{version}.tar.gz
 Source1:       %{name}.init
 Patch0:                %{name}-PLD.patch
-Provides:      httpd                                                           
-Provides:      webserver                                                       
-Prereq:                sh-utils
-Prereq:                %{_sbindir}/groupadd
-Prereq:                %{_sbindir}/groupdel
-Prereq:                %{_sbindir}/useradd
-Prereq:                %{_sbindir}/userdel
+Patch1:                %{name}-logrotate.patch
+URL:           http://www.boa.org/
+BuildRequires: autoconf
 BuildRequires: flex
 BuildRequires: sgml-tools
-Requires:      rc-scripts
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+PreReq:                rc-scripts
+Requires(pre): /bin/id
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(post,preun):  /sbin/chkconfig
+Provides:      httpd
+Provides:      webserver
 Obsoletes:     apache
+Obsoletes:     httpd
+Obsoletes:     thttpd
+Obsoletes:     webserver
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/httpd
 
@@ -41,49 +51,68 @@ systemowych.
 %prep
 %setup -q
 %patch0 -p1
+%patch1        -p0
 
 %build
 cd src
-CFLAGS="%{?debug:-O0 -g}%{!?debug:$RPM_OPT_FLAGS} -DINET6"
+CFLAGS="%{rpmcflags} %{!?_without_ipv6:-DINET6}"
+%{__autoconf}
 %configure
 %{__make}
-(cd ../docs; make boa.html )
+cd ../docs
+%{__make} boa.html
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,/var/log/httpd} \
+install -d $RPM_BUILD_ROOT/etc/rc.d/init.d/ \
+       $RPM_BUILD_ROOT/var/log/httpd \
        $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html} \
-       $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8}
+       $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8} \
+       $RPM_BUILD_ROOT/etc/logrotate.d
+
 
-install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}
+install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}/
 
-install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
-install examples/resolver.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
+install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin/
+install examples/* $RPM_BUILD_ROOT/home/httpd/cgi-bin/
 install        %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 
 install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
+install contrib/redhat/boa.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
 
 install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
 
 touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
 
-gzip -9nf README
+gzip -9nf README ChangeLog
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-%{_sbindir}/groupadd -g 51 -f http > /dev/null 2>&1
-%{_sbindir}/useradd -u 51 -f http -g http > /dev/null 2>&1
+if [ -n "`id -u http 2>/dev/null`" ]; then
+        if [ "`id -u http`" != "51" ]; then
+                echo "Error: user http doesn't have uid=51. Correct this before installing boa." 1>&2
+                exit 1
+        fi
+else
+       echo "Creating user http UID=51"
+        /usr/sbin/useradd -u 51 -r -d /home/httpd -s /bin/false -c "HTTP User" http 1>&2
+fi
 
 %postun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/userdel http > /dev/null 2>&1
-       %{_sbindir}/groupdel http > /dev/null 2>&1
+       echo "Removing user http UID=51"
+       /usr/sbin/userdel http > /dev/null 2>&1
 fi
 
 %post
-/sbin/chkconfig -add %{name}
+/sbin/chkconfig --add boa
+if [ -f /var/lock/subsys/boa ]; then
+        /etc/rc.d/init.d/boa restart 1>&2
+else
+        echo "Run \"/etc/rc.d/init.d/boa start\" to start boa http daemon."
+fi
 
 %preun
 if [ "$1" = "0" ]; then
@@ -95,13 +124,14 @@ fi
 
 %files
 %defattr(644,root,root,755)
-%doc README.gz docs/*.html docs/*.png docs/boa.{ps,sgml}
-%attr(750, root,http) %dir %{_sysconfdir}
-%attr(640, root,http) %config %{_sysconfdir}/*
-%attr(755, root,http) /home/httpd/html
-%attr(755, root,http) /home/httpd/cgi-bin
-%attr(750, root,http) %dir /var/log/httpd/
-%attr(640, root,http) %ghost /var/log/httpd/*
+%doc *.gz docs/*.html docs/*.png
+%attr(750, root,root) %dir %{_sysconfdir}
+%attr(640, root,root) %config(noreplace) %{_sysconfdir}/*
+%attr(640, root,root) %config(noreplace) /etc/logrotate.d/%{name}
+%attr(755, root,root) /home/httpd/html
+%attr(755, root,root) /home/httpd/cgi-bin
+%attr(750, root,root) %dir /var/log/httpd/
+%attr(640, root,root) %ghost /var/log/httpd/*
 %attr(755, root,root) %{_sbindir}/*
 %attr(754, root,root) /etc/rc.d/init.d/%{name}
 %{_mandir}/man8/*
This page took 0.05594 seconds and 4 git commands to generate.