]> git.pld-linux.org Git - packages/boa.git/blobdiff - boa.spec
- reverting last change: removing new macros from %p{re,ost}{,un}
[packages/boa.git] / boa.spec
index c10d704ef6ac44f3c3aab506f31af4f52bc50de3..19f398971b51abc3033232667e1d5440c038e468 100644 (file)
--- a/boa.spec
+++ b/boa.spec
@@ -1,38 +1,42 @@
 Summary:       Boa high speed HTTP server
 Summary(pl):   Boa - szybki serwer HTTP
 Name:          boa
-Version:       0.94.6
-Release:       1
-Copyright:     GPL
+Version:       0.94.8.3
+Release:       2
+License:       GPL
 Group:         Networking/Daemons
+Group(de):     Netzwerkwesen/Server
 Group(pl):     Sieciowe/Serwery
 Source0:       http://www.boa.org/%{name}-%{version}.tar.gz
-Source1:       boa.init
-Patch0:                boa-PLD.patch
-Provides:       httpd                                                           
-Provides:       webserver                                                       
+Source1:       %{name}.init
+Patch0:                %{name}-PLD.patch
+Provides:      httpd                                                           
+Provides:      webserver                                                       
 Prereq:                sh-utils
 Prereq:                %{_sbindir}/groupadd
 Prereq:                %{_sbindir}/groupdel
 Prereq:                %{_sbindir}/useradd
 Prereq:                %{_sbindir}/userdel
-Requires:      rc-scripts
-BuildRoot:     /tmp/%{name}-%{version}-root
+BuildRequires: flex
+BuildRequires: sgml-tools
+Prereq:                rc-scripts
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+Obsoletes:     apache
 
 %define                _sysconfdir     /etc/httpd
 
 %description
-A high speed, lightweight web server (HTTP protocol).
-Based on direct use of the select(2) system call, it internally multiplexes 
-all connections without forking, for maximum speed and minimum system 
+A high speed, lightweight web server (HTTP protocol). Based on direct
+use of the select(2) system call, it internally multiplexes all
+connections without forking, for maximum speed and minimum system
 resource use.
 
 %description -l pl
-Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP).
-Bazuje na bezpo¶rednim u¿yciu funkcji systemowej select(2)
-dziêki czemu mo¿e obs³ugiwaæ wiele po³±czeñ równocze¶nie bez
-fork()owania co w efekcie znacznie zwiêksza szybko¶æ
-dzia³ania oraz zmniejsza zu¿ycie zasobów systemowych.
+Niezwykle szybki i wysoko wydajny serwer WWW (protokó³ HTTP). Bazuje
+na bezpo¶rednim u¿yciu funkcji systemowej select(2) dziêki czemu mo¿e
+obs³ugiwaæ wiele po³±czeñ równocze¶nie bez fork()owania co w efekcie
+znacznie zwiêksza szybko¶æ dzia³ania oraz zmniejsza zu¿ycie zasobów
+systemowych.
 
 %prep
 %setup -q
@@ -40,44 +44,68 @@ dzia
 
 %build
 cd src
+CFLAGS="%{rpmcflags} -DINET6"
 %configure
-make
+%{__make}
 (cd ../docs; make boa.html )
 
 %install
+rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,/var/log/httpd} \
        $RPM_BUILD_ROOT/home/httpd/{cgi-bin,html} \
        $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/conf,%{_mandir}/man8}
 
-install -s             src/boa $RPM_BUILD_ROOT%{_sbindir}
-install -s             src/boa_indexer $RPM_BUILD_ROOT%{_sbindir}
+install src/{boa,boa_indexer} $RPM_BUILD_ROOT%{_sbindir}
+
+install src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
+install examples/resolver.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
+install        %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 
-install                        src/*.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
-install                        examples/resolver.pl $RPM_BUILD_ROOT/home/httpd/cgi-bin
-install        %{SOURCE1}      $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
+install boa.conf $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
 
-install boa.conf $RPM_BUILD_ROOT/etc/httpd/%{name}.conf
+install docs/boa.8 $RPM_BUILD_ROOT%{_mandir}/man8/
 
-install docs/boa.8     $RPM_BUILD_ROOT%{_mandir}/man8/
+touch $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
 
-touch                  $RPM_BUILD_ROOT/var/log/httpd/{access_log,agent_log,error_log,referer_log}
-gzip -9nf              README $RPM_BUILD_ROOT%{_mandir}/man*/* || :
+gzip -9nf README
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-%{_sbindir}/groupadd -g 51 -f http > /dev/null 2>&1
-%{_sbindir}/useradd -u 51 -f http -g http > /dev/null 2>&1
+if [ -n "`getgid http`" ]; then
+        if [ "`getgid http`" != "51" ]; then
+                echo "Warning:group http haven't gid=51. Correct this before install boa" 1>&2
+                exit 1
+        fi
+else
+        /usr/sbin/groupadd -g 51 -r -f http
+fi
+if [ -n "`id -u http 2>/dev/null`" ]; then
+        if [ "`id -u http`" != "51" ]; then
+                echo "Warning:user http haven't uid=51. Correct this before install boa" 1>&2
+                exit 1
+        fi
+else
+        /usr/sbin/useradd -u 51 -r -d /home/httpd -s /bin/false -c "HTTP User" -g http http 1>&2
+fi
+
 
 %postun
 if [ "$1" = "0" ]; then
-       %{_sbindir}/groupdel http > /dev/null 2>&1
        %{_sbindir}/userdel http > /dev/null 2>&1
+       %{_sbindir}/groupdel http > /dev/null 2>&1
 fi
 
 %post
-/sbin/chkconfig -add %{name}
+/sbin/chkconfig --add %{name}
+
+if [ -f /var/lock/subsys/httpd ]; then
+        /etc/rc.d/init.d/httpd restart 1>&2
+else
+        echo "Run \"/etc/rc.d/init.d/boa start\" to start boa http daemon."
+fi
+
 
 %preun
 if [ "$1" = "0" ]; then
@@ -90,8 +118,8 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc README.gz docs/*.html docs/*.png docs/boa.{ps,sgml}
-%attr(750, root,http) %dir /etc/httpd
-%attr(640, root,http) %config /etc/httpd/*
+%attr(750, root,http) %dir %{_sysconfdir}
+%attr(640, root,http) %config %{_sysconfdir}/*
 %attr(755, root,http) /home/httpd/html
 %attr(755, root,http) /home/httpd/cgi-bin
 %attr(750, root,http) %dir /var/log/httpd/
This page took 0.041949 seconds and 4 git commands to generate.