]> git.pld-linux.org Git - packages/bind.git/blobdiff - bind.spec
- up to 9.14.8; fixes CVE-2019-6477
[packages/bind.git] / bind.spec
index 0effe597768dfb8755e49b7273bc81c1bd75139a..c44d1d3d8c634f798f966cc73a610d69d63ab5a9 100644 (file)
--- a/bind.spec
+++ b/bind.spec
@@ -3,7 +3,6 @@
 #
 # Conditional build:
 %bcond_without geoip           # GeoIP support
-%bcond_without ipv6            # IPv6 support
 %bcond_without kerberos5       # GSS-API support
 %bcond_without ssl             # OpenSSL support
 %bcond_with    ldap            # LDAP DLZ support
 %bcond_without sql             # SQL (MySQL+PostgreSQL) DLZ support
 %bcond_without lmdb            # LMDB storage support for addzone zones
 %bcond_without static_libs     # static libraries
-%bcond_without tests           # perform tests
+%bcond_with    system_tests    # system tests (require root to configure localhost IPs)
+%bcond_with    tests           # unit tests
 %bcond_with    edns_cli        # ability to use edns-client-subnet in dig
 %bcond_with    hip             # HIP RR support
-%bcond_with    seccomp         # libseccomp system call filtering
 
 %if "%{pld_release}" == "ac"
 %bcond_with    epoll           # enable epoll support
 %bcond_without epoll           # disable epoll support
 %endif
 
-%define                ver     9.12.1
-%if 1
-%define                pverdot .P2
-%define                pverdir -P2
+%define                ver     9.14.8
+%if 0
+%define                pverdot .P0
+%define                pverdir -P0
 %else
 %define                pverdot %{nil}
 %define                pverdir %{nil}
@@ -51,7 +50,7 @@ Epoch:                7
 License:       MPL 2.0
 Group:         Networking/Daemons
 Source0:       ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
-# Source0-md5: 7fbefc12bd0cf891546ee9d8bc18f7b0
+# Source0-md5: 779a04954839ed349a1c35d8b8552089
 Source1:       named.init
 Source2:       named.sysconfig
 Source3:       named.logrotate
@@ -61,8 +60,8 @@ Source5:      http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
 # Source5-md5: 49fe799c6eca54ae227b22d57ebc1145
 Source6:       %{name}-hip.tar.gz
 # Source6-md5: 62a8a67f51ff8db9fe815205416a1f62
-Source7:       ftp://rs.internic.net/domain/root.zone
-# Source7-md5: d1377ba28666891f9bea92556e764a4d
+Source7:       https://www.internic.net/domain/named.root
+# Source7-md5: 23ec4e704cdaa1dcaaa6f66bc2c0563f
 Source8:       %{name}-127.0.0.zone
 Source9:       %{name}-localhost.zone
 Source10:      %{name}-named.conf
@@ -80,14 +79,15 @@ BuildRequires:      autoconf >= 2.59
 BuildRequires: automake
 BuildRequires: bison
 BuildRequires: flex
-%{?with_geoip:BuildRequires:   GeoIP-devel}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
-BuildRequires: idnkit-devel
 BuildRequires: json-c-devel
-%{?with_seccomp:BuildRequires: libseccomp-devel}
+BuildRequires: libidn2-devel
+# note, there is no kyua in PLD yet (work in progress)
+%{?with_tests:%{!?with_system_tests:BuildRequires:     kyua}}
 BuildRequires: libtool
 %{?with_hip:BuildRequires:     libxml2-devel}
 %{?with_lmdb:BuildRequires:    lmdb-devel}
+%{?with_geoip:BuildRequires:   libmaxminddb-devel}
 %{?with_sql:BuildRequires:     mysql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel}
 %{?with_ssl:BuildRequires:     openssl-devel >= 0.9.8d}
@@ -409,14 +409,10 @@ cp -f /usr/share/automake/config.* .
        CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
        %{!?with_epoll:--disable-epoll --disable-devpoll} \
        --enable-full-report \
-       --enable-getifaddrs \
-       %{?with_ipv6:--enable-ipv6} \
        --enable-largefile \
-       %{__enable_disable seccomp} \
        %{!?with_static_libs:--disable-static} \
-       --enable-threads \
        %{?with_kerberos5:--with-gssapi} \
-       --with-idn \
+       --with-libidn2 \
        --with-libtool \
        %{?with_ssl:--with-openssl} \
        %{?with_sql:--with-dlz-postgres} \
@@ -426,7 +422,7 @@ cp -f /usr/share/automake/config.* .
        %{?with_ldap:--with-dlz-ldap} \
        --with-dlz-odbc%{!?with_odbc:=no} \
        --with-dlz-stub \
-       %{?with_geoip:--with-geoip} \
+       %{?with_geoip:--with-geoip2} \
        --with-lmdb%{!?with_lmdb:=no} \
        --with-python=%{__python3}
 
@@ -434,7 +430,13 @@ cp -f /usr/share/automake/config.* .
 
 %{?with_hip:%{__make} -C bind-hip}
 
-%{?with_tests:%{__make} test-force}
+%if %{with tests}
+%if %{with system_tests}
+%{__make} test-force
+%else
+sh unit/unittest.sh
+%endif
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -452,7 +454,6 @@ bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
 
 cp -p bin/tests/named.conf             EXAMPLE-CONFIG-named
-cp -p bin/tests/ndc.conf               EXAMPLE-CONFIG-ndc
 install -p %{SOURCE1}                  $RPM_BUILD_ROOT/etc/rc.d/init.d/named
 cp -p %{SOURCE2}                       $RPM_BUILD_ROOT/etc/sysconfig/named
 cp -p %{SOURCE3}                       $RPM_BUILD_ROOT/etc/logrotate.d/named
@@ -557,7 +558,6 @@ fi
 
 %attr(755,root,root) %{_sbindir}/ddns-confgen
 %attr(755,root,root) %{_sbindir}/dnssec-*
-%attr(755,root,root) %{_sbindir}/genrandom
 %attr(755,root,root) %{_sbindir}/named
 %attr(755,root,root) %{_sbindir}/named-*
 %attr(755,root,root) %{_sbindir}/nsec3hash
@@ -569,7 +569,6 @@ fi
 %{_mandir}/man5/rndc.conf.5*
 %{_mandir}/man8/ddns-confgen.8*
 %{_mandir}/man8/dnssec-*.8*
-%{_mandir}/man8/genrandom.8*
 %{_mandir}/man8/named.8*
 %{_mandir}/man8/named-*.8*
 %{_mandir}/man8/nsec3hash.8*
@@ -599,6 +598,10 @@ fi
 
 %attr(770,root,named) %dir %{_var}/run/named
 
+%dir %{_libdir}/named
+%attr(755,root,root) %{_libdir}/named/filter-aaaa.so
+%{_mandir}/man8/filter-aaaa.8*
+
 %files utils
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/arpaname
@@ -635,19 +638,19 @@ fi
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libbind9.so.1200
+%attr(755,root,root) %ghost %{_libdir}/libbind9.so.1302
 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libdns.so.1203
+%attr(755,root,root) %ghost %{_libdir}/libdns.so.1311
 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libirs.so.1200
+%attr(755,root,root) %ghost %{_libdir}/libirs.so.1301
 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libisc.so.1200
+%attr(755,root,root) %ghost %{_libdir}/libisc.so.1310
 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libisccc.so.1200
+%attr(755,root,root) %ghost %{_libdir}/libisccc.so.1302
 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libisccfg.so.1200
+%attr(755,root,root) %ghost %{_libdir}/libisccfg.so.1302
 %attr(755,root,root) %{_libdir}/libns.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libns.so.1203
+%attr(755,root,root) %ghost %{_libdir}/libns.so.1307
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.035731 seconds and 4 git commands to generate.