]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
Fix fd leaks when sourcing directory. RHBZ#903833
[packages/bash.git] / bash.spec
index 5d50f54d504f59110d5d16f04f6c806de488e76f..feef2c555a3208f4fa298eb35f9eb5a2e01ddf47 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -1,12 +1,11 @@
-#
 # Conditional build:
 %bcond_without static          # don't build static version
 %bcond_with    bash_history    # build with additional history in /var/log/bash_hist ;)
 %bcond_without tests   # do not perform "make test"
-#
+
 %define                ver             4.2
-%define                patchlevel      20
-%define                rel             1
+%define                patchlevel      45
+%define                rel             2
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
 Summary(pl.UTF-8):     Powłoka GNU Bourne Again Shell (bash)
@@ -35,7 +34,9 @@ Patch9:               %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
 Patch11:       %{name}-elinks_cont.patch
 Patch12:       %{name}-pl.po-update.patch
-%{?patchlevel:%patchset_source -f http://ftp.gnu.org/gnu/bash/bash-4.2-patches/bash42-%03g 1 %{patchlevel}}
+Patch13:       %{name}-format-string.patch
+Patch14:       %{name}-4.2-missing_closes.patch
+%patchset_source -f http://ftp.gnu.org/gnu/bash/bash-4.2-patches/bash42-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -193,6 +194,8 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
+%patch13 -p1
+%patch14 -p1
 
 %build
 cp -f /usr/share/automake/config.* support
@@ -210,13 +213,13 @@ for mode in %{?with_static:static} shared; do
        --enable-dparen-arithmetic \
        --enable-separate-helpfiles \
        --without-bash-malloc \
-       `[ "$mode" = "static" ] && echo "--enable-static-link"` \
+       $([ "$mode" = "static" ] && echo "--enable-static-link") \
        --with-installed-readline
 
 %{__make} \
        DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
 
-[ "$mode" = "static" ] && mv -f bash bash.static || :
+[ "$mode" = "static" ] && mv -f bash bash.static
 done
 
 %{?with_tests:%{__make} tests}
This page took 0.029222 seconds and 4 git commands to generate.