]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
- loadables patch still needed; files updated
[packages/bash.git] / bash.spec
index 0aff53f10a513630b898573b258bca16ea4b03ef..7b2c6832fa527d24352f513b11d06cff2f3ce13d 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -6,10 +6,10 @@
 %bcond_with    bash_history    # build with additional history in /var/log/bash_hist ;)
 %bcond_without tests   # do not perform "make test"
 
-%define                ver             5.0
-%define                patchlevel      3
+%define                ver             5.1
+%define                patchlevel      0
 %define                rel             1
-%define                min_readline    8.0
+%define                min_readline    8.1
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
 Summary(pl.UTF-8):     Powłoka GNU Bourne Again Shell (bash)
@@ -19,7 +19,7 @@ Release:      %{rel}%{?with_bash_history:inv}
 License:       GPL v3+
 Group:         Applications/Shells
 Source0:       http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
-# Source0-md5: 2b44b47b905be16f45709648f671820b
+# Source0-md5: bb91a17fd6c9032c26d0b2b78b50aff5
 Source1:       %{name}rc
 Source2:       %{name}-skel-.bash_logout
 Source3:       %{name}-skel-.bash_profile
@@ -38,6 +38,7 @@ Patch8:               %{name}-sighup.patch
 Patch9:                %{name}-backup_history.patch
 Patch10:       %{name}-act_like_sh.patch
 Patch11:       %{name}-elinks_cont.patch
+Patch12:       bash-5.1-parallel_make.patch
 %patchset_source -f https://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-%03g 1 %{patchlevel}
 URL:           http://www.gnu.org/software/bash/
 BuildRequires: autoconf >= 2.61
@@ -208,6 +209,7 @@ Pliki nagłówkowe do tworzenia wtyczek basha.
 %{?with_bash_history:%patch9 -p1}
 %patch10 -p1
 %patch11 -p1
+%patch12 -p1
 
 sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
 
@@ -233,7 +235,9 @@ for mode in %{?with_static:static} shared; do
 %{__make} \
        DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
 
-[ "$mode" = "static" ] && mv -f bash bash.static
+if [ "$mode" = "static" ]; then
+       mv -f bash bash.static
+fi
 done
 
 %{?with_tests:%{__make} tests}
@@ -326,7 +330,10 @@ end
 
 # loadables
 %dir %{_libdir}/%{name}
+%attr(755,root,root) %{_libdir}/%{name}/accept
 %attr(755,root,root) %{_libdir}/%{name}/basename
+%attr(755,root,root) %{_libdir}/%{name}/csv
+%attr(755,root,root) %{_libdir}/%{name}/cut
 %attr(755,root,root) %{_libdir}/%{name}/dirname
 %attr(755,root,root) %{_libdir}/%{name}/fdflags
 %attr(755,root,root) %{_libdir}/%{name}/finfo
@@ -335,12 +342,15 @@ end
 %attr(755,root,root) %{_libdir}/%{name}/ln
 %attr(755,root,root) %{_libdir}/%{name}/logname
 %attr(755,root,root) %{_libdir}/%{name}/mkdir
+%attr(755,root,root) %{_libdir}/%{name}/mkfifo
+%attr(755,root,root) %{_libdir}/%{name}/mktemp
 %attr(755,root,root) %{_libdir}/%{name}/mypid
 %attr(755,root,root) %{_libdir}/%{name}/pathchk
 %attr(755,root,root) %{_libdir}/%{name}/print
 %attr(755,root,root) %{_libdir}/%{name}/printenv
 %attr(755,root,root) %{_libdir}/%{name}/push
 %attr(755,root,root) %{_libdir}/%{name}/realpath
+%attr(755,root,root) %{_libdir}/%{name}/rm
 %attr(755,root,root) %{_libdir}/%{name}/rmdir
 %attr(755,root,root) %{_libdir}/%{name}/seq
 %attr(755,root,root) %{_libdir}/%{name}/setpgid
@@ -364,5 +374,6 @@ end
 %defattr(644,root,root,755)
 %{_includedir}/bash
 %dir %{_libdir}/%{name}
-%dir %{_libdir}/%{name}/Makefile.inc
+%{_libdir}/%{name}/Makefile.inc
+%{_libdir}/%{name}/loadables.h
 %{_pkgconfigdir}/bash.pc
This page took 0.035825 seconds and 4 git commands to generate.