]> git.pld-linux.org Git - packages/bash.git/blobdiff - bash.spec
- release 3
[packages/bash.git] / bash.spec
index fd77b0edda16776245c31a2cadbe79fad3f2005d..00b2be61ddf8ef56a66a3cf7bfe04e608f617f63 100644 (file)
--- a/bash.spec
+++ b/bash.spec
@@ -5,8 +5,8 @@
 %bcond_without tests   # do not perform "make test"
 #
 %define                ver             3.2
-%define                patchlevel      39
-%define                rel             1
+%define                patchlevel      48
+%define                rel             3
 Summary:       GNU Bourne Again Shell (bash)
 Summary(fr.UTF-8):     Le shell Bourne Again de GNU
 Summary(pl.UTF-8):     Powłoka GNU Bourne Again Shell (bash)
@@ -44,7 +44,7 @@ BuildRequires:        automake
 BuildRequires: bison
 BuildRequires: ncurses-devel >= 5.2
 BuildRequires: readline-devel >= 5.2
-BuildRequires: rpmbuild(macros) >= 1.429
+BuildRequires: rpmbuild(macros) >= 1.462
 BuildRequires: sed >= 4.0
 BuildRequires: texinfo
 %if %{with static}
@@ -194,7 +194,7 @@ tym pakiecie jest wersja basha skonsolidowana statycznie.
 %{?with_bash_history:%patch9 -p1}
 %patch10 -p1
 %patch11 -p1
-tar xjf %SOURCE6 -C po
+%{__tar} xjf %{SOURCE6} -C po
 sed -e 's/boldquot ru/boldquot ru af ca de es et fr hu ja nl pl pt_BR ro tr vi/' -i po/LINGUAS
 
 %build
@@ -259,16 +259,25 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/bashbug
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p %add_etc_shells -p /bin/sh /bin/ksh
+%post  -p <lua>
+%lua_add_etc_shells /bin/bash /bin/rbash
 os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
 
-%preun -p %remove_etc_shells -p /bin/bash /bin/rbash
+%preun -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash /bin/rbash
+end
 
 %postun        -p      /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%post static -p %add_etc_shells -p /bin/bash.static
-%preun static -p %remove_etc_shells -p /bin/bash.static
+%post static -p <lua>
+%lua_add_etc_shells /bin/bash.static
+
+%preun static -p <lua>
+if arg[2] == 0 then
+       %lua_remove_etc_shells /bin/bash.static
+end
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
This page took 0.029416 seconds and 4 git commands to generate.