]> git.pld-linux.org Git - packages/automake.git/blobdiff - automake.spec
- updated to 1.16
[packages/automake.git] / automake.spec
index 266bc21075c4f90620599184285f47ce2e68d2f6..f0d0e78c3ab73f5f14b0c2fc34fbeaf6e17adfc0 100644 (file)
@@ -1,7 +1,7 @@
 #
 # Conditional build:
-%bcond_without regeneration    # without full regeneration
-#
+%bcond_with    bootstrap       # without full regeneration
+
 %include       /usr/lib/rpm/macros.perl
 Summary:       GNU automake - Makefile configuration tools
 Summary(de.UTF-8):     GNU automake - Makefile-Konfigurationstools
@@ -14,35 +14,45 @@ Summary(ru.UTF-8):  GNU automake - инструменты для автомати
 Summary(tr.UTF-8):     Makefile yapılandırma araçları
 Summary(uk.UTF-8):     GNU automake - інструменти для автоматичної генерації Makefile'ів
 Name:          automake
-Version:       1.10.2
-Release:       2
+Version:       1.16
+Release:       1
 Epoch:         1
 License:       GPL v2+
 Group:         Development/Building
-Source0:       http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.bz2
-# Source0-md5: 1498208ab1c8393dcbd9afb7d06df6d5
+Source0:       http://ftp.gnu.org/gnu/automake/%{name}-%{version}.tar.xz
+# Source0-md5: bfdf69ac36c327b3a59b83ab01057e30
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-man.patch
 Patch2:                %{name}-no_versioned_dir.patch
 Patch3:                %{name}-morearchs.patch
-Patch4:                %{name}-depout.patch
+Patch4:                revert-debian-python-hacks.patch
 URL:           http://sources.redhat.com/automake/
-%if %{with regeneration}
-BuildRequires: autoconf >= 2.60
-BuildRequires: automake >= 1:1.8a
-%else
-BuildRequires: autoconf = 2.60
+BuildRequires: autoconf >= 2.69
+%if %{without bootstrap}
+BuildRequires: automake >= 1:1.14
 %endif
+BuildRequires: help2man
 BuildRequires: rpm-perlprov
-BuildRequires: texinfo >= 4.7
+BuildRequires: tar >= 1:1.22
+BuildRequires: texinfo >= 4.9
+BuildRequires: xz
 Requires(pre): fileutils
 Requires:      filesystem >= 3.0-2
 Requires:      perl(File::Glob)
-Conflicts:     autoconf < 2.60
+%if %(%{__perl} -le 'use threads; print 1' || echo 0)
+# required only if perl was built with threads
+Requires:      perl(Thread::Queue)
+Requires:      perl(threads)
+%endif
+Conflicts:     autoconf < 2.65
 Conflicts:     libtool < 2:1.5-11
-#BuildArch:    noarch -- autoconf doesn't allow
+Conflicts:     texinfo < 4.9
+BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                ver_maj         %(echo %{version} | cut -d. -f1-2)
+%define                _enable_debug_packages  0
+
 %description
 Automake is an experimental Makefile generator. Automake was inspired
 by the 4.4BSD make and include files, but aims to be portable and to
@@ -100,7 +110,7 @@ Makefile'ів.
 %patch3 -p1
 %patch4 -p1
 
-%if %{with regeneration}
+%if %{without bootstrap}
 # prepare temporary copy of m4 dir without amversion.m4 (which causes automake version check)
 mkdir m4-tmp
 cd m4-tmp
@@ -108,14 +118,20 @@ ln -s ../m4/[!a]*.m4 ../m4/a[!m]*.m4 .
 %endif
 
 %build
-%if %{with regeneration}
+%if %{without bootstrap}
 %{__aclocal} -I m4-tmp
 %endif
 %{__autoconf}
-%if %{with regeneration}
+%if %{without bootstrap}
 %{__automake}
 %endif
-%configure
+
+%configure \
+%if "%{_host_cpu}" != "x32"
+       --host=%{_host} \
+       --build=%{_host} \
+%endif
+       --disable-silent-rules
 %{__make}
 
 %install
@@ -126,47 +142,51 @@ install -d $RPM_BUILD_ROOT%{_mandir}/man1
        DESTDIR=$RPM_BUILD_ROOT \
        pkgvdatadir=%{_datadir}/automake
 
-install aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
+cp -a aclocal.1 automake.1 $RPM_BUILD_ROOT%{_mandir}/man1
+
+# not needed when dir/files are handled by package system
+%{__rm} $RPM_BUILD_ROOT%{_datadir}/aclocal/README
 
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p      /sbin/postshell
+%post  -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
-%postun        -p      /sbin/postshell
+%postun        -p /sbin/postshell
 -/usr/sbin/fix-info-dir -c %{_infodir}
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README THANKS TODO
+%doc AUTHORS ChangeLog NEWS README THANKS
 %attr(755,root,root) %{_bindir}/aclocal*
 %attr(755,root,root) %{_bindir}/automake*
 %{_infodir}/automake.info*
+%{_infodir}/automake-history.info*
 %{_mandir}/man1/aclocal.1*
+%{_mandir}/man1/aclocal-%{ver_maj}.1*
 %{_mandir}/man1/automake.1*
+%{_mandir}/man1/automake-%{ver_maj}.1*
 
-%{_datadir}/aclocal-*
+%{_datadir}/aclocal-%{ver_maj}
 %dir %{_datadir}/automake
 %{_datadir}/automake/am
 %{_datadir}/automake/Automake
 %{_datadir}/automake/COPYING
 %{_datadir}/automake/INSTALL
 %{_datadir}/automake/texinfo.tex
-%{_datadir}/automake/ansi2knr*
-%attr(755,root,root) %{_datadir}/automake/acinstall
+%attr(755,root,root) %{_datadir}/automake/ar-lib
 %attr(755,root,root) %{_datadir}/automake/compile
 %attr(755,root,root) %{_datadir}/automake/config.guess
 %attr(755,root,root) %{_datadir}/automake/config.sub
-%attr(755,root,root) %{_datadir}/automake/config-ml.in
 %attr(755,root,root) %{_datadir}/automake/depcomp
-%attr(755,root,root) %{_datadir}/automake/elisp-comp
 %attr(755,root,root) %{_datadir}/automake/install-sh
 %attr(755,root,root) %{_datadir}/automake/mdate-sh
 %attr(755,root,root) %{_datadir}/automake/missing
 %attr(755,root,root) %{_datadir}/automake/mkinstalldirs
 %attr(755,root,root) %{_datadir}/automake/py-compile
-%attr(755,root,root) %{_datadir}/automake/symlink-tree
+%attr(755,root,root) %{_datadir}/automake/tap-driver.sh
+%attr(755,root,root) %{_datadir}/automake/test-driver
 %attr(755,root,root) %{_datadir}/automake/ylwrap
This page took 0.052341 seconds and 4 git commands to generate.