]> git.pld-linux.org Git - packages/aspseek.git/blobdiff - aspseek.spec
cosmetics
[packages/aspseek.git] / aspseek.spec
index d7a4520ccf252d2a1fdc2c8ea0ba3de9745ecc59..fb47a7dd4422a37ad9a126e9ef92024ec0e42c7c 100644 (file)
@@ -6,20 +6,30 @@ Summary:      Advanced Internet search engine
 Summary(pl):   Silnik zaawansowanej wyszukiwarki Internetowej
 Name:          aspseek
 Version:       1.2.8
-Release:       1
+Release:       4
 License:       GPL
 Group:         Networking/Utilities
 Source0:       http://www.aspseek.org/pkg/src/1.2.8/%{name}-%{version}.tar.gz
+# Source0-md5: 0660b6b0d45d37c7a53c7e1c40cae002
 Source1:       %{name}-mod_aspseek.conf
 Source2:       %{name}.init
+Patch0:                %{name}-types.patch
 URL:           http://www.aspseek.org/
-Requires:      webserver
-Requires:      %{name}-db-%{version}
 BuildRequires: apache(EAPI)-devel
-BuildRequires: openssl-devel
+BuildRequires: openssl-devel >= 0.9.7
 BuildRequires: mysql-devel
 BuildRequires: libstdc++-devel
 BuildRequires: zlib-devel
+Requires(pre): /bin/id
+Requires(pre): /usr/sbin/useradd
+Requires(postun):      /usr/sbin/userdel
+Requires(post):        fileutils
+Requires(post,preun):  /sbin/chkconfig
+Requires(post,postun): /sbin/ldconfig
+Requires:      webserver
+Requires:      %{name}-db-%{version}
+Obsoletes:     swish++
+Obsoletes:     mnogosearch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/%{name}
@@ -69,6 +79,7 @@ Summary(pl):  Obs
 Group:         Networking/Utilities
 Provides:      %{name}-db-%{version}
 Requires:      %{name} = %{version}
+Requires(post):        /sbin/ldconfig
 
 %description db-mysql
 This driver acts as a database backend for ASPSeek, so ASPSeek will
@@ -82,8 +93,10 @@ b
 Summary:       Apache module: ASPSeek search engine
 Summary(pl):   Modu³ Apache: Silnik wyszukiwania ASPSeek
 Group:         Networking/Daemons
-Requires(post):        %{_sbindir}/apxs
-Requires(pre): aspseek
+PreReq:                aspseek
+Requires(post,preun):  %{apxs}
+Requires(post,preun):  grep
+Requires(preun):       fileutils
 Requires:      apache(EAPI)
 
 %description -n apache-mod_aspseek
@@ -94,6 +107,7 @@ Modu
 
 %prep
 %setup -q
+%patch -p1
 
 %build
 %configure2_13 \
@@ -102,12 +116,13 @@ Modu
        --enable-apache-module \
        --with-openssl \
        --with-mysql \
+       --enable-unicode \
        --localstatedir=/var/spool
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/httpd,/home/httpd/icons,rc.d/init.d}
+install -d $RPM_BUILD_ROOT{/etc/{httpd,rc.d/init.d},/home/httpd/icons}
 install -d $RPM_BUILD_ROOT/var/{spool/aspseek,log}
 
 %{__make} install \
@@ -120,69 +135,69 @@ sed -e "s#/img/#/icons/#g" $RPM_BUILD_ROOT%{_sysconfdir}/s.htm-dist > \
 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
 touch $RPM_BUILD_ROOT/var/log/aspseek.log
 
-gzip -9nf AUTHOR* FAQ* NEWS* README* RELEASE* THANKS* TODO* doc/*.txt
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %pre
 if [ -n "`id -u aspseek 2>/dev/null`" ]; then
        if [ "`id -u aspseek`" != "50" ]; then
-         echo "Warning: user aspseek haven't uid=50. Correct this before installing aspseek" 1>&2
-          exit 1
-        fi
+               echo "Error: user aspseek doesn't have uid=50. Correct this before installing aspseek." 1>&2
+               exit 1
+       fi
 else
-        /usr/sbin/useradd -u 50 -r -d /home/services/aspseek -s /bin/false -c "ASPSEEK User" -g root aspseek 1>&2
+       /usr/sbin/useradd -u 50 -r -d /home/services/aspseek -s /bin/false -c "ASPSEEK User" -g root aspseek 1>&2
 fi
 
 %post
 /sbin/ldconfig
-/sbin/chkconfig --add httpd
-touch /var/log/aspseek.log && chown aspseek.root /var/log/aspseek.log
+/sbin/chkconfig --add %{name}
+touch /var/log/aspseek.log
+chown aspseek:root /var/log/aspseek.log
 
 %preun
 if [ "$1" = "0" ]; then
-        if [ -f /var/lock/subsys/%{name} ]; then
-                /etc/rc.d/init.d/%{name} stop 1>&2
-        fi
-        /sbin/chkconfig --del %{name}
+       if [ -f /var/lock/subsys/%{name} ]; then
+               /etc/rc.d/init.d/%{name} stop 1>&2
+       fi
+       /sbin/chkconfig --del %{name}
 fi
 
 %postun
 /sbin/ldconfig
 if [ "$1" = "0" ]; then
-        /usr/sbin/userdel aspseek
+       /usr/sbin/userdel aspseek
 fi
 
 %post db-mysql
 /sbin/ldconfig
-echo "Remember to run: %{_sbindir}/aspseek-mysql-postinstall"
+echo "Remember to run %{_sbindir}/aspseek-mysql-postinstall."
 
 %postun db-mysql -p /sbin/ldconfig
 
 %post -n apache-mod_aspseek
-%{_sbindir}/apxs -e -a -n aspseek %{_pkglibdir}/mod_aspseek.so 1>&2
+%{apxs} -e -a -n aspseek %{_pkglibdir}/mod_aspseek.so 1>&2
 if [ -f /etc/httpd/httpd.conf ] && ! grep -q "^Include.*mod_aspseek.conf" /etc/httpd/httpd.conf; then
-        echo "Include /etc/httpd/mod_aspseek.conf" >> /etc/httpd/httpd.conf
+       echo "Include /etc/httpd/mod_aspseek.conf" >> /etc/httpd/httpd.conf
 fi
 if [ -f /var/lock/subsys/httpd ]; then
-        /etc/rc.d/init.d/httpd restart 1>&2
+       /etc/rc.d/init.d/httpd restart 1>&2
 fi
 
 %preun -n apache-mod_aspseek
 if [ "$1" = "0" ]; then
-        %{_sbindir}/apxs -e -A -n aspseek %{_pkglibdir}/mod_aspseek.so 1>&2
-        grep -v "^Include.*mod_aspseek.conf" /etc/httpd/httpd.conf > \
-                /etc/httpd/httpd.conf.tmp
-        mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
-        if [ -f /var/lock/subsys/httpd ]; then
-                /etc/rc.d/init.d/httpd restart 1>&2
-        fi
+       %{apxs} -e -A -n aspseek %{_pkglibdir}/mod_aspseek.so 1>&2
+       umask 027
+       grep -v "^Include.*mod_aspseek.conf" /etc/httpd/httpd.conf > \
+               /etc/httpd/httpd.conf.tmp
+       mv -f /etc/httpd/httpd.conf.tmp /etc/httpd/httpd.conf
+       if [ -f /var/lock/subsys/httpd ]; then
+               /etc/rc.d/init.d/httpd restart 1>&2
+       fi
 fi
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHOR* FAQ* NEWS* README.gz RELEASE* THANKS* TODO* doc/*.gz
+%doc AUTHOR* FAQ* NEWS* README* RELEASE* THANKS* TODO* doc/*.txt
 %attr(755,root,root) %{_bindir}/s.cgi
 %attr(755,root,root) %{_sbindir}/index
 %attr(755,root,root) %{_sbindir}/searchd
@@ -197,6 +212,7 @@ fi
 %dir %{_sysconfdir}/sql
 %{_sysconfdir}/stopwords
 %{_sysconfdir}/tables
+%attr(754,root,root) /etc/rc.d/init.d/aspseek
 %attr(750,aspseek,root) %dir /var/spool/aspseek
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.conf
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/*.htm
@@ -211,6 +227,6 @@ fi
 
 %files -n apache-mod_aspseek
 %defattr(644,root,root,755)
-%doc README.APACHE_MODULE.gz
+%doc README.APACHE_MODULE
 %attr(755,root,root) %{_pkglibdir}/*.so
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/httpd/mod_*.conf
This page took 0.041314 seconds and 4 git commands to generate.