]> git.pld-linux.org Git - packages/apache1-mod_auth_pgsql.git/blobdiff - apache1-mod_auth_pgsql.spec
- release 3 to rebuild with PostgreSQL 8.2
[packages/apache1-mod_auth_pgsql.git] / apache1-mod_auth_pgsql.spec
index c1e255e8a9d94482a77ba24bfd14e7883da5d82a..5182c783f7fd1001e13ccadef7018bc057a5f574 100644 (file)
@@ -1,4 +1,5 @@
 %define                mod_name        auth_pgsql
+%define        apxs            /usr/sbin/apxs1
 Summary:       This is the PostgreSQL authentication module for Apache
 Summary(cs):   Základní autentizace pro WWW server Apache pomocí PostgreSQL
 Summary(da):   Autenticering for webtjeneren Apache fra en PostgreSQL-database
@@ -7,43 +8,33 @@ Summary(es):  Autenticaci
 Summary(fr):   Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
 Summary(it):   Autenticazione di base per il server web Apache mediante un database PostgreSQL
 Summary(ja):   PostgreSQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
-Summary(no):   Autentisering for webtjeneren Apache fra en PostgreSQL-database
-Summary(pl):   Modu³ autentykacji PostgreSQL dla Apache
+Summary(nb):   Autentisering for webtjeneren Apache fra en PostgreSQL-database
+Summary(pl):   Modu³ uwierzytelnienia PostgreSQL dla Apache
 Summary(pt_BR):        Autenticação via PostgreSQL para o Apache
 Summary(sv):   Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
-Name:          apache-mod_%{mod_name}
+Name:          apache1-mod_%{mod_name}
 Version:       0.9.12
-Release:       1
+Release:       3
 License:       GPL
 Group:         Networking/Daemons
-Group(cs):     Sí»ové/Démoni
-Group(da):     Netværks/Dæmoner
-Group(de):     Netzwerkwesen/Server
-Group(es):     Red/Servidores
-Group(fr):     Réseau/Serveurs
-Group(is):     Net/Púkar
-Group(it):     Rete/Demoni
-Group(no):     Nettverks/Daemoner
-Group(pl):     Sieciowe/Serwery
-Group(pt):     Rede/Servidores
-Group(ru):     óÅÔØ/äÅÍÏÎÙ
-Group(sl):     Omre¾ni/Stre¾niki
-Group(sv):     Nätverk/Demoner
-Group(uk):     íÅÒÅÖÁ/äÅÍÏÎÉ
 Source0:       http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
-BuildRequires: postgresql-devel
-BuildRequires: /usr/sbin/apxs
-BuildRequires: apache(EAPI)-devel
-Prereq:                /usr/sbin/apxs
-Requires:      apache(EAPI)
+# Source0-md5: 7be403b7487c13cdb023cc526ee2e13a
 URL:           http://www.giuseppetanzilli.it/mod_auth_pgsql/
+BuildRequires: %{apxs}
+BuildRequires: apache1-devel >= 1.3.33-2
+BuildRequires: postgresql-devel >= 7
+BuildRequires: rpmbuild(macros) >= 1.268
+Requires(triggerpostun):       %{apxs}
+Requires:      apache1 >= 1.3.33-2
+Obsoletes:     apache-mod_auth_pgsql <= 0.9.12
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
+%define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
+%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
 
 %description
 This is an authentication module for Apache that allows you to
-authenticate HTTP clients using postgresql RDBMS.
+authenticate HTTP clients using PostgreSQL RDBMS.
 
 %description -l cs
 Balíèek mod_auth_pgsql slou¾í pro omezení pøístupu k dokumentùm, které
@@ -76,8 +67,8 @@ Mod_auth_pgsql 
 À©¸Â¤Ç¤­¤Þ¤¹¡£
 
 %description -l pl
-To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
-klientów HTTP z u¿yciem bazy danych postgresql.
+To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
+uwierzytelnianie klientów HTTP z u¿yciem bazy danych PostgreSQL.
 
 %description -l pt_BR
 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
@@ -89,39 +80,43 @@ servade av en webbserver genom att kontrollera data i en
 PostgreSQL-databas.
 
 %prep
-%setup -q -n "mod_%{mod_name}-%{version}"
+%setup -q -n mod_%{mod_name}-%{version}
 
 %build
-/usr/sbin/apxs \
-       -I %{_includedir}/postgresql \
-       -l pq \
+%{apxs} \
+       -I%{_includedir}/postgresql \
+       -lpq \
        -c mod_%{mod_name}.c \
        -o mod_%{mod_name}.so
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_pkglibdir}
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
 
 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
 
+echo 'LoadModule %{mod_name}_module    modules/mod_%{mod_name}.so' > \
+       $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %post
-/usr/sbin/apxs -e -a -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
+%service -q apache restart
 
-%preun
+%postun
 if [ "$1" = "0" ]; then
-       /usr/sbin/apxs -e -A -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
-       if [ -f /var/lock/subsys/httpd ]; then
-               /etc/rc.d/init.d/httpd restart 1>&2
-       fi
+       %service -q apache restart
+fi
+
+%triggerpostun -- apache1-mod_%{mod_name} < 0.9.12-1.1
+# check that they're not using old apache.conf
+if grep -q '^Include conf\.d' /etc/apache/apache.conf; then
+       %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
 fi
 
 %files
 %defattr(644,root,root,755)
 %doc *.html
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.063086 seconds and 4 git commands to generate.