]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/blobdiff - apache-mod_pagespeed.spec
- added system-protobuf patch to use system protobuf; but build still fails due to...
[packages/apache-mod_pagespeed.git] / apache-mod_pagespeed.spec
index 71be2ae72817f0c62eba3cf6c129476f99c2b9de..5d80913f4a909087ffb55d399ad4736e6b2d6e98 100644 (file)
@@ -1,6 +1,7 @@
 #
 # Conditional build:
 %bcond_without verbose         # verbose build (V=1)
+%bcond_with    sse2            # use SSE2 instructions
 
 # NOTE
 # - relase notes: https://developers.google.com/speed/pagespeed/module/release_notes
@@ -51,17 +52,26 @@ Name:               apache-mod_%{mod_name}
 # beta: 1.9.32.x-beta
 # stable: 1.9.32.x-stable
 Version:       1.9.32.4
-Release:       1
+Release:       8
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
+#Source0Download: https://github.com/pagespeed/mod_pagespeed/releases
+#Source0:      https://github.com/pagespeed/mod_pagespeed/archive/%{version}/mod_pagespeed-%{version}.tar.gz
 Source0:       modpagespeed-%{version}.tar.xz
 # Source0-md5: c6740a5de9cb7f20f0cf29c8835f6f95
 Source1:       get-source.sh
 Source2:       gclient.conf
 Patch0:                system-libs.patch
+Patch1:                addrinfo.patch
 Patch2:                bug-632.patch
 Patch4:                no-dev-stdout.patch
 Patch5:                apache24-config.patch
+Patch6:                no-force-xxbit.patch
+Patch7:                no-arch-opt.patch
+Patch8:                %{name}-icu.patch
+Patch9:                %{name}-format.patch
+Patch10:       serf-openssl1.1.patch
+Patch11:       %{name}-system-protobuf.patch
 URL:           https://developers.google.com/speed/pagespeed/module
 BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.2
@@ -69,11 +79,14 @@ BuildRequires:      bash
 BuildRequires: glib2-devel
 BuildRequires: gperf
 BuildRequires: libicu-devel
+BuildRequires: libjpeg-turbo-devel
+BuildRequires: libpng-devel
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= 5:4.1
 BuildRequires: opencv-devel >= 2.3.1
-BuildRequires: openssl-devel
+BuildRequires: openssl-devel >= 1.1
 BuildRequires: pkgconfig
+BuildRequires: protobuf-devel
 BuildRequires: python-devel >= 1:2.6
 BuildRequires: yasm
 # This version of gyp is new enough that it knows to use make for Linux 3.x
@@ -110,21 +123,31 @@ site is maintained.
 
 %prep
 %setup -q -n modpagespeed-%{version}
-%patch0 -p2
+%patch0 -p1
+%patch1 -p0
 %patch2 -p1
 %patch4 -p1
 %patch5 -p1
+%patch6 -p1
+%patch7 -p1
+%patch8 -p1
+%patch9 -p1
+%patch10 -p1
+%patch11 -p1
 
 %if 0
 sh -x %{_sourcedir}/clean-source.sh
 %endif
 
-rm -r third_party/icu/source
-rm -r third_party/icu/genfiles
+%{__rm} -r third_party/icu/source
+%{__rm} -r third_party/icu/genfiles
+# third_party_chromium uses "third_party/icu/..." includes
 install -d third_party/icu/source/{common,i18n}
 ln -s %{_includedir}/unicode third_party/icu/source/i18n/unicode
 ln -s %{_includedir}/unicode third_party/icu/source/common/unicode
 
+%{__rm} -r third_party/protobuf/src
+
 %build
 # re-gen makefiles
 CC="%{__cc}" \
@@ -133,6 +156,7 @@ CXX="%{__cxx}" \
        --format=make \
        --depth=. \
        build/all.gyp \
+       %{!?with_sse2:-Ddisable_sse2=1} \
        -Duse_openssl=1 \
        -Duse_system_apache_dev=1 \
        -Duse_system_icu=1 \
@@ -140,6 +164,7 @@ CXX="%{__cxx}" \
        -Duse_system_libpng=1 \
        -Duse_system_opencv=1 \
        -Duse_system_openssl=1 \
+       -Duse_system_protobuf=1 \
        -Duse_system_yasm=1 \
        -Duse_system_zlib=1 \
        -Dsystem_include_path_apr=%{_includedir}/apr \
@@ -155,8 +180,8 @@ CXX="%{__cxx}" \
        CC.host="%{__cc}" \
        CXX.host="%{__cxx}" \
        LINK.host="%{__cxx}" \
-       CFLAGS="%{rpmcflags} %{rpmcppflags}" \
-       CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
+       CFLAGS="%{rpmcflags} %{rpmcppflags} -DUSE_SYSTEM_LIBJPEG" \
+       CXXFLAGS="%{rpmcxxflags} %{rpmcppflags} -DUSE_SYSTEM_LIBJPEG" \
        %{nil}
 
 %install
This page took 0.064597 seconds and 4 git commands to generate.