]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/blobdiff - apache-mod_pagespeed.spec
use tar transform instead of copying
[packages/apache-mod_pagespeed.git] / apache-mod_pagespeed.spec
index 17d4e58628c03587c929d1e2177739934663e2ac..23e5a6d1c3f7a02d1c21d3077bede77177ea0698 100644 (file)
@@ -7,7 +7,6 @@
 # - http://wiki.mediatemple.net/w/(dv)_HOWTO:_Install_mod_pagespeed
 # TODO
 # - add unit tests running
-# - use only source for modpagespeed if system headers are used (remove copies from tarball)
 # - possible sysdeps (uses release tags)
 #  "serf_src": "http://serf.googlecode.com/svn/tags/0.3.1",
 #  "gflags_root": "http://google-gflags.googlecode.com/svn/tags/gflags-1.3/src",
 %define        apxs            %{_sbindir}/apxs
 Summary:       Apache module for rewriting web pages to reduce latency and bandwidth
 Name:          apache-mod_%{mod_name}
-Version:       0.10.22.4
-Release:       0.10
+Version:       1.3.25.4
+Release:       1
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
-Source0:       modpagespeed-%{version}.tar.bz2
-# Source0-md5: 5a05827b25b66cdfb68bdce163f13e37
+Source0:       modpagespeed-%{version}.tar.xz
+# Source0-md5: ce8569ada0efe16c8fef1cd87064e04c
 Source1:       get-source.sh
+Source2:       gclient.conf
 Patch0:                system-libs.patch
 Patch1:                gcc-headers.patch
+Patch2:                bug-632.patch
+Patch3:                opencv.patch
 URL:           https://developers.google.com/speed/pagespeed/
 BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.2
-BuildRequires: dbus-glib-devel
-BuildRequires: fontconfig-devel
-BuildRequires: freetype-devel
 BuildRequires: glib2-devel
 BuildRequires: gperf
-BuildRequires: gtk+2-devel
-BuildRequires: libgcrypt-devel
-BuildRequires: libgnome-keyring-devel
-BuildRequires: libjpeg-devel
-BuildRequires: libpng-devel
 BuildRequires: libselinux-devel
 BuildRequires: libstdc++-devel >= 5:4.1
-BuildRequires: opencv-devel
+BuildRequires: opencv-devel >= 2.3.1
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: python-devel >= 1:2.6
+# This version of gyp is new enough that it knows to use make for Linux 3.x
+# and FreeBSD, but old enough that 'type': 'settings' works and
+# LINKER_SUPPORTS_ICF hasn't been removed yet.
+BuildRequires: python-gyp >= 1-1175
 BuildRequires: rpmbuild(macros) >= 1.268
-BuildRequires: xorg-lib-libX11-devel
-BuildRequires: xorg-lib-libXext-devel
-BuildRequires: xorg-lib-libXi-devel
+BuildRequires: tar >= 1:1.22
+BuildRequires: util-linux
+BuildRequires: xz
 BuildRequires: zlib-devel
 # gcc4 might be installed, but not current __cc
 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "4.0"
@@ -82,33 +80,32 @@ by Page Speed can be used without having to change the way the web
 site is maintained.
 
 %prep
-%setup -q -n modpagespeed
-%patch0 -p1
-%patch1 -p1
+%setup -q -n modpagespeed-%{version}
+%patch0 -p2
+%patch1 -p2
+%patch2 -p2
+%patch3 -p3
 
 %build
 # re-gen makefiles
-cd src
 CC="%{__cc}" \
 CXX="%{__cxx}" \
-%{__python} build/gyp_chromium --format=make build/all.gyp \
-       -Dlinux_link_gsettings=1 \
-       -Dlinux_link_gnome_keyring=1 \
-       -Duse_gnome_keyring=1 \
+%{__python} build/gyp_chromium \
+       --format=make \
+       --depth=. \
+       build/all.gyp \
        -Duse_openssl=1 \
        -Duse_system_apache_dev=1 \
        -Duse_system_libjpeg=1 \
        -Duse_system_libpng=1 \
        -Duse_system_opencv=1 \
        -Duse_system_zlib=1 \
+       -Dsystem_include_path_apr=%{_includedir}/apr \
+       -Dsystem_include_path_aprutil=%{_includedir}/apr-util \
+       -Dsystem_include_path_httpd=%{_includedir}/apache \
        %{nil}
 
-cd ..
-
-# makefile wrapper so we could just invoke "make" from shell
-cat > Makefile <<'EOF'
-default:
-       $(MAKE) -C src \
+%{__make} mod_pagespeed js_minify css_minify_main \
        BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
        %{?with_verbose:V=1} \
        CC="%{__cc}" \
@@ -118,29 +115,34 @@ default:
        LINK.host="%{__cxx}" \
        CFLAGS="%{rpmcflags} %{rpmcppflags}" \
        CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
-       $(MAKEFLAGS) \
-EOF
-%{__make}
+       %{nil}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},%{cachedir}/{cache,files}}
-%{__make} -j1 -C src/install staging_except_module \
-       HOSTNAME=localhost \
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},%{_bindir},%{cachedir}}
+
+%{__make} -j1 -C install staging_except_module \
        APACHE_ROOT=%{_pkgrootdir} \
        APACHE_MODULES=modules \
        APACHE_DOC_ROOT=%{htdocsdir} \
-       MOD_PAGESPEED_FILE_ROOT=%{cachedir} \
+       MOD_PAGESPEED_CACHE=%{cachedir} \
+       MOD_PAGESPEED_STATS_LOG=/var/log/httpd/mod_pagespeed_stats.log \
        STAGING_DIR=staging
 
-install -p src/out/Release/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
-cd src/install/staging
+out=out/%{!?debug:Release}%{?debug:Debug}
+install -p $out/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
+install -p $out/js_minify $RPM_BUILD_ROOT%{_bindir}/pagespeed_js_minify
+install -p $out/css_minify_main $RPM_BUILD_ROOT%{_bindir}/pagespeed_css_minify
+
+cd install/staging
 cat > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf <<EOF
 LoadModule %{mod_name}_module  modules/mod_%{mod_name}.so
 
 $(cat pagespeed.conf)
 EOF
 
+cp -p pagespeed_libraries.conf $RPM_BUILD_ROOT%{_sysconfdir}/91_mod_%{mod_name}_libraries.conf
+
 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a mod_pagespeed_example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
@@ -158,9 +160,9 @@ fi
 %files
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}_libraries.conf
+%attr(755,root,root) %{_bindir}/pagespeed_css_minify
+%attr(755,root,root) %{_bindir}/pagespeed_js_minify
 %attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
 %{_examplesdir}/%{name}-%{version}
-
-%dir %attr(710,root,http) %{cachedir}
-%dir %attr(770,root,http) %{cachedir}/cache
-%dir %attr(770,root,http) %{cachedir}/files
+%dir %attr(770,root,http) %{cachedir}
This page took 0.037069 seconds and 4 git commands to generate.