]> git.pld-linux.org Git - packages/ansible.git/blobdiff - ansible.spec
up to 1.3.1
[packages/ansible.git] / ansible.spec
index 78a701cbcb83e3c4eeafedff05d06a23aa52ce8f..733e38d1c94486f5473e238031785cc2daf398fe 100644 (file)
@@ -1,21 +1,22 @@
-Summary:       Minimal SSH command and control
+Summary:       SSH-based configuration management, deployment, and task execution system
 Name:          ansible
-Version:       1.2
-Release:       0.10
+Version:       1.3.1
+Release:       0.1
 License:       GPL v3+
 Group:         Development/Libraries
-Source0:       https://github.com/ansible/ansible/archive/devel.tar.gz?/%{version}-dev.tgz
-# Source0-md5: 7dcb52644cbe4e9dc998246e69ca3edc
+Source0:       https://github.com/ansible/ansible/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 15b72c9f0d9c0d01c90c4e431a3fe3ae
 Patch0:                https://github.com/glensc/ansible/compare/pm-poldek.patch
-# Patch0-md5:  da4815872cf281741afa01a88a18da95
+# Patch0-md5:  91dd49cb9c64c52615aec95341c40128
 Patch1:                https://github.com/glensc/ansible/compare/rc.d-systemd.patch
-# Patch1-md5:  58add52a8243e9c8daf5ddce56d5385b
+# Patch1-md5:  a51f047c5514124dc29221f3336be402
 URL:           http://ansible.github.com/
 BuildRequires: python-modules >= 1:2.6
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.219
 Requires:      python-PyYAML
 Requires:      python-jinja2
+Requires:      python-modules
 Requires:      python-paramiko
 %if "%{py_ver}" < "2.6"
 Requires:      python-simplejson
@@ -30,9 +31,31 @@ over SSH and does not require any software or daemons to be installed
 on remote nodes. Extension modules can be written in any language and
 are transferred to managed machines automatically.
 
+%package fireball
+Summary:       Ansible fireball transport support
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      python-keyczar
+Requires:      python-zmq
+
+%description fireball
+Ansible can optionally use a 0MQ based transport mechanism, which is
+considerably faster than the standard ssh mechanism when there are
+multiple actions, but requires additional supporting packages.
+
+%package node-fireball
+Summary:       Ansible fireball transport - node end support
+Group:         Development/Libraries
+Requires:      python-keyczar
+Requires:      python-zmq
+
+%description node-fireball
+Ansible can optionally use a 0MQ based transport mechanism, which has
+additional requirements for nodes to use. This package includes those
+requirements.
+
 %prep
-%setup -qc
-mv %{name}-devel/* .
+%setup -q
 %patch0 -p1
 
 %build
@@ -50,6 +73,7 @@ rm -rf $RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_datadir}/%{name},%{_mandir}}
 sed -re '/^#/ !s,[^#]+$,#&,' examples/hosts > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/hosts
+cp -p examples/ansible.cfg $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
 cp -a docs/man/* $RPM_BUILD_ROOT%{_mandir}
 cp -a library/* $RPM_BUILD_ROOT%{_datadir}/%{name}
 
@@ -64,6 +88,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc VERSION *.md
 %dir %{_sysconfdir}/%{name}
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/hosts
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/%{name}.cfg
 %attr(755,root,root) %{_bindir}/ansible
 %attr(755,root,root) %{_bindir}/ansible-doc
 %attr(755,root,root) %{_bindir}/ansible-playbook
@@ -73,6 +98,16 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/ansible-playbook.1*
 %{_mandir}/man1/ansible-pull.1*
 %{_mandir}/man3/ansible.*.3*
+%exclude %{_mandir}/man3/ansible.fireball.3*
 %{_datadir}/%{name}
+%exclude %{_datadir}/%{name}/utilities/fireball
 %{py_sitescriptdir}/ansible
 %{py_sitescriptdir}/ansible-%{version}-*.egg-info
+
+%files fireball
+%defattr(644,root,root,755)
+%{_datadir}/%{name}/utilities/fireball
+%{_mandir}/man3/ansible.fireball.3*
+
+%files node-fireball
+%defattr(644,root,root,755)
This page took 0.066702 seconds and 4 git commands to generate.