]> git.pld-linux.org Git - packages/alsa-lib.git/blobdiff - alsa-lib.spec
up to 1.2.1
[packages/alsa-lib.git] / alsa-lib.spec
index 5c515fdfa3e2c5b3f0877e335ae3c9df2602cafb..dedcdf63bed1b1293cb4c871873d399f57d4db8b 100644 (file)
@@ -3,6 +3,7 @@
 %bcond_without static_libs     # don't build static library
 %bcond_without apidocs         # do not build and package API docs
 %bcond_without python          # smixer-python binding
+%bcond_with    python2         # python 2.x instead of python 3.x for smixer pymodules
 %bcond_with    resmgr          # Resource Manager support
 
 Summary:       Advanced Linux Sound Architecture (ALSA) - Library
@@ -12,22 +13,29 @@ Summary(pt_BR.UTF-8):       Biblioteca para o ALSA (Advanced Linux Sound Architecture)
 Summary(ru.UTF-8):     Библиотека API для работы с драйвером ALSA
 Summary(uk.UTF-8):     Бібліотека API для роботи з драйвером ALSA
 Name:          alsa-lib
-Version:       1.1.0
+Version:       1.2.1
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       ftp://ftp.alsa-project.org/pub/lib/%{name}-%{version}.tar.bz2
-# Source0-md5: 69515ca73c3c4a212ef45160dea846c1
+# Source0-md5: 7f7cae6925c99d900dfdfe9b7b056ccc
 Source1:       %{name}-modprobe.conf
 Source2:       %{name}-asound.conf
+Source3:       smixer.conf
+Patch0:                python-3.8.patch
 URL:           http://www.alsa-project.org/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
 BuildRequires: doxygen
 BuildRequires: libtool >= 1.4
 %if %{with python}
+%if %{with python2}
 BuildRequires: python-devel >= 1:2.4
-BuildRequires: python-modules
+BuildRequires: python-modules >= 1:2.4
+%else
+BuildRequires: python3-devel >= 1:3.2
+BuildRequires: python3-modules >= 1:3.2
+%endif
 %endif
 %{?with_resmgr:BuildRequires:  resmgr-devel}
 BuildConflicts:        alsa-lib <= 0.4.0
@@ -188,6 +196,8 @@ Moduł wiązania Pythona dla interfejsu miksera architektury ALSA.
 
 %prep
 %setup -q
+%patch0 -p1
+cp -p %{SOURCE3} src/conf
 
 %build
 %{__libtoolize}
@@ -198,7 +208,10 @@ Moduł wiązania Pythona dla interfejsu miksera architektury ALSA.
 configure_opts="\
        --disable-silent-rules \
        %{!?with_python:--disable-python} \
-       %{?with_resmgr:--enable-resmgr}
+       %{?with_python2:--enable-python2} \
+       %{?with_resmgr:--enable-resmgr} \
+       --enable-mixer-modules \
+       --enable-mixer-pymods
 "
 
 %if %{with static_libs}
@@ -223,7 +236,7 @@ cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/alsa,/etc/modprobe.d}
+install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/alsa/conf.d,%{_datadir}/alsa/alsa.conf.d,/etc/modprobe.d}
 
 %if %{with static_libs}
 %{__make} -C build-static/src install-libLTLIBRARIES \
@@ -233,7 +246,7 @@ install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/alsa,/etc/modprobe.d}
 %{__make} -C build-shared install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv -f $RPM_BUILD_ROOT%{_libdir}/libasound.so.* $RPM_BUILD_ROOT/%{_lib}
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/libasound.so.* $RPM_BUILD_ROOT/%{_lib}
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libasound.so
 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib}; echo libasound.so.*.*) \
        $RPM_BUILD_ROOT%{_libdir}/libasound.so
@@ -256,24 +269,38 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/aserver
 %attr(755,root,root) /%{_lib}/libasound.so.*.*.*
 %attr(755,root,root) %ghost /%{_lib}/libasound.so.2
+%attr(755,root,root) /%{_libdir}/libatopology.so.*.*.*
+%attr(755,root,root) %ghost /%{_libdir}/libatopology.so.2
 %dir %{_libdir}/alsa-lib
 %dir %{_libdir}/alsa-lib/smixer
 %attr(755,root,root) %{_libdir}/alsa-lib/smixer/smixer-ac97.so
 %attr(755,root,root) %{_libdir}/alsa-lib/smixer/smixer-hda.so
 %attr(755,root,root) %{_libdir}/alsa-lib/smixer/smixer-sbase.so
-%{_datadir}/alsa
+%dir %{_datadir}/alsa
+%{_datadir}/alsa/cards
+%{_datadir}/alsa/pcm
+%{_datadir}/alsa/alsa.conf
+# directory for "global" config files (not accessed directly, but through symlinks in %{_sysconfdir}/alsa/conf.d)
+%dir %{_datadir}/alsa/alsa.conf.d
+%{_datadir}/alsa/smixer.conf
 %dir %{_sysconfdir}/alsa
+# directory for "local" config files (loaded from %{_datadir}/alsa/alsa.conf)
+%dir %{_sysconfdir}/alsa/conf.d
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/asound.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/alsa-base.conf
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libasound.so
+%attr(755,root,root) %{_libdir}/libatopology.so
 %{_libdir}/libasound.la
+%{_libdir}/libatopology.la
 %{_includedir}/sys/asoundlib.h
 %{_includedir}/alsa
+%{_includedir}/asoundlib.h
 %{_aclocaldir}/alsa.m4
 %{_pkgconfigdir}/alsa.pc
+%{_pkgconfigdir}/alsa-topology.pc
 
 %if %{with static_libs}
 %files static
This page took 0.057076 seconds and 4 git commands to generate.