]> git.pld-linux.org Git - packages/acl.git/blobdiff - acl.spec
- updated to 2.2.13
[packages/acl.git] / acl.spec
index 728f52a2f0d11e7500363e9cfcbf461a3c29ef46..e19165d811343a9f1ca081da3288e98e377cd6e4 100644 (file)
--- a/acl.spec
+++ b/acl.spec
@@ -1,17 +1,23 @@
 Summary:       Command for manipulating access control lists
 Summary(pl):   Komenda do manipulacji listami kontroli dostêpu (ACL)
 Name:          acl
-Version:       2.0.9
+Version:       2.2.13
 Release:       1
-License:       GPL
+License:       GPL v2 (chacl utility), LGPL v2+ (library and the rest)
 Group:         Applications/System
 Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
+# Source0-md5: 179890f6dbd0b31701713947e6b8270f
 Patch0:                %{name}-miscfix.patch
 URL:           http://oss.sgi.com/projects/xfs/
+BuildRequires: attr-devel >= 2.4.1
 BuildRequires: autoconf
 Requires:      attr
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _bindir         /bin
+%define                _libdir         /lib
+%define                _libexecdir     /usr/lib
+
 %description
 A command (chacl) to manipulate POSIX access control lists under
 Linux.
@@ -21,17 +27,30 @@ Komenda (chacl) do manipulowania zgodnymi z POSIX listami kontroli
 dostêpu (ACL) pod Linuksem.
 
 %package devel
-Summary:       Header files and libraries to manipulate acls
-Summary(pl):   Pliki nag³ówkowe i biblioteki do manipulacji ACL-ami
+Summary:       Header files for acl library
+Summary(pl):   Pliki nag³ówkowe biblioteki acl
 Group:         Development/Libraries
+Requires:      %{name} = %{version}
 
 %description devel
-Header files and libraries to develop software which manipulate access
-control lists.
+Header files to develop software which manipulate access control
+lists.
 
 %description devel -l pl
-Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
-manipuluj±cego listami kontroli dostêpu (ACL).
+Pliki nag³ówkowe potrzebne do rozwoju oprogramowania manipuluj±cego
+listami kontroli dostêpu (ACL).
+
+%package static
+Summary:       Static acl library
+Summary(pl):   Statyczna biblioteka acl
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}
+
+%description static
+Static acl library.
+
+%description static -l pl
+Statyczna biblioteka acl.
 
 %prep
 %setup  -q
@@ -39,26 +58,28 @@ manipuluj
 
 %build
 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
-autoconf
+%{__autoconf}
 %configure
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_includedir}/acl
+install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
 
-DIST_ROOT="$RPM_BUILD_ROOT"
+DIST_ROOT=$RPM_BUILD_ROOT
 DIST_INSTALL=`pwd`/install.manifest
 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
-%{__make} install DIST_MANIFEST="$DIST_INSTALL"
-%{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
-%{__make} install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
 
+%{__make} install \
+       DIST_MANIFEST=$DIST_INSTALL
+%{__make} install-dev \
+       DIST_MANIFEST=$DIST_INSTALL_DEV
+%{__make} install-lib \
+       DIST_MANIFEST=$DIST_INSTALL_LIB
 
-mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
 echo ".so acl_copy_ext.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
@@ -67,29 +88,34 @@ echo ".so acl_get_file.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
 echo ".so acl_from_text.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
 echo ".so acl_from_text.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
 
-rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
-ln -sf /lib/libacl.so.1.0.0 $RPM_BUILD_ROOT%{_libdir}/libacl.so
+rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
+ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT/lib ; echo libacl.so.*.*.*) \
+       $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
 
-gzip -9nf doc/CHANGES
+%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
-%files
+%files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc doc/*.gz
+%doc README doc/{CHANGES,TODO}
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) /lib/lib*.so.*.*
-%{_mandir}/man1/*
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%{_mandir}/man[15]/*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.la
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.a
+%doc doc/{extensions.txt,libacl.txt}
+%attr(755,root,root) %{_libexecdir}/lib*.so
+%{_libexecdir}/lib*.la
 %{_includedir}/acl
 %{_includedir}/sys/*
-%{_mandir}/man[235]/*
+%{_mandir}/man[23]/*
+
+%files static
+%defattr(644,root,root,755)
+%{_libexecdir}/lib*.a
This page took 0.082059 seconds and 4 git commands to generate.