]> git.pld-linux.org Git - packages/acl.git/blobdiff - acl.spec
- 2.0.18, STBR
[packages/acl.git] / acl.spec
index 064d375af079be699894af670beb38d202d682f9..8e03c28b2a161329b16ce9e81a7c427a93a49af7 100644 (file)
--- a/acl.spec
+++ b/acl.spec
@@ -1,18 +1,22 @@
 Summary:       Command for manipulating access control lists
 Summary(pl):   Komenda do manipulacji listami kontroli dostêpu (ACL)
 Name:          acl
-Version:       1.1.4
+Version:       2.0.18
 Release:       1
 License:       GPL
 Group:         Applications/System
-Group(de):     Applikationen/System
-Group(pl):     Aplikacje/System
 Source0:       ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
 Patch0:                %{name}-miscfix.patch
 URL:           http://oss.sgi.com/projects/xfs/
 BuildRequires: autoconf
+BuildRequires: attr-devel >= 2.0.0
+Requires:      attr
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _bindir         /bin
+%define                _libdir         /lib
+%define                _libexecdir     /usr/lib
+
 %description
 A command (chacl) to manipulate POSIX access control lists under
 Linux.
@@ -22,24 +26,30 @@ Komenda (chacl) do manipulowania zgodnymi z POSIX listami kontroli
 dostêpu (ACL) pod Linuksem.
 
 %package devel
-Summary:       Header files and libraries to manipulate acls
-Summary(pl):   Pliki nag³ówkowe i biblioteki do manipulacji ACL-ami
+Summary:       Header files for acl library
+Summary(pl):   Pliki nag³ówkowe biblioteki acl
 Group:         Development/Libraries
-Group(de):     Entwicklung/Libraries
-Group(es):     Desarrollo/Bibliotecas
-Group(fr):     Development/Librairies
-Group(pl):     Programowanie/Biblioteki
-Group(pt_BR):  Desenvolvimento/Bibliotecas
-Group(ru):     òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
-Group(uk):     òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
+Requires:      %{name} = %{version}
 
 %description devel
-Header files and libraries to develop software which manipulate access
-control lists.
+Header files to develop software which manipulate access control
+lists.
+
+%description devel -l pl
+Pliki nag³ówkowe potrzebne do rozwoju oprogramowania manipuluj±cego
+listami kontroli dostêpu (ACL).
+
+%package static
+Summary:       Static acl library
+Summary(pl):   Statyczna biblioteka acl
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}
 
-%description -l pl devel
-Pliki nag³ówkowe i biblioteki potrzebne do rozwoju oprogramowania
-manipuluj±cego listami kontroli dostêpu (ACL).
+%description static
+Static acl library.
+
+%description static -l pl
+Statyczna biblioteka acl.
 
 %prep
 %setup  -q
@@ -47,7 +57,7 @@ manipuluj
 
 %build
 DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
-autoconf
+%{__autoconf}
 %configure
 
 %{__make}
@@ -59,42 +69,45 @@ install -d $RPM_BUILD_ROOT%{_includedir}/acl
 DIST_ROOT="$RPM_BUILD_ROOT"
 DIST_INSTALL=`pwd`/install.manifest
 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
-export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV 
+DIST_INSTALL_LIB=`pwd`/install-lib.manifest
+export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
 %{__make} install DIST_MANIFEST="$DIST_INSTALL"
 %{__make} install-dev DIST_MANIFEST="$DIST_INSTALL_DEV"
+%{__make} install-lib DIST_MANIFEST="$DIST_INSTALL_LIB"
 
+mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
 rm -f  $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
-echo ".so man3/acl_copy_ext.3" > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
-echo ".so man3/acl_get_fd.3"   > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
-echo ".so man3/acl_get_file.3" > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
-echo ".so man3/acl_from_text.3"        > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
-echo ".so man3/acl_from_text.3"        > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
-
-rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.so
-ln -sf /lib/libacl.so.1.0.0 $RPM_BUILD_ROOT%{_libdir}/libacl.so
+echo ".so acl_copy_ext.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
+echo ".so acl_get_fd.3"        > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
+echo ".so acl_get_file.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
+echo ".so acl_from_text.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
+echo ".so acl_from_text.3"     > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
 
-gzip -9nf doc/CHANGES
+rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
+ln -sf %{_libdir}/libacl.so.1.0.2 $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
-%doc doc/*.gz
-%attr(755,root,root) /bin/*
+%doc doc/CHANGES
 %attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) /lib/lib*.so.*.*
+%attr(755,root,root) %{_libdir}/lib*.so.*.*
 %{_mandir}/man1/*
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.la
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.a
+%attr(755,root,root) %{_libexecdir}/lib*.la
+%attr(755,root,root) %{_libexecdir}/lib*.so
 %{_includedir}/acl
 %{_includedir}/sys/*
 %{_mandir}/man[235]/*
+
+%files static
+%defattr(644,root,root,755)
+%{_libexecdir}/lib*.a
This page took 0.04216 seconds and 4 git commands to generate.