]> git.pld-linux.org Git - packages/Zope-CMFPlone.git/blobdiff - Zope-CMFPlone.spec
- fixed some products of Plone
[packages/Zope-CMFPlone.git] / Zope-CMFPlone.spec
index d5aec92a99544e2f5be30ea57a035f88cdef7705..4db4da53d3b7f7b43053a2fdd66637435bb891fe 100644 (file)
@@ -1,30 +1,35 @@
-%include       /usr/lib/rpm/macros.python
+
 %define                zope_subname    CMFPlone
 Summary:       Free and open source Content Management System based on Zope and CMF
-Summary:       Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
+Summary(pl):   Darmowy i otwarty system zarz±dzania tre¶ci± oparty na Zope i CMF
 Name:          Zope-%{zope_subname}
-Version:       2.0
-%define                sub_ver beta3
-Release:       4.%{sub_ver}.2
+Version:       2.1
+Release:       2
 License:       Zope Public License (ZPL), GPL
 Group:         Networking/Daemons
-Source0:       http://dl.sourceforge.net/plone/%{zope_subname}%{version}-%{sub_ver}.tar.gz
-# Source0-md5: ae47b12f56eb6e4f86ec7b0650e35552
-Patch0:                %{name}-migration.patch
+Source0:       http://dl.sourceforge.net/plone/Plone-%{version}.tar.gz
+# Source0-md5: a72efb9aace662ac8f81f3f66ad7c44c
 URL:           http://www.plone.org/
+BuildRequires: python
 %pyrequires_eq python-modules
-Requires:      Zope-CMF >= 1.4
-Requires:      Zope >= 2.6.2
-Requires:      Zope-BTreeFolder2
-Requires:      Zope-CMFQuickInstallerTool
-Requires:      Zope-ExternalEditor
-Requires:      Zope-Formulator
-Requires:      Zope-GroupUserFolder
-Requires:      Zope-Epoz
+Requires:      i18ndude
+Requires:      Zope-archetypes >= 1.3.4
+Requires:      Zope-kupu >= 1.3
+Requires:      Zope-CMF = 1:1.5.4
+Requires:      Zope >= 2.7.7
+Requires:      Zope-BTreeFolder2 >= 1.0.2
+Requires:      Zope-CMFQuickInstallerTool >= 1.5.5
+Requires:      Zope-Epoz >= 0.8.2
+Requires:      Zope-ExternalEditor >= 0.9.1
+Requires:      Zope-Formulator >= 1.6.2
+Requires:      Zope-GroupUserFolder >= 1:3.4
+Requires:      Zope-PlacelessTranslationService >= 1.2.1
+Requires:      Zope-PloneLanguageTool >= 0.7
 Requires(post,postun): /usr/sbin/installzopeproduct
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 Obsoletes:     Plone
+Obsoletes:     Zope-PortalTransforms
 Conflicts:     CMF
 
 %description
@@ -44,21 +49,24 @@ zabezpieczenia serwisu. Plone dzia
 Pythonem.
 
 %prep
-%setup -q -n %{zope_subname}-%{version}-%{sub_ver}
-%patch0 -p1
-
-%build
+%setup -q -n Plone-%{version}
 # remove dirs - additional packages!
-rm -rf {BTreeFolder2,CMFQuickInstallerTool,ExternalEditor,GroupUserFolder,Formulator}
+# ExternalEditor
+rm -rf {BTreeFolder2,CMFQuickInstallerTool,Formulator,GroupUserFolder,Archetypes,generator,validation}
+rm -rf {PloneLanguageTool,kupu,MimetypesRegistry}
+rm -rf {CMFActionIcons,CMFSetup,CMFUid}
+rm -rf {CMFCalendar,CMFCore,CMFDefault,CMFTopic,DCWorkflow,PortalTransforms,Epoz}
+rm -rf {ExternalEditor,PlacelessTranslationService}
+find . -type d -name debian | xargs rm -rf
 
-mkdir docs docs/CMFPlone docs/CMFFormController docs/i18n
-rm -rf `find . type f -name .cvsignore`
-mv -f CMFPlone/{CREDITS.txt,ChangeLog,HISTORY.txt,INSTALL.txt,README.txt} docs/CMFPlone
-mv -f CMFPlone/docs/* docs/CMFPlone
-mv -f CMFPlone/i18n/ChangeLog docs/i18n
-rm -rf CMFPlone/i18n/{build.bat,msgfmt.exe}
+%build
+mkdir docs docs/CMFPlone docs/CMFFormController docs/PloneErrorReporting
+mv -f CMFPlone/{CREDITS.txt,HISTORY.txt,INSTALL.txt,README.txt,UPGRADE.txt,LICENSE.txt} docs/CMFPlone
+rm -rf CMFPlone/LICENSE.GPL
 mv -f CMFFormController/{AUTHORS,ChangeLog,README.txt} docs/CMFFormController
 rm -rf CMFPlone/docs
+mv -f PloneErrorReporting/{ChangeLog,README.txt} docs/PloneErrorReporting
+rm -rf PloneErrorReporting/LICENSE.txt
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -74,17 +82,23 @@ rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/docs
 rm -rf $RPM_BUILD_ROOT
 
 %post
-for p in CMFPlone CMFActionIcons CMFFormController; do
+for p in ATContentTypes ATReferenceBrowserWidget CMFDynamicViewFTI CMFFormController CMFPlone ExtendedPathIndex; do
        /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
 done
+for p in PloneErrorReporting PloneTranslations ResourceRegistries SecureMailHost; do
+       /usr/sbin/installzopeproduct %{_datadir}/%{name}/$p
+done  
+
 if [ -f /var/lock/subsys/zope ]; then
        /etc/rc.d/init.d/zope restart >&2
 fi
-echo "From /manage interface there should be a 'Select Type to Add' and says Plone Site" >&2
 
 %postun
 if [ "$1" = "0" ]; then
-       for p in CMFPlone CMFActionIcons CMFFormController; do
+       for p in ATContentTypes ATReferenceBrowserWidget CMFDynamicViewFTI CMFFormController CMFPlone ExtendedPathIndex; do
+               /usr/sbin/installzopeproduct -d $p
+       done
+       for p in PloneErrorReporting PloneTranslations ResourceRegistries SecureMailHost; do
                /usr/sbin/installzopeproduct -d $p
        done
        if [ -f /var/lock/subsys/zope ]; then
This page took 0.046275 seconds and 4 git commands to generate.