]> git.pld-linux.org Git - packages/ZendFramework.git/blobdiff - ZendFramework.spec
- updated to 1.8.4
[packages/ZendFramework.git] / ZendFramework.spec
index f1ae8238e7423d88d1384587db6f711723eb78fe..95ea91ddb48b925aa13016c6a4dffef5511aa268 100644 (file)
@@ -2,26 +2,24 @@
 Summary:       Zend Framework
 Summary(pl.UTF-8):     Szkielet Zend
 Name:          ZendFramework
-Version:       1.7.6
-Release:       2
+Version:       1.8.4
+Release:       1
 License:       New BSD License
 Group:         Development/Languages/PHP
 Source0:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: 969c4d51fb3e24b843db4964496bb017
+# Source0-md5: d86770f2e0c1f9c836eb643744e4f0ae
 Source1:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}-manual-en.tar.gz
-# Source1-md5: 09cc4b57b2ae08339c3b2fd86a0f61a2
+# Source1-md5: 341fbd9ded24b38ecf061675919691e1
 Source2:       %{name}-find-lang.sh
-# http://framework.zend.com/issues/browse/ZF-5802
-Source3:       %{name}-Zend_Tool_Framework_Manifest_Exception.php
-Source4:       %{name}-Zend_Tool_Framework_Provider_Exception.php
-Source5:       %{name}-Zend_Tool_Project_Resource.php
 Patch0:                %{name}-additional-locales.patch
-Patch1:                %{name}-db_charset.patch
-Patch2:                %{name}-deps.patch
+Patch1:                %{name}-deps.patch
+Patch2:                %{name}-bug6499.patch
 URL:           http://framework.zend.com/
+BuildRequires: php-pecl-runkit
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
 BuildRequires: sed >= 4.0
 Requires:      php-common >= 4:5.1.4
+Requires:      php-pear
 Requires:      rpm-whiteout >= 1.12
 Obsoletes:     ZendFramework-doc
 BuildArch:     noarch
@@ -86,6 +84,18 @@ szczególności udostępnia implementację serwera bramki do obsługi żądań
 wysyłanych z Flash Playera do serwera i odwzorowywania tych żądań na
 obiekty i metody klas oraz wywołania zwrotne.
 
+%package Zend_Application
+Summary:       Zend_Application - bootstrap facility
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.amf.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Application
+Zend_Application provides a bootstrapping facility for applications
+which provides reusable resources, common- and module-based bootstrap
+classes and dependency checking. It also takes care of setting up the
+PHP environment and introduces autoloading by default.
+
 %package Zend_Auth
 Summary:       Zend_Auth - authentication API
 Summary(pl.UTF-8):     Zend_Auth - API do uwierzytelniania
@@ -149,6 +159,20 @@ fontów lub obrazków z pytaniem o ich powiązania. Klasa Zend_Captcha
 udostępnia różne backendy. Może być używana zarówno samodzielnie, jak
 i w połączeniu z Zend_Form.
 
+%package Zend_CodeGenerator
+Summary:       Zend_CodeGenerator - generate arbitrary code using OO interface
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.codegenerator.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_CodeGenerator
+Zend_CodeGenerator provides facilities to generate arbitrary code
+using an object oriented interface, both to create new code as well as
+to update existing code. While the current implementation is limited
+to generating PHP code, you can easily extend the base class in order
+to provide code generation for other tasks: JavaScript, configuration
+files, apache vhosts, etc.
+
 %package Zend_Config
 Summary:       Zend_Config - access to configuration data
 Summary(pl.UTF-8):     Zend_Config - dostęp do danych konfiguracyjnych
@@ -197,6 +221,15 @@ Model-View-Controller (model-widok-kontroler) i jest wzorcem
 projektowym służącym do oddzielenia logiki aplikacji od logiki
 wyświetlania.
 
+%package Zend_Crypt
+Summary:       Zend_Crypt
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.crypt.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Crypt
+Zend_Crypt
+
 %package Zend_Currency
 Summary:       Zend_Currency - currency representation handling
 Summary(pl.UTF-8):     Zend_Currency - obsługa reprezentacji walut
@@ -603,6 +636,18 @@ Requires:  php-iconv
 %description Zend_Mime
 Zend_Mime is a support class for handling multipart MIME messages.
 
+%package Zend_Navigation
+Summary:       Zend_Navigation - manage trees of pointers to web page
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.navigation.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Navigation
+Zend_Navigation is a component for managing trees of pointers to web
+pages. Simply put: It can be used for creating menus, breadcrumbs,
+links, and sitemaps, or serve as a model for other navigation related
+purposes.
+
 %package Zend_OpenId
 Summary:       Zend_OpenId
 Group:         Development/Languages/PHP
@@ -678,6 +723,32 @@ takes an absolute value and optionally a status message, and then
 calls the adapter with some precalculated values like percentage and
 estimated time left.
 
+%package Zend_Reflection
+Summary:       Zend_Reflection
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.reflection.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Reflection
+Zend_Reflection is a drop-in extension to PHP's own Reflection API,
+providing several additional features:
+ - Ability to retrieve return values types.
+ - Ability to retrieve method and function parameter types.
+ - Ability to retrieve class property types.
+ - DocBlocks gain a Reflection class, allowing introspection of
+   docblocks. This provides the ability to determine what annotation tags
+   have been defined as well as to retrieve their values, and the ability
+   to retrieve the short and long descriptions.
+ - Files gain a Reflection class, allowing introspection of PHP files.
+   This provides the ability to determine what functions and classes are
+   defined in a given file, as well as to instrospect them.
+ - Ability to override any Reflection class with your own variant, for
+   the entire reflection tree you create.
+
+In general, Zend_Reflection works just like the standard Reflection
+API, but provides a few additional methods for retrieving artifacts
+not defined in the Reflection API.
+
 %package Zend_Registry
 Summary:       Zend_Registry
 Group:         Development/Languages/PHP
@@ -1000,6 +1071,19 @@ Requires:        %{name} = %{version}-%{release}
 Zend_Soap component is intended to simplify Web Services development
 for PHP programmers.
 
+%package Zend_Tag
+Summary:       Zend_Tag -- work with taggable Items
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.tag.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Tag
+Zend_Tag is a component suite which provides a facility to work with
+taggable Items. As its base, it provides two classes to work with
+Tags, Zend_Tag_Item and Zend_Tag_ItemList. Additionally, it comes with
+the interface Zend_Tag_Taggable, which allows you to use any of your
+models as a taggable item in conjunction with Zend_Tag.
+
 %package Zend_Text
 Summary:       Zend_Text
 Group:         Development/Languages/PHP
@@ -1178,13 +1262,34 @@ Podręcznik do Zend Framework w języku angielskim.
 mv %{name}-%{version}/documentation .
 find '(' -name '*.php' -o -name '*.xml' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
 %patch0 -p1
-cd library
-%patch1 -p0
-cd -
-%patch2 -p1
+%patch1 -p1
+%patch2 -p0
 
 install %{SOURCE2} find-lang.sh
 
+# cleanup backups after patching
+find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
+
+%build
+# check *.php files syntax using runkit extension
+lint_php() {
+       php -r '
+               $errors = 0;
+               array_shift($argv);
+               echo "Checking syntax of ", count($argv), " PHP files";
+               foreach ($argv as $file) {
+                       echo ".";
+                       if (!runkit_lint_file($file)) {
+                               echo "PHP Lint: $file\n";
+                               $errors++;
+                       }
+               }
+               echo "\nDONE!\n";
+               exit($errors ? 1 : 0);
+       ' $(find library -name '*.php')
+}
+lint_php
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{php_pear_dir}/bin}
@@ -1196,16 +1301,8 @@ cp -a demos/Zend/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 # pear(...) deps won't be satisifed that these libs use extensively.
 cp -a library/* $RPM_BUILD_ROOT%{php_pear_dir}
 
-# copy Zend_Tool from incubator
-cp -a incubator/library/Zend/Tool $RPM_BUILD_ROOT%{php_pear_dir}/Zend
-cp -a incubator/bin/zf.php $RPM_BUILD_ROOT%{php_pear_dir}/bin
-
-# install missing files
-install %{SOURCE3} $RPM_BUILD_ROOT%{php_pear_dir}/Zend/Tool/Framework/Manifest/Exception.php
-install %{SOURCE4} $RPM_BUILD_ROOT%{php_pear_dir}/Zend/Tool/Framework/Provider/Exception.php
-install %{SOURCE5} $RPM_BUILD_ROOT%{php_pear_dir}/Zend/Tool/Project/Resource.php
-
 # create script in bindir
+cp -a bin/zf.php $RPM_BUILD_ROOT%{php_pear_dir}/bin
 cat >> $RPM_BUILD_ROOT%{_bindir}/zf <<-'EOF'
 #!/bin/sh
 cd %{php_pear_dir}/bin
@@ -1243,9 +1340,6 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Service/Abstract.php
 %{php_pear_dir}/Zend/Service/Exception.php
 
-%dir %{php_pear_dir}/Zend/Request
-%{php_pear_dir}/Zend/Request/Interface.php
-
 %{php_pear_dir}/Zend/TimeSync
 %{php_pear_dir}/Zend/TimeSync.php
 
@@ -1258,6 +1352,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Amf
 
+%files Zend_Application
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Application
+%{php_pear_dir}/Zend/Application.php
+
 %files Zend_ProgressBar
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/ProgressBar.php
@@ -1280,6 +1379,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Captcha
 
+%files Zend_CodeGenerator
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/CodeGenerator
+
 %files Zend_Config
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Config
@@ -1294,6 +1397,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Controller
 
+%files Zend_Crypt
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Crypt
+%{php_pear_dir}/Zend/Crypt.php
+
 %files Zend_Currency
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Currency
@@ -1426,6 +1534,11 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Mime
 %{php_pear_dir}/Zend/Mime.php
 
+%files Zend_Navigation
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Navigation
+%{php_pear_dir}/Zend/Navigation.php
+
 %files Zend_OpenId
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/OpenId
@@ -1441,6 +1554,10 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Pdf
 %{php_pear_dir}/Zend/Pdf.php
 
+%files Zend_Reflection
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Reflection
+
 %files Zend_Registry
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Registry.php
@@ -1533,6 +1650,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Soap
 
+%files Zend_Tag
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Tag
+
 %files Zend_Text
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Text
This page took 0.325076 seconds and 4 git commands to generate.