]> git.pld-linux.org Git - packages/ZendFramework.git/blobdiff - ZendFramework.spec
- updated to 1.8.4
[packages/ZendFramework.git] / ZendFramework.spec
index 3c26a634d5a8ecabb173fc7d7251f2c68a3aa341..95ea91ddb48b925aa13016c6a4dffef5511aa268 100644 (file)
@@ -1,28 +1,33 @@
-# TODO
-# - summaries for subpackages
-# - dependencies to subpackages
 %include       /usr/lib/rpm/macros.php
 Summary:       Zend Framework
 Summary(pl.UTF-8):     Szkielet Zend
 Name:          ZendFramework
-Version:       1.6.2
+Version:       1.8.4
 Release:       1
 License:       New BSD License
 Group:         Development/Languages/PHP
-Source0:       http://framework.zend.com/releases/%{name}-%{version}/ZendFramework-%{version}.tar.gz
-# Source0-md5: d1ad283f9190688fcae0daf25625e3cb
+Source0:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: d86770f2e0c1f9c836eb643744e4f0ae
+Source1:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}-manual-en.tar.gz
+# Source1-md5: 341fbd9ded24b38ecf061675919691e1
+Source2:       %{name}-find-lang.sh
+Patch0:                %{name}-additional-locales.patch
+Patch1:                %{name}-deps.patch
+Patch2:                %{name}-bug6499.patch
 URL:           http://framework.zend.com/
+BuildRequires: php-pecl-runkit
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
+BuildRequires: sed >= 4.0
 Requires:      php-common >= 4:5.1.4
-Requires:      php-ctype
-Requires:      php-hash
-Requires:      php-iconv
-Requires:      php-pcre
-Requires:      php-pdo
+Requires:      php-pear
+Requires:      rpm-whiteout >= 1.12
 Obsoletes:     ZendFramework-doc
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# exclude optional dependencies
+%define                _noautoreq      'php(oci8)' 'php(bitset)' 'pear(../application/bootstrap.php)'
+
 %description
 Zend Framework is a high quality and open source framework for
 developing Web Applications and Web Services.
@@ -40,7 +45,8 @@ użyciu i potężną funkcjonalność. Udostępnia rozwiązania do tworzenia
 nowoczesnych, bogatych i bezpiecznych serwisów WWW.
 
 %package Zend_Acl
-Summary:       Zend_Acl
+Summary:       Zend_Acl - ACL functionality and privileges management
+Summary(pl.UTF-8):     Zend_Acl - listy kontroli dostępu i zarządzanie uprawnieniami
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.acl.html
 Requires:      %{name} = %{version}-%{release}
@@ -51,28 +57,81 @@ functionality and privileges management. In general, an application
 may utilize such functionality to control access to certain protected
 objects by other requesting objects.
 
+%description Zend_Acl -l pl.UTF-8
+Zend_Acl udostępnia lekkie i elastyczne listy kontroli dostępu (ACL)
+oraz zarządzanie uprawnieniami. W ogólności aplikacje mogą
+wykorzystywać te funkcje do kontroli dostępu do określonych
+chronionych obiektów przez inne obiekty.
+
+%package Zend_Amf
+Summary:       Zend_Amf - Action Message Format support
+Summary(pl.UTF-8):     Zend_Amf - obsługa formatu AMF (Action Message Format)
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.amf.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Amf
+Zend_Amf provides support for Adobe's Action Message Format (AMF), to
+allow communication between Adobe's Flash Player and PHP.
+Specifically, it provides a gateway server implementation for handling
+requests sent from the Flash Player to the server and mapping these
+requests to object and class methods and arbitrary callbacks.
+
+%description Zend_Amf -l pl.UTF-8
+Zend_Amf dodaje obsługę formatu Adobe Action Message Format (AMF),
+pozwalającego na komunikację między Adobe Flash Playerem a PHP. W
+szczególności udostępnia implementację serwera bramki do obsługi żądań
+wysyłanych z Flash Playera do serwera i odwzorowywania tych żądań na
+obiekty i metody klas oraz wywołania zwrotne.
+
+%package Zend_Application
+Summary:       Zend_Application - bootstrap facility
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.amf.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Application
+Zend_Application provides a bootstrapping facility for applications
+which provides reusable resources, common- and module-based bootstrap
+classes and dependency checking. It also takes care of setting up the
+PHP environment and introduces autoloading by default.
+
 %package Zend_Auth
-Summary:       Zend_Auth
+Summary:       Zend_Auth - authentication API
+Summary(pl.UTF-8):     Zend_Auth - API do uwierzytelniania
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.auth.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-ctype
+# Zend_Auth_Adapter_Http has hard dependency on hash
 
 %description Zend_Auth
 Zend_Auth provides an API for authentication and includes concrete
 authentication adapters for common use case scenarios.
 
+%description Zend_Auth -l pl.UTF-8
+Zend_Auth udostępnia API do uwierzytelniania i zawiera właściwe
+adaptery do uwierzytelniania w popularnych przypadkach użycia.
+
 %package Zend_Cache
-Summary:       Zend_Cache
+Summary:       Zend_Cache - data caching
+Summary(pl.UTF-8):     Zend_Cache - pamięć podręczna dla danych
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.cache.html
 Requires:      %{name} = %{version}-%{release}
+# Zend_Cache_Backend_Apc hard dep on php-pecl-APC
 
 %description Zend_Cache
 Zend_Cache provides a flexible approach toward caching data, including
 support for tagging, manipulating, iterating, and removing subsets.
 
+%description Zend_Cache -l pl.UTF-8
+Zend_Cache zapewnia elastyczną pamięć podręczną dla danych z obsługą
+oznaczania, modyfikowania, iterowania i usuwania podzbiorów.
+
 %package Zend_Captcha
-Summary:       Zend_Captcha
+Summary:       Zend_Captcha - CAPTCHA functionality
+Summary(pl.UTF-8):     Zend_Captcha - funkcjonalność CAPTCHA
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.captcha.html
 Requires:      %{name} = %{version}-%{release}
@@ -89,8 +148,34 @@ asking how they relate. Zend_Captcha aims to provide a variety of
 backends that may be utilized either standalone or in conjunction with
 Zend_Form.
 
+%description Zend_Captcha -l pl.UTF-8
+CAPTCHA (Completely Automated Turing test to tell Computers and Humans
+Apart) to oparta na pytaniu i odpowiedzi metoda upewnienia się, że
+wysyłający informację jest człowiekiem, a nie zautomatyzowanym
+procesem. Zwykle captcha używa się tam, gdzie formularze są wywyłane
+bez uwierzytelniania, ale chcemy zapobiec wysyłaniu spamu. Mają różne
+postaci, np. zadawanie pytań logicznych, pokazywanie wykrzywionych
+fontów lub obrazków z pytaniem o ich powiązania. Klasa Zend_Captcha
+udostępnia różne backendy. Może być używana zarówno samodzielnie, jak
+i w połączeniu z Zend_Form.
+
+%package Zend_CodeGenerator
+Summary:       Zend_CodeGenerator - generate arbitrary code using OO interface
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.codegenerator.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_CodeGenerator
+Zend_CodeGenerator provides facilities to generate arbitrary code
+using an object oriented interface, both to create new code as well as
+to update existing code. While the current implementation is limited
+to generating PHP code, you can easily extend the base class in order
+to provide code generation for other tasks: JavaScript, configuration
+files, apache vhosts, etc.
+
 %package Zend_Config
-Summary:       Zend_Config
+Summary:       Zend_Config - access to configuration data
+Summary(pl.UTF-8):     Zend_Config - dostęp do danych konfiguracyjnych
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.config.html
 Requires:      %{name} = %{version}-%{release}
@@ -99,8 +184,13 @@ Requires:   %{name} = %{version}-%{release}
 Zend_Config is designed to simplify access to and use of configuration
 data within applications.
 
+%description Zend_Config -l pl.UTF-8
+Zend_Config ma na celu ułatwienie dostępu i używania danych
+konfiguracyjnych w aplikacjach.
+
 %package Zend_Console_Getopt
-Summary:       Zend_Console_Getopt
+Summary:       Zend_Console_Getopt - parsing command-line options and arguments
+Summary(pl.UTF-8):     Zend_Console_Getopt - analiza opcji i argumentów linii poleceń
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.console.getopt.html
 Requires:      %{name} = %{version}-%{release}
@@ -109,8 +199,13 @@ Requires:  %{name} = %{version}-%{release}
 The Zend_Console_Getopt class helps command-line applications to parse
 their options and arguments.
 
+%description Zend_Console_Getopt -l pl.UTF-8
+Klasa Zend_Console_Getopt pomaga aplikacjom linii poleceń w analizie
+opcji i argumentów.
+
 %package Zend_Controller
-Summary:       Zend_Controller
+Summary:       Zend_Controller - heart of Model-View-Controller system
+Summary(pl.UTF-8):     Zend_Controller - podstawa systemu Model-View-Controller
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.controller.html
 Requires:      %{name} = %{version}-%{release}
@@ -120,11 +215,28 @@ Zend_Controller is the heart of Zend Framework's MVC system. MVC
 stands for Model-View-Controller and is a design pattern targeted at
 separating application logic from display logic.
 
+%description Zend_Controller -l pl.UTF-8
+Zend_Controller to podstawa systemu MVC szkieletu Zend. MVC oznacza
+Model-View-Controller (model-widok-kontroler) i jest wzorcem
+projektowym służącym do oddzielenia logiki aplikacji od logiki
+wyświetlania.
+
+%package Zend_Crypt
+Summary:       Zend_Crypt
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.crypt.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Crypt
+Zend_Crypt
+
 %package Zend_Currency
-Summary:       Zend_Currency
+Summary:       Zend_Currency - currency representation handling
+Summary(pl.UTF-8):     Zend_Currency - obsługa reprezentacji walut
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.currency.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-iconv
 
 %description Zend_Currency
 Zend_Currency is part of the I18N core of the Zend_Framework. It
@@ -133,8 +245,16 @@ formating. And it also provides additional informational methods which
 include localized informations on currencies, informations about which
 currency is used in which region and more.
 
+%description Zend_Currency -l pl.UTF-8
+Zend_Currency to część rdzenia I18N szkieletu Zend. Obsługuje
+wszystkie zawiłości związane z walutami, reprezentacją i formatowaniem
+jednostek monetarnych. Zawiera także dodatkowe metody informacyjne
+zawierające zlokalizowane informacje o walutach, regionach, w których
+są używane itp.
+
 %package Zend_Date
-Summary:       Zend_Date
+Summary:       Zend_Date - manipulating dates and times
+Summary(pl.UTF-8):     Zend_Date - operacje na dacie i czasie
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.date.html
 Requires:      %{name} = %{version}-%{release}
@@ -146,6 +266,12 @@ information, including date parts, in numerous combinations yielding
 many features and possibilities above and beyond the existing PHP date
 related functions.
 
+%description Zend_Date -l pl.UTF-8
+Komponent Zend_Date oferuje szczegółowe, ale proste API do operacji na
+dacie i czasie. Metody przyjmują szeroki zakres typów informacji, w
+tym części daty w różnych kombinacjach wykraczających poza funkcje
+obróbki daty istniejące w PHP.
+
 %package Zend_Db
 Summary:       Zend_Db
 Group:         Development/Languages/PHP
@@ -236,6 +362,8 @@ Summary:    Zend_Feed
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.feed.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-dom
+Requires:      php-mbstring
 
 %description Zend_Feed
 Zend_Feed provides functionality for consuming RSS and Atom feeds. It
@@ -303,6 +431,8 @@ Summary:    Zend_Gdata
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.gdata.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-ctype
+Requires:      php-dom
 
 %description Zend_Gdata
 Zend_Gdata component is a interface for accessing Google Data from
@@ -319,6 +449,8 @@ Summary:    Zend_Http
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.http.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-ctype
+# Zend_Http_Client_Adapter_Curl has hard dependency on curl
 
 %description Zend_Http
 Zend_Http component provides a client for the HTTP protocol. It
@@ -415,6 +547,7 @@ Summary:    Zend_Locale
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.locale.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-iconv
 
 %description Zend_Locale
 Zend_Locale is the Framework's answer to the question, "How can the
@@ -430,6 +563,7 @@ Summary:    Zend_Log
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.log.html
 Requires:      %{name} = %{version}-%{release}
+# Zend_Log_Formatter_Xml has hard dependency on dom
 
 %description Zend_Log
 Zend_Log is a component for general purpose logging. It supports
@@ -497,10 +631,23 @@ Summary:  Zend_Mime
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.mime.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-iconv
 
 %description Zend_Mime
 Zend_Mime is a support class for handling multipart MIME messages.
 
+%package Zend_Navigation
+Summary:       Zend_Navigation - manage trees of pointers to web page
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.navigation.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Navigation
+Zend_Navigation is a component for managing trees of pointers to web
+pages. Simply put: It can be used for creating menus, breadcrumbs,
+links, and sitemaps, or serve as a model for other navigation related
+purposes.
+
 %package Zend_OpenId
 Summary:       Zend_OpenId
 Group:         Development/Languages/PHP
@@ -535,6 +682,10 @@ Summary:   Zend_Pdf
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.pdf.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-ctype
+Requires:      php-gd
+Requires:      php-iconv
+Requires:      php-zlib
 
 %description Zend_Pdf
 Zend_Pdf module is a PDF (Portable Document Format) manipulation
@@ -558,6 +709,46 @@ Zend_Pdf module supports the following features:
   images are supported).
 - Incremental PDF file update.
 
+%package Zend_ProgressBar
+Summary:       Zend_ProgressBar
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.progressbar.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_ProgressBar
+Zend_ProgressBar is a component to create and update progressbars in
+different environments. It consists of a single backend, which outputs
+the progress through one of the multiple adapters. On every update, it
+takes an absolute value and optionally a status message, and then
+calls the adapter with some precalculated values like percentage and
+estimated time left.
+
+%package Zend_Reflection
+Summary:       Zend_Reflection
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.reflection.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Reflection
+Zend_Reflection is a drop-in extension to PHP's own Reflection API,
+providing several additional features:
+ - Ability to retrieve return values types.
+ - Ability to retrieve method and function parameter types.
+ - Ability to retrieve class property types.
+ - DocBlocks gain a Reflection class, allowing introspection of
+   docblocks. This provides the ability to determine what annotation tags
+   have been defined as well as to retrieve their values, and the ability
+   to retrieve the short and long descriptions.
+ - Files gain a Reflection class, allowing introspection of PHP files.
+   This provides the ability to determine what functions and classes are
+   defined in a given file, as well as to instrospect them.
+ - Ability to override any Reflection class with your own variant, for
+   the entire reflection tree you create.
+
+In general, Zend_Reflection works just like the standard Reflection
+API, but provides a few additional methods for retrieving artifacts
+not defined in the Reflection API.
+
 %package Zend_Registry
 Summary:       Zend_Registry
 Group:         Development/Languages/PHP
@@ -575,6 +766,8 @@ Summary:    Zend_Rest
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.rest.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-ctype
+Requires:      php-dom
 
 %description Zend_Rest
 REST Web Services use service-specific XML formats. These ad-hoc
@@ -590,6 +783,9 @@ Summary:    Zend_Search_Lucene
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.search.lucene.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-ctype
+Requires:      php-dom
+Requires:      php-iconv
 
 %description Zend_Search_Lucene
 Zend_Search_Lucene is a general purpose text search engine. Since it
@@ -646,6 +842,7 @@ Summary:    Zend_Service_Amazon
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.service.amazon.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-dom
 
 %description Zend_Service_Amazon
 Zend_Service_Amazon is a simple API for using Amazon web services.
@@ -662,6 +859,7 @@ Summary:    Zend_Service_Audioscrobbler
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.service.audioscrobbler.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-iconv
 
 %description Zend_Service_Audioscrobbler
 Zend_Service_Audioscrobbler is a simple API for using the
@@ -674,6 +872,7 @@ Summary:    Zend_Service_Delicious
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.service.delicious.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-dom
 
 %description Zend_Service_Delicious
 Zend_Service_Delicious is simple API for using del.icio.us XML and
@@ -686,12 +885,14 @@ Summary:  Zend_Service_Flickr
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.service.delicious.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-dom
+Requires:      php-iconv
 
 %description Zend_Service_Flickr
 Zend_Service_Flickr is a simple API for using the Flickr REST Web
 Service. In order to use the Flickr web services, you must have an API
 key. To obtain a key, visit the Flickr API Documentation
-(http://www.flickr.com/services/api/).
+<http://www.flickr.com/services/api/>.
 
 %package Zend_Service_Nirvanix
 Summary:       Zend_Service_Nirvanix
@@ -744,6 +945,7 @@ Summary:    Zend_Service_Simpy
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.service.simpy.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-dom
 
 %description Zend_Service_Simpy
 Zend_Service_Simpy is a lightweight wrapper for the free REST API
@@ -817,11 +1019,25 @@ you first need to create a new Technorati account
 (http://technorati.com/signup/), then visit the API Key section
 (http://technorati.com/developers/apikey.html).
 
+%package Zend_Service_Twitter
+Summary:       Zend_Service_Twitter
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.service.technorati.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service_Twitter
+Zend_Service_Twitter provides a client for the Twitter REST API.
+Zend_Service_Twitter will allow you to query the public timeline and
+if you provide a username and password for Twitter it will allow you
+to get and update your status, reply to friends, direct message
+friends, mark tweets as favorite and much more.
+
 %package Zend_Service_Yahoo
 Summary:       Zend_Service_Yahoo
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.service.yahoo.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-dom
 
 %description Zend_Service_Yahoo
 Zend_Service_Yahoo is a simple API for using many of the Yahoo! REST
@@ -855,6 +1071,19 @@ Requires: %{name} = %{version}-%{release}
 Zend_Soap component is intended to simplify Web Services development
 for PHP programmers.
 
+%package Zend_Tag
+Summary:       Zend_Tag -- work with taggable Items
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.tag.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Tag
+Zend_Tag is a component suite which provides a facility to work with
+taggable Items. As its base, it provides two classes to work with
+Tags, Zend_Tag_Item and Zend_Tag_ItemList. Additionally, it comes with
+the interface Zend_Tag_Taggable, which allows you to use any of your
+models as a taggable item in conjunction with Zend_Tag.
+
 %package Zend_Text
 Summary:       Zend_Text
 Group:         Development/Languages/PHP
@@ -872,11 +1101,25 @@ Summary: Zend_Test
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.test.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-PHPUnit
 
 %description Zend_Test
 Zend_Test provides tools to facilitate unit testing of your Zend
 Framework applications.
 
+%package Zend_Tool
+Summary:       Zend_Tool
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/wiki/display/ZFDEV/Zend_Tool
+Requires:      %{name} = %{version}-%{release}
+Requires:      /usr/bin/php
+
+%description Zend_Tool
+Zend_Tool component is intended to simplify project development for
+PHP programmers.
+
+Please note that this component is part of Zend Framework incubator.
+
 %package Zend_Translate
 Summary:       Zend_Translate
 Group:         Development/Languages/PHP
@@ -911,6 +1154,7 @@ Summary:   Zend_Uri
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.uri.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-ctype
 
 %description Zend_Uri
 Zend_Uri is a component that aids in manipulating and validating
@@ -923,6 +1167,7 @@ Summary:   Zend_Validate
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.validate.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-ctype
 
 %description Zend_Validate
 The Zend_Validate component provides a set of commonly needed
@@ -979,9 +1224,11 @@ Summary:  Zend_XmlRpc
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.xmlrpc.html
 Requires:      %{name} = %{version}-%{release}
+Requires:      php-dom
+Requires:      php-iconv
 
 %description Zend_XmlRpc
-From its home page (http://www.xmlrpc.com/), XML-RPC is described as a
+From its home page <http://www.xmlrpc.com/>, XML-RPC is described as a
 "...remote procedure calling using HTTP as the transport and XML as
 the encoding. XML-RPC is designed to be as simple as possible, while
 allowing complex data structures to be transmitted, processed and
@@ -999,17 +1246,75 @@ Demos for Zend Framework.
 %description demos -l pl.UTF-8
 Programy demonstracyjne dla szkieletu Zend Framework.
 
+%package manual-en
+Summary:       Zend Framework manual in English language
+Summary(pl.UTF-8):     Podręcznik do Zend Framework w języku angielskim
+Group:         Documentation
+
+%description manual-en
+Zend Framework manual in English language.
+
+%description manual-en -l pl.UTF-8
+Podręcznik do Zend Framework w języku angielskim.
+
 %prep
-%setup -q
+%setup -q -a1
+mv %{name}-%{version}/documentation .
+find '(' -name '*.php' -o -name '*.xml' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
+%patch0 -p1
+%patch1 -p1
+%patch2 -p0
+
+install %{SOURCE2} find-lang.sh
+
+# cleanup backups after patching
+find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
+
+%build
+# check *.php files syntax using runkit extension
+lint_php() {
+       php -r '
+               $errors = 0;
+               array_shift($argv);
+               echo "Checking syntax of ", count($argv), " PHP files";
+               foreach ($argv as $file) {
+                       echo ".";
+                       if (!runkit_lint_file($file)) {
+                               echo "PHP Lint: $file\n";
+                               $errors++;
+                       }
+               }
+               echo "\nDONE!\n";
+               exit($errors ? 1 : 0);
+       ' $(find library -name '*.php')
+}
+lint_php
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{php_pear_dir}}
+install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{php_pear_dir}/bin}
+install -d $RPM_BUILD_ROOT%{_bindir}
 cp -a demos/Zend/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 # library should be in include_path if used, so we use already defined %{php_pear_dir}
+# NOTE: we could use %{php_data_dir} as of php-common-4:5.2.8-3, but then
+# pear(...) deps won't be satisifed that these libs use extensively.
 cp -a library/* $RPM_BUILD_ROOT%{php_pear_dir}
 
+# create script in bindir
+cp -a bin/zf.php $RPM_BUILD_ROOT%{php_pear_dir}/bin
+cat >> $RPM_BUILD_ROOT%{_bindir}/zf <<-'EOF'
+#!/bin/sh
+cd %{php_pear_dir}/bin
+exec /usr/bin/php -d Safe_mode=off zf.php ${1:+"$@"}
+EOF
+
+./find-lang.sh %{name}.lang
+
+# manual
+install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-en
+cp -a documentation/manual/core/en/* $RPM_BUILD_ROOT%{_docdir}/%{name}-en
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -1024,14 +1329,17 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Server/Abstract.php
 %{php_pear_dir}/Zend/Server/Exception.php
 %{php_pear_dir}/Zend/Server/Interface.php
+%{php_pear_dir}/Zend/Server/Definition.php
+%dir %{php_pear_dir}/Zend/Server/Method
+%{php_pear_dir}/Zend/Server/Method/Callback.php
+%{php_pear_dir}/Zend/Server/Method/Definition.php
+%{php_pear_dir}/Zend/Server/Method/Parameter.php
+%{php_pear_dir}/Zend/Server/Method/Prototype.php
 
 %dir %{php_pear_dir}/Zend/Service
 %{php_pear_dir}/Zend/Service/Abstract.php
 %{php_pear_dir}/Zend/Service/Exception.php
 
-%dir %{php_pear_dir}/Zend/Request
-%{php_pear_dir}/Zend/Request/Interface.php
-
 %{php_pear_dir}/Zend/TimeSync
 %{php_pear_dir}/Zend/TimeSync.php
 
@@ -1040,6 +1348,20 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Acl
 %{php_pear_dir}/Zend/Acl.php
 
+%files Zend_Amf
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Amf
+
+%files Zend_Application
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Application
+%{php_pear_dir}/Zend/Application.php
+
+%files Zend_ProgressBar
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/ProgressBar.php
+%{php_pear_dir}/Zend/ProgressBar
+
 %files Zend_Auth
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Auth
@@ -1049,11 +1371,18 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Cache
 %{php_pear_dir}/Zend/Cache.php
+# Zend_Server_Cache subpackage?
+# but not listed as separate component on doc
+%{php_pear_dir}/Zend/Server/Cache.php
 
 %files Zend_Captcha
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Captcha
 
+%files Zend_CodeGenerator
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/CodeGenerator
+
 %files Zend_Config
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Config
@@ -1068,6 +1397,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Controller
 
+%files Zend_Crypt
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Crypt
+%{php_pear_dir}/Zend/Crypt.php
+
 %files Zend_Currency
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Currency
@@ -1113,7 +1447,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Filter
 %{php_pear_dir}/Zend/Filter.php
-#???
 %exclude %{php_pear_dir}/Zend/Filter/Input.php
 
 %files Zend_Filter_Input
@@ -1159,10 +1492,23 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Loader
 %{php_pear_dir}/Zend/Loader.php
 
-%files Zend_Locale
+%files Zend_Locale -f %{name}.lang
 %defattr(644,root,root,755)
-%{php_pear_dir}/Zend/Locale
+%dir %{php_pear_dir}/Zend/Locale
 %{php_pear_dir}/Zend/Locale.php
+%{php_pear_dir}/Zend/Locale/Exception.php
+%{php_pear_dir}/Zend/Locale/Format.php
+%{php_pear_dir}/Zend/Locale/Math.php
+%{php_pear_dir}/Zend/Locale/Math
+
+%{php_pear_dir}/Zend/Locale/Data.php
+%dir %{php_pear_dir}/Zend/Locale/Data
+%{php_pear_dir}/Zend/Locale/Data/Translation.php
+%{php_pear_dir}/Zend/Locale/Data/characters.xml
+%{php_pear_dir}/Zend/Locale/Data/plurals.xml
+%{php_pear_dir}/Zend/Locale/Data/root.xml
+%{php_pear_dir}/Zend/Locale/Data/supplementalData.xml
+%{php_pear_dir}/Zend/Locale/Data/telephoneCodeData.xml
 
 %files Zend_Log
 %defattr(644,root,root,755)
@@ -1188,6 +1534,11 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Mime
 %{php_pear_dir}/Zend/Mime.php
 
+%files Zend_Navigation
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Navigation
+%{php_pear_dir}/Zend/Navigation.php
+
 %files Zend_OpenId
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/OpenId
@@ -1203,6 +1554,10 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Pdf
 %{php_pear_dir}/Zend/Pdf.php
 
+%files Zend_Reflection
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Reflection
+
 %files Zend_Registry
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Registry.php
@@ -1233,6 +1588,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files Zend_Service_Audioscrobbler
 %defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/Audioscrobbler
 %{php_pear_dir}/Zend/Service/Audioscrobbler.php
 
 %files Zend_Service_Delicious
@@ -1275,6 +1631,11 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Service/Technorati
 %{php_pear_dir}/Zend/Service/Technorati.php
 
+%files Zend_Service_Twitter
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/Twitter
+%{php_pear_dir}/Zend/Service/Twitter.php
+
 %files Zend_Service_Yahoo
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/Yahoo
@@ -1289,6 +1650,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Soap
 
+%files Zend_Tag
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Tag
+
 %files Zend_Text
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Text
@@ -1297,6 +1662,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Test
 
+%files Zend_Tool
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/zf
+%{php_pear_dir}/bin/zf.php
+%{php_pear_dir}/Zend/Tool
+
 %files Zend_Translate
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Translate
@@ -1332,3 +1703,7 @@ rm -rf $RPM_BUILD_ROOT
 %files demos
 %defattr(644,root,root,755)
 %{_examplesdir}/%{name}-%{version}
+
+%files manual-en
+%defattr(644,root,root,755)
+%doc %{_docdir}/%{name}-en
This page took 1.577264 seconds and 4 git commands to generate.