]> git.pld-linux.org Git - packages/ZendFramework.git/blobdiff - ZendFramework.spec
up to 1.12.11
[packages/ZendFramework.git] / ZendFramework.spec
index 26199e2a55bcb2ba355db175e58294fb840fd404..91e2cfe0034104976d002ac75aee2bb37f06eb43 100644 (file)
@@ -1,3 +1,6 @@
+# TODO
+# - drop pear autogenerated deps and fill deps based on official doc:
+#   http://framework.zend.com/manual/1.12/en/requirements.introduction.html
 #
 # Conditional build:
 %bcond_without tests   # do not perform "make test"
@@ -5,26 +8,28 @@
 # TODO
 # - check Zend/Pdf/FileParser/Image/Jpeg.php and Zend/Pdf/FileParser/Image/Tiff.php
 #   presence in Zend/Pdf/Image.php after update [not implemented in 1.10.2)
+%define                php_min_version 5.2.11
 %include       /usr/lib/rpm/macros.php
 Summary:       Zend Framework
 Summary(pl.UTF-8):     Szkielet Zend
 Name:          ZendFramework
-Version:       1.11.1
+Version:       1.12.11
 Release:       1
 License:       New BSD License
 Group:         Development/Languages/PHP
 Source0:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: d1c4f5742c7650dea31dff5e11f53599
+# Source0-md5: fb05390d22bb0ab9b340c456c4b25af5
 Source1:       http://framework.zend.com/releases/%{name}-%{version}/%{name}-%{version}-manual-en.tar.gz
-# Source1-md5: 832b857955feaa2993f0caf9986c0825
+# Source1-md5: ca6ab6b20ca0a0f32b680c8111404286
 Source2:       %{name}-find-lang.sh
 Patch0:                %{name}-additional-locales.patch
 Patch1:                %{name}-deps.patch
 URL:           http://framework.zend.com/
 BuildRequires: /usr/bin/php
 BuildRequires: rpm-php-pearprov >= 4.4.2-11
+BuildRequires: rpmbuild(macros) >= 1.654
 BuildRequires: sed >= 4.0
-Requires:      php-common >= 4:5.1.4
+Requires:      php(core) >= %{php_min_version}
 Requires:      php-pear
 Requires:      rpm-whiteout >= 1.32
 Obsoletes:     ZendFramework-doc
@@ -35,9 +40,10 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _noautopear     pear(../application/bootstrap.php)
 
 # bad code
-%define                _bad_deps_1_10 pear(Zend/Pdf/FileParser/Image/Jpeg.php) pear(Zend/Pdf/FileParser/Image/Tiff.php)
-%define                _bad_deps_1_10_2 pear(Zend/Serializer/Excception.php) pear(Zend/Services/DeveloperGarden/Response/Exception.php)
-%define                _noautodeps     %{?_bad_deps_1_10} %{?_bad_deps_1_10_2}
+%define                _bad_deps_1_10 Zend/Pdf/FileParser/Image/Jpeg.php Zend/Pdf/FileParser/Image/Tiff.php
+%define                _bad_deps_1_10_2 Zend/Serializer/Excception.php Zend/Services/DeveloperGarden/Response/Exception.php
+%define                _bad_deps_1_12_1 Zend/Service/Rackspace/Exception.php Zend/Service/Rackspace/Files.php Exception/InvalidArgumentException.php Zend/Loader/Exception/../Exception.php Zend/Service/Console/Command.php Zend/Service/Console/Exception.php Zend/Service/Log/Exception.php Zend/Service/Log/Formatter/Interface.php Zend/Service/Log/Writer/Abstract.php Zend/Service/Management/Exception.php
+%define                _noautoreq_pear %{?_bad_deps_1_10} %{?_bad_deps_1_10_2} %{?_bad_deps_1_12_1}
 
 # exclude optional php dependencies
 %define                _noautophp      php-oci8 php-bitset
@@ -119,7 +125,7 @@ Summary(pl.UTF-8):  Zend_Auth - API do uwierzytelniania
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.auth.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-ctype
+Requires:      php(ctype)
 # Zend_Auth_Adapter_Http has hard dependency on hash
 
 %description Zend_Auth
@@ -132,7 +138,7 @@ adaptery do uwierzytelniania w popularnych przypadkach użycia.
 
 %package Zend_Barcode
 Summary:       Zend_Barcode - barcode generator
-Summary(pl.UTF_8):     Zend_Barcode - generator kodów kreskowych
+Summary(pl.UTF-8):     Zend_Barcode - generator kodów kreskowych
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.barcode.html
 Requires:      %{name} = %{version}-%{release}
@@ -282,7 +288,7 @@ Summary(pl.UTF-8):  Zend_Currency - obsługa reprezentacji walut
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.currency.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-iconv
+Requires:      php(iconv)
 
 %description Zend_Currency
 Zend_Currency is part of the I18N core of the Zend_Framework. It
@@ -403,13 +409,25 @@ Zend_Exception is a base exception class. All exceptions thrown by
 Zend Framework classes should throw an exception that derives from the
 base class Zend_Exception.
 
+%package Zend_EventManager
+Summary:       Zend_EventManager
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.event-manager.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_EventManager
+Zend_EventManager is a component designed for the following use cases:
+- Implementing simple subject/observer patterns.
+- Implementing Aspect-Oriented designs.
+- Implementing event-driven architectures.
+
 %package Zend_Feed
 Summary:       Zend_Feed
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.feed.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-dom
-Requires:      php-mbstring
+Requires:      php(dom)
+Requires:      php(mbstring)
 
 %description Zend_Feed
 Zend_Feed provides functionality for consuming RSS and Atom feeds. It
@@ -477,8 +495,8 @@ Summary:    Zend_Gdata
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.gdata.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-ctype
-Requires:      php-dom
+Requires:      php(ctype)
+Requires:      php(dom)
 
 %description Zend_Gdata
 Zend_Gdata component is a interface for accessing Google Data from
@@ -495,7 +513,7 @@ Summary:    Zend_Http
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.http.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-ctype
+Requires:      php(ctype)
 # Zend_Http_Client_Adapter_Curl has hard dependency on curl
 
 %description Zend_Http
@@ -593,7 +611,7 @@ Summary:    Zend_Locale
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.locale.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-iconv
+Requires:      php(iconv)
 
 %description Zend_Locale
 Zend_Locale is the Framework's answer to the question, "How can the
@@ -695,11 +713,23 @@ Summary:  Zend_Mime
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.mime.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-iconv
+Requires:      php(iconv)
 
 %description Zend_Mime
 Zend_Mime is a support class for handling multipart MIME messages.
 
+%package Zend_Mobile_Push
+Summary:       Zend_Mobile_Push
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.mobile.push.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Mobile_Push
+Zend_Mobile_Push provides the ability for sending push notifications
+to the vendor specific notification servers. Currently this list
+includes APNS (iTouch/iPad/iPhone), GCM (Google Android) and MPNS
+(Windows Phone).
+
 %package Zend_Navigation
 Summary:       Zend_Navigation - manage trees of pointers to web page
 Group:         Development/Languages/PHP
@@ -736,9 +766,9 @@ Group:              Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.openid.html
 Requires:      %{name} = %{version}-%{release}
 # needed for dh keys: any of these tree can do for
-Suggests:      php-bcmath
-Suggests:      php-gmp
-Suggests:      php-openssl
+Suggests:      php(bcmath)
+Suggests:      php(gmp)
+Suggests:      php(openssl)
 
 %description Zend_OpenId
 Zend_OpenId is a Zend Framework component that provides a simple API
@@ -768,10 +798,10 @@ Summary:  Zend_Pdf
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.pdf.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-ctype
-Requires:      php-gd
-Requires:      php-iconv
-Requires:      php-zlib
+Requires:      php(ctype)
+Requires:      php(gd)
+Requires:      php(iconv)
+Requires:      php(zlib)
 
 %description Zend_Pdf
 Zend_Pdf module is a PDF (Portable Document Format) manipulation
@@ -866,8 +896,8 @@ Summary:    Zend_Rest
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.rest.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-ctype
-Requires:      php-dom
+Requires:      php(ctype)
+Requires:      php(dom)
 
 %description Zend_Rest
 REST Web Services use service-specific XML formats. These ad-hoc
@@ -883,9 +913,9 @@ Summary:    Zend_Search_Lucene
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.search.lucene.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-ctype
-Requires:      php-dom
-Requires:      php-iconv
+Requires:      php(ctype)
+Requires:      php(dom)
+Requires:      php(iconv)
 
 %description Zend_Search_Lucene
 Zend_Search_Lucene is a general purpose text search engine. Since it
@@ -974,7 +1004,7 @@ Summary:   Zend_Service_Amazon
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.service.amazon.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-dom
+Requires:      php(dom)
 
 %description Zend_Service_Amazon
 Zend_Service_Amazon is a simple API for using Amazon web services.
@@ -991,7 +1021,7 @@ Summary:   Zend_Service_Audioscrobbler
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.service.audioscrobbler.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-iconv
+Requires:      php(iconv)
 
 %description Zend_Service_Audioscrobbler
 Zend_Service_Audioscrobbler is a simple API for using the
@@ -1004,7 +1034,7 @@ Summary:  Zend_Service_Delicious
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.service.delicious.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-dom
+Requires:      php(dom)
 
 %description Zend_Service_Delicious
 Zend_Service_Delicious is simple API for using del.icio.us XML and
@@ -1045,8 +1075,8 @@ Summary:  Zend_Service_Flickr
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.service.delicious.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-dom
-Requires:      php-iconv
+Requires:      php(dom)
+Requires:      php(iconv)
 
 %description Zend_Service_Flickr
 Zend_Service_Flickr is a simple API for using the Flickr REST Web
@@ -1095,6 +1125,16 @@ register for an account (https://www.nirvanix.com/signUpSingle.aspx).
 After registering, you will receive a Username, Password, and
 Application Key. All three are required to use Zend_Service_Nirvanix.
 
+%package Zend_Service_Rackspace
+Summary:       Zend_Service_Rackspace
+Group:         Development/Languages/PHP
+URL:           http://framework.zend.com/manual/en/zend.service.rackspace.html
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service_Rackspace
+The Zend_Service_Rackspace is a class that provides a simple API to
+manage the Rackspace services Cloud Files and Cloud Servers.
+
 %package Zend_Service_ReCaptcha
 Summary:       Zend_Service_ReCaptcha
 Group:         Development/Languages/PHP
@@ -1137,7 +1177,7 @@ Summary:  Zend_Service_Simpy
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.service.simpy.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-dom
+Requires:      php(dom)
 
 %description Zend_Service_Simpy
 Zend_Service_Simpy is a lightweight wrapper for the free REST API
@@ -1164,6 +1204,13 @@ create an account on the slideshare.net servers in order to receive an
 API key, username, password and shared secret value -- all of which
 are needed in order to use the Zend_Service_SlideShare component.
 
+%package Zend_Service_SqlAzure
+Summary:       Zend_Service_
+Group:         Development/Languages/PHP
+Requires:      %{name} = %{version}-%{release}
+
+%description Zend_Service_SqlAzure
+
 %package Zend_Service_StrikeIron
 Summary:       Zend_Service_StrikeIron
 Group:         Development/Languages/PHP
@@ -1243,7 +1290,7 @@ Summary:  Zend_Service_Yahoo
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.service.yahoo.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-dom
+Requires:      php(dom)
 
 %description Zend_Service_Yahoo
 Zend_Service_Yahoo is a simple API for using many of the Yahoo! REST
@@ -1307,7 +1354,6 @@ Summary:  Zend_Test
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.test.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-PHPUnit
 
 %description Zend_Test
 Zend_Test provides tools to facilitate unit testing of your Zend
@@ -1372,7 +1418,7 @@ Summary:  Zend_Uri
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.uri.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-ctype
+Requires:      php(ctype)
 
 %description Zend_Uri
 Zend_Uri is a component that aids in manipulating and validating
@@ -1385,7 +1431,7 @@ Summary:  Zend_Validate
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.validate.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-ctype
+Requires:      php(ctype)
 
 %description Zend_Validate
 The Zend_Validate component provides a set of commonly needed
@@ -1442,8 +1488,8 @@ Summary:  Zend_XmlRpc
 Group:         Development/Languages/PHP
 URL:           http://framework.zend.com/manual/en/zend.xmlrpc.html
 Requires:      %{name} = %{version}-%{release}
-Requires:      php-dom
-Requires:      php-iconv
+Requires:      php(dom)
+Requires:      php(iconv)
 
 %description Zend_XmlRpc
 From its home page <http://www.xmlrpc.com/>, XML-RPC is described as a
@@ -1493,7 +1539,7 @@ find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 %if %{with tests}
 lint_php() {
        for a in $(find library -name '*.php'); do
-               php -l $a
+               php -n -l $a
        done
 }
 lint_php
@@ -1511,7 +1557,7 @@ cp -a demos/Zend/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 cp -a library/* $RPM_BUILD_ROOT%{php_pear_dir}
 
 # create script in bindir
-cp -a bin/zf.php $RPM_BUILD_ROOT%{php_pear_dir}/bin
+install -p bin/zf.php $RPM_BUILD_ROOT%{php_pear_dir}/bin
 cat >> $RPM_BUILD_ROOT%{_bindir}/zf <<-'EOF'
 #!/bin/sh
 cd %{php_pear_dir}/bin
@@ -1529,7 +1575,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc LICENSE.txt README.txt
+%doc LICENSE.txt README.md
 %dir %{php_pear_dir}/Zend
 
 %files Zend_Acl
@@ -1582,6 +1628,7 @@ rm -rf $RPM_BUILD_ROOT
 
 # subpackages?
 %{php_pear_dir}/Zend/Cloud/DocumentService
+%{php_pear_dir}/Zend/Cloud/Infrastructure
 %{php_pear_dir}/Zend/Cloud/QueueService
 %{php_pear_dir}/Zend/Cloud/StorageService
 
@@ -1641,6 +1688,13 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Exception.php
 
+%files Zend_EventManager
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/EventManager
+
+# package here, as for now only EventManager uses Stdlib classes
+%{php_pear_dir}/Zend/Stdlib
+
 %files Zend_Feed
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Feed
@@ -1674,10 +1728,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Http
 
+%if 0
 %files Zend_InfoCard
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/InfoCard
 %{php_pear_dir}/Zend/InfoCard.php
+%endif
 
 %files Zend_Json
 %defattr(644,root,root,755)
@@ -1712,13 +1768,21 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{php_pear_dir}/Zend/Locale/Data
 %{php_pear_dir}/Zend/Locale/Data/Translation.php
 %{php_pear_dir}/Zend/Locale/Data/characters.xml
+%{php_pear_dir}/Zend/Locale/Data/coverageLevels.xml
+%{php_pear_dir}/Zend/Locale/Data/dayPeriods.xml
+%{php_pear_dir}/Zend/Locale/Data/genderList.xml
+%{php_pear_dir}/Zend/Locale/Data/languageInfo.xml
 %{php_pear_dir}/Zend/Locale/Data/likelySubtags.xml
-%{php_pear_dir}/Zend/Locale/Data/metazoneInfo.xml
+%{php_pear_dir}/Zend/Locale/Data/metaZones.xml
 %{php_pear_dir}/Zend/Locale/Data/numberingSystems.xml
+%{php_pear_dir}/Zend/Locale/Data/ordinals.xml
+%{php_pear_dir}/Zend/Locale/Data/plurals.xml
 %{php_pear_dir}/Zend/Locale/Data/postalCodeData.xml
 %{php_pear_dir}/Zend/Locale/Data/root.xml
 %{php_pear_dir}/Zend/Locale/Data/supplementalData.xml
+%{php_pear_dir}/Zend/Locale/Data/supplementalMetadata.xml
 %{php_pear_dir}/Zend/Locale/Data/telephoneCodeData.xml
+%{php_pear_dir}/Zend/Locale/Data/windowsZones.xml
 
 %files Zend_Log
 %defattr(644,root,root,755)
@@ -1749,6 +1813,12 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Mime
 %{php_pear_dir}/Zend/Mime.php
 
+%files Zend_Mobile_Push
+%defattr(644,root,root,755)
+%dir %{php_pear_dir}/Zend/Mobile
+%{php_pear_dir}/Zend/Mobile/Exception.php
+%{php_pear_dir}/Zend/Mobile/Push
+
 %files Zend_Navigation
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Navigation
@@ -1827,6 +1897,9 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Service/Abstract.php
 %{php_pear_dir}/Zend/Service/Exception.php
 
+# subpackage?
+%{php_pear_dir}/Zend/Service/Console
+
 %files Zend_Service_Akismet
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/Akismet.php
@@ -1864,10 +1937,16 @@ rm -rf $RPM_BUILD_ROOT
 %{php_pear_dir}/Zend/Service/LiveDocx
 %{php_pear_dir}/Zend/Service/LiveDocx.php
 
+%if 0
 %files Zend_Service_Nirvanix
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/Nirvanix
 %{php_pear_dir}/Zend/Service/Nirvanix.php
+%endif
+
+%files Zend_Service_Rackspace
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/Rackspace
 
 %files Zend_Service_ReCaptcha
 %defattr(644,root,root,755)
@@ -1878,16 +1957,22 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/ShortUrl
 
+%if 0
 %files Zend_Service_Simpy
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/Simpy
 %{php_pear_dir}/Zend/Service/Simpy.php
+%endif
 
 %files Zend_Service_SlideShare
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/SlideShare
 %{php_pear_dir}/Zend/Service/SlideShare.php
 
+%files Zend_Service_SqlAzure
+%defattr(644,root,root,755)
+%{php_pear_dir}/Zend/Service/SqlAzure
+
 %files Zend_Service_StrikeIron
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/Service/StrikeIron
@@ -1976,6 +2061,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{php_pear_dir}/Zend/XmlRpc
 
+%dir %{php_pear_dir}/Zend/Xml
+%{php_pear_dir}/Zend/Xml/Exception.php
+%{php_pear_dir}/Zend/Xml/Security.php
+
 %files demos
 %defattr(644,root,root,755)
 %{_examplesdir}/%{name}-%{version}
This page took 0.0844 seconds and 4 git commands to generate.