]> git.pld-linux.org Git - packages/X11-driver-nvidia.git/blobdiff - X11-driver-nvidia.spec
- more AC-branch merge
[packages/X11-driver-nvidia.git] / X11-driver-nvidia.spec
index 18ff89e21879067e2d08aeaada2f3dc7f8a2b7e7..d3da25a211a320d602e18ec9892a7a0523d820ca 100644 (file)
@@ -1,3 +1,5 @@
+# TODO
+# - missing CC quotes somewhere: ccache: invalid option -- S
 #
 # Conditional build:
 %bcond_without dist_kernel     # without distribution kernel
@@ -6,9 +8,14 @@
 %bcond_without incall          # include all tarballs
 %bcond_without userspace       # don't build userspace programs
 %bcond_with    verbose         # verbose build (V=1)
+%bcond_with    grsec_kernel    # build for kernel-grsecurity
+#
+%if %{with kernel} && %{with dist_kernel} && %{with grsec_kernel}
+%define        alt_kernel      grsecurity
+%endif
 #
 %define                _nv_ver         1.0
-%define                _nv_rel         9629
+%define                _nv_rel         9746
 %define                _min_x11        6.7.0
 %define                _rel            1
 #
 %endif
 %endif
 
-%if %{without kernel}
-%undefine with_dist_kernel
-%endif
-#
 Summary:       Linux Drivers for NVIDIA GeForce/Quadro Chips
 Summary(pl):   Sterowniki do kart graficznych NVIDIA GeForce/Quadro
 Name:          X11-driver-nvidia
@@ -40,11 +43,11 @@ Group:              X11
 # why not pkg0!?
 %if %{need_x86}
 Source0:       http://download.nvidia.com/XFree86/Linux-x86/%{_nv_ver}-%{_nv_rel}/NVIDIA-Linux-x86-%{_nv_ver}-%{_nv_rel}-pkg1.run
-# Source0-md5: a9e6097e84a0d6310e5a71c58249ccae
+# Source0-md5: cf0cdbd9099a6df028de429044e7f4da
 %endif
 %if %{need_x8664}
 Source1:       http://download.nvidia.com/XFree86/Linux-x86_64/%{_nv_ver}-%{_nv_rel}/NVIDIA-Linux-x86_64-%{_nv_ver}-%{_nv_rel}-pkg1.run
-# Source1-md5: 7ff9c0cb34f0e43817703a765d21f813
+# Source1-md5: 6af676cc903bff3bc141098a47f78182
 %endif
 Source2:       %{name}-settings.desktop
 Source3:       %{name}-xinitrc.sh
@@ -57,7 +60,7 @@ URL:          http://www.nvidia.com/object/linux.html
 %endif
 BuildRequires: %{kgcc_package}
 #BuildRequires:        X11-devel >= %{_min_x11}        # disabled for now
-BuildRequires: rpmbuild(macros) >= 1.308
+BuildRequires: rpmbuild(macros) >= 1.330
 BuildRequires: sed >= 4.0
 BuildConflicts:        XFree86-nvidia
 Requires:      X11-Xserver
@@ -86,31 +89,28 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %endif
 
 %description
-This driver set adds improved 2D functionality to the Xorg/XFree86 X
-server as well as high performance OpenGL acceleration, AGP support,
-support for most flat panels, and 2D multiple monitor support.
-
-Supported hardware: new NVIDIA GeForce (from GeForce2 MX) and Quadro
-(Quadro4 and up) based graphics accelerators.
+This driver set adds improved 2D functionality to the Xorg X server as
+well as high performance OpenGL acceleration, AGP support, support for
+most flat panels, and 2D multiple monitor support. Supported hardware:
+modern NVIDIA GeForce (from GeForce2 MX) and Quadro (Quadro4 and up)
+based graphics accelerators.
 
 The older graphics chips are unsupported:
-- NV1 and RIVA 128/128ZX chips are supported in the base Xorg
-  install (nv driver)
-- TNT/TNT2/GeForce 256/GeForce2 Ultra/Quadro2 are suported by
-  X11-driver-nvidia-legacy drivers.
+- NV1 and RIVA 128/128ZX chips are supported in the base Xorg install
+  (nv driver)
+- TNT/TNT2/GeForce 256/GeForce2 Ultra/Quadro2 are suported by -legacy
+  drivers.
 
 %description -l pl
-Usprawnione sterowniki dla kart graficznych nVidia do serwera
-Xorg/XFree86, daj±ce wysokowydajn± akceleracjê OpenGL, obs³ugê AGP 
-i wielu monitorów 2D.
-
-Obs³uguj± w miarê nowe karty NVIDIA GeForce (od wersji GeForce2 MX)
-oraz Quadro (od wersji Quadro4).
+Usprawnione sterowniki dla kart graficznych NVIDIA do serwera Xorg,
+daj±ce wysokowydajn± akceleracjê OpenGL, obs³ugê AGP i wielu monitorów
+2D. Obs³uguj± w miarê nowe karty NVIDIA GeForce (od wersji GeForce2
+MX) oraz Quadro (od wersji Quadro4) do serwera Xorg/XFree86.
 
 Starsze uk³ady graficzne NVIDIA nie s± obs³ugiwane przez ten pakiet:
 - NV1 i Riva 128/128ZX s± obs³ugiwane przez sterownik nv z Xorg.
 - TNT/TNT2/GeForce 256/GeForce2 Ultra/Quadro2 obs³ugiwane s± przez
-  sterownik NVIDIA z pakietu X11-driver-nvidia-legacy.
+  sterownik NVIDIA w wersji -legacy.
 
 %package devel
 Summary:       OpenGL for X11R6 development (only gl?.h)
@@ -205,35 +205,13 @@ sed -i 's:-Wpointer-arith::' usr/src/nv/Makefile.kbuild
 %if %{with kernel}
 cd usr/src/nv/
 ln -sf Makefile.kbuild Makefile
-for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
-       if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
-               exit 1
-       fi
-       rm -rf o
-       install -d o/include/linux
-       ln -sf %{_kernelsrcdir}/config-$cfg o/.config
-       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg o/Module.symvers
-       ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h o/include/linux/autoconf.h
-%if %{with dist_kernel}
-       %{__make} -j1 -C %{_kernelsrcdir} O=$PWD/o prepare scripts
-%else
-       touch o/include/config/MARKER
-       ln -sf %{_kernelsrcdir}/scripts o/scripts
-%endif
-       %{__make} -C %{_kernelsrcdir} clean \
-               RCS_FIND_IGNORE="-name '*.ko' -o -name nv-kernel.o -o" \
-               SYSSRC=%{_kernelsrcdir} \
-               SYSOUT=$PWD/o \
-               M=$PWD O=$PWD/o \
-               %{?with_verbose:V=1}
-       %{__make} -C %{_kernelsrcdir} modules \
-               CC="%{__cc}" CPP="%{__cpp}" \
-               SYSSRC=%{_kernelsrcdir} \
-               SYSOUT=$PWD/o \
-               M=$PWD O=$PWD/o \
-               %{?with_verbose:V=1}
-       mv nvidia.ko nvidia-$cfg.ko
-done
+cat >> Makefile <<'EOF'
+
+$(obj)/nv-kernel.o: $(src)/nv-kernel.o.bin
+       cp $< $@
+EOF
+mv nv-kernel.o{,.bin}
+%build_kernel_modules -m nvidia
 %endif
 
 %install
@@ -279,14 +257,7 @@ ln -sf %{_libdir}/libGL.so $RPM_BUILD_ROOT/usr/%{_lib}/libGL.so
 %endif
 
 %if %{with kernel}
-cd usr/src/nv/
-install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
-install nvidia-%{?with_dist_kernel:up}%{!?with_dist_kernel:nondist}.ko \
-       $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/nvidia.ko
-%if %{with smp} && %{with dist_kernel}
-install nvidia-smp.ko \
-       $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/nvidia.ko
-%endif
+%install_kernel_modules -m usr/src/nv/nvidia -d misc
 %endif
 
 %clean
@@ -370,6 +341,7 @@ EOF
 
 %files progs
 %defattr(644,root,root,755)
+%doc usr/share/doc/nvidia-settings-user-guide.txt
 %attr(755,root,root) %{_bindir}/nvidia-settings
 %attr(755,root,root) %{_bindir}/nvidia-xconfig
 %attr(755,root,root) /etc/X11/xinit/xinitrc.d/*.sh
This page took 0.035554 seconds and 4 git commands to generate.