]> git.pld-linux.org Git - packages/STLport.git/blobdiff - STLport.spec
- stlport doesn't require libstdc++ runtime.
[packages/STLport.git] / STLport.spec
index aa831e9aeb0131f8fc54ac4dfe820c382a765417..a9f2530d2750f304dc1738f7ef9271084efb1aef 100644 (file)
@@ -1,3 +1,7 @@
+#
+# Conditional build:
+%bcond_with    static_gcc      # linkg libgcc* statically into libstlport.
+#
 Summary:       C++ standard library
 Summary(pl.UTF-8):     Biblioteki standardowe C++
 Name:          STLport
@@ -15,7 +19,6 @@ Patch3:               %{name}-vendor_gcc_detection.patch
 URL:           http://stlport.sourceforge.net/
 BuildRequires: libstdc++-devel >= 6:4.2.0-1
 BuildRequires: sed >= 4.0
-%requires_eq   libstdc++
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -55,7 +58,6 @@ Biblioteki statyczne do STLport.
 Summary:       Debug version of STLport library
 Summary(pl.UTF-8):     Wersja diagnostyczna biblioteki STLport
 Group:         Libraries
-%requires_eq   libstdc++
 
 %description dbg
 Debug version of STLport library.
@@ -98,7 +100,11 @@ Statyczna wersja diagnostyczna biblioteki STLport.
 sed -i -e 's/= -O2$/= %{rpmcflags}/' build/Makefiles/gmake/gcc.mak
 
 %build
-%{__make} -C build/lib -f gcc.mak \
+cd build/lib
+
+%{?with_static_gcc:./configure --use-static-gcc}
+
+%{__make} -f gcc.mak \
        stldbg-shared \
        stldbg-static \
        release-shared \
@@ -106,6 +112,8 @@ sed -i -e 's/= -O2$/= %{rpmcflags}/' build/Makefiles/gmake/gcc.mak
        CC="%{__cc}" \
        CXX="%{__cxx}"
 
+cd ../..
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_includedir}
This page took 0.058338 seconds and 4 git commands to generate.