]> git.pld-linux.org Git - packages/STLport.git/blobdiff - STLport.spec
- bcond_with static_gcc added (useful for deploying binaries on ancient enterpise...
[packages/STLport.git] / STLport.spec
index aa831e9aeb0131f8fc54ac4dfe820c382a765417..874b35633c40d98694aace55d93c50e90e71ea4e 100644 (file)
@@ -1,3 +1,7 @@
+#
+# Conditional build:
+%bcond_with    static_gcc      # linkg libgcc* statically into libstlport.
+#
 Summary:       C++ standard library
 Summary(pl.UTF-8):     Biblioteki standardowe C++
 Name:          STLport
@@ -98,7 +102,11 @@ Statyczna wersja diagnostyczna biblioteki STLport.
 sed -i -e 's/= -O2$/= %{rpmcflags}/' build/Makefiles/gmake/gcc.mak
 
 %build
-%{__make} -C build/lib -f gcc.mak \
+cd build/lib
+
+%{?with_static_gcc:./configure --use-static-gcc}
+
+%{__make} -f gcc.mak \
        stldbg-shared \
        stldbg-static \
        release-shared \
@@ -106,6 +114,8 @@ sed -i -e 's/= -O2$/= %{rpmcflags}/' build/Makefiles/gmake/gcc.mak
        CC="%{__cc}" \
        CXX="%{__cxx}"
 
+cd ../..
+
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_includedir}
This page took 0.042344 seconds and 4 git commands to generate.