]> git.pld-linux.org Git - packages/SPE.git/blobdiff - SPE.spec
- up to 0.7.0
[packages/SPE.git] / SPE.spec
index 96b1435bf20e5b062b0dddd88c106543ac4cfea1..6c0d33b3db3c5421cbfa5e9cb1ee34c0f4e965fe 100644 (file)
--- a/SPE.spec
+++ b/SPE.spec
@@ -1,31 +1,45 @@
 # TODO:
 # - fix %%files (doc to %%doc, no .py, remove unused files)
-%include       /usr/lib/rpm/macros.python
+
+%define        _wx     2.5.2.8
+%define        _bl     2.35
 
 Summary:       SPE - Stani's Python Editor
+Summary(pl):   SPE - pythonowy edytor Staniego
 Name:          SPE
-Version:       0.1.8.c
-%define                _wx 2.4.1.2
-%define                _bl 2.28
+Version:       0.7.0.a
 Release:       0.1
 License:       LGPL 2.1+ (except sm library <free to use> and sm_idle <PSF>)
 Group:         Applications/Text
-Source0:       http://spe.pycs.net/releases/%{name}-%{version}-wx%{_wx}.-bl%{_bl}.zip
-# Source0-md5: ca7deec95e38a19b75144d4ce481d6a0
+Source0:       http://projects.blender.org/frs/download.php/244/%{name}-%{version}-linux-mac.tgz
+# Source0-md5: f3c19dcbab4d1e77b4ef34f7916d8235
 URL:           http://spe.pycs.net/
 BuildRequires: rpm-pythonprov
+BuildRequires: findutils
 %pyrequires_eq python-modules
 Requires:      python-wxPython >= %{_wx}
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Spe is a python IDE with auto-indentation, auto completion, call tips, syntax
-coloring, syntax highlighting, class explorer, source index, auto todo list,
-sticky notes, integrated pycrust shell, python file browser, recent file
-browser, drag&drop, context help, ... Special is its blender support with a
-blender 3d object browser and its ability to run interactively inside blender.
-Spe is extensible with boa. 
+Spe is a python IDE with auto-indentation, auto completion, call tips,
+syntax coloring, syntax highlighting, class explorer, source index,
+auto todo list, sticky notes, integrated pycrust shell, python file
+browser, recent file browser, drag&drop, context help, ... Special is
+its blender support with a blender 3d object browser and its ability
+to run interactively inside blender. Spe is extensible with boa. 
+
+%description -l pl
+Spe (Stani's Python Editor) to pythonowe IDE z automatycznym
+wykonywaniem wciêæ, automatycznym dope³nianiem, podpowiedziami
+wywo³añ, kolorowaniem sk³adni, pod¶wietlaniem sk³adni, eksploratorem
+klas, indeksem ¼róde³, automatyczn± list± TODO, przyklejanymi
+notatkami, zintegrowan± pow³ok± pycrust, przegl±dark± plików
+pythonowych, przegl±dark± ostatnio u¿ywanych plików, obs³ug± w stylu
+przeci±gnij-i-upu¶æ, pomoc± kontekstow±... Specjaln± rzecz± jest
+wsparcie dla blendera z przegl±dark± obiektów blendera 3D i
+mo¿liwo¶ci± automatycznego uruchamiania z poziomu blendera. Spe jest
+rozszerzalne przy pomocy boa.
 
 %prep
 %setup -q -n %{name}-%{version}-wx%{_wx}.-bl%{_bl}
@@ -40,6 +54,8 @@ python setup.py install \
        --optimize=2 \
        --root=$RPM_BUILD_ROOT
 
+find $RPM_BUILD_ROOT -name '*.py' -exec rm "{}" ";"
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -47,4 +63,4 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.txt
 %attr(755,root,root) %{_bindir}/*
-%{py_sitedir}/*
+%{py_sitescriptdir}/*
This page took 0.101201 seconds and 4 git commands to generate.