]> git.pld-linux.org Git - packages/SPE.git/blobdiff - SPE.spec
- massive change ( validate errors warrings from desktop-file-validate)
[packages/SPE.git] / SPE.spec
index fed254644040eb9f30391d198c86809290d4d5ac..55c7a7c6bc1f3596087d51e4f802b78897e61d18 100644 (file)
--- a/SPE.spec
+++ b/SPE.spec
@@ -1,45 +1,70 @@
 # TODO:
 # - fix %%files (doc to %%doc, no .py, remove unused files)
-%include       /usr/lib/rpm/macros.python
-
+%define        _wx     2.6.1.0
+#
 Summary:       SPE - Stani's Python Editor
+Summary(pl.UTF-8):     SPE - pythonowy edytor Staniego
 Name:          SPE
-Version:       0.1.8.c
-%define                _wx 2.4.1.2
-%define                _bl 2.28
-Release:       0.1
+Version:       0.8.2.a
+Release:       2
 License:       LGPL 2.1+ (except sm library <free to use> and sm_idle <PSF>)
 Group:         Applications/Text
-Source0:       http://spe.pycs.net/releases/%{name}-%{version}-wx%{_wx}.-bl%{_bl}.zip
-# Source0-md5: 252ace7ecf6e9c210f29a4c38ed742e8
+Source0:       http://download.berlios.de/python/%{name}-%{version}-wx%{_wx}.tar.gz
+# Source0-md5: d5d5a55414aa2410ac430f7e79b271e5
+Source1:       %{name}.desktop
+Source2:       %{name}.png
 URL:           http://spe.pycs.net/
-BuildRequires: rpm-pythonprov
+BuildRequires: python
+BuildRequires: python-devel
+BuildRequires: python-modules
+Requires:      pydoc
 %pyrequires_eq python-modules
 Requires:      python-wxPython >= %{_wx}
+# below is needed - SPE doesn't start without "hacked" release of wxPython (reporting version issue)
+Requires:      python-wxPython >= 2.6.1.0-3
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Spe is a python IDE with auto-indentation, auto completion, call tips, syntax
-coloring, syntax highlighting, class explorer, source index, auto todo list,
-sticky notes, integrated pycrust shell, python file browser, recent file
-browser, drag&drop, context help, ... Special is its blender support with a
-blender 3d object browser and its ability to run interactively inside blender.
-Spe is extensible with boa. 
+Spe is a python IDE with auto-indentation, auto completion, call tips,
+syntax coloring, syntax highlighting, class explorer, source index,
+auto todo list, sticky notes, integrated pycrust shell, python file
+browser, recent file browser, drag&drop, context help, ... Special is
+its blender support with a blender 3d object browser and its ability
+to run interactively inside blender. Spe is extensible with boa. 
+
+%description -l pl.UTF-8
+Spe (Stani's Python Editor) to pythonowe IDE z automatycznym
+wykonywaniem wcięć, automatycznym dopełnianiem, podpowiedziami
+wywołań, kolorowaniem składni, podświetlaniem składni, eksploratorem
+klas, indeksem źródeł, automatyczną listą TODO, przyklejanymi
+notatkami, zintegrowaną powłoką pycrust, przeglądarką plików
+pythonowych, przeglądarką ostatnio używanych plików, obsługą w stylu
+przeciągnij-i-upuść, pomocą kontekstową... Specjalną rzeczą jest
+wsparcie dla blendera z przeglądarką obiektów blendera 3D i
+możliwością automatycznego uruchamiania z poziomu blendera. Spe jest
+rozszerzalne przy pomocy boa.
 
 %prep
-%setup -q -n %{name}-%{version}-wx%{_wx}.-bl%{_bl}
+%setup -q -n %{name}-%{version}-wx%{_wx}
 
 %build
 python setup.py build
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
 
 python setup.py install \
        --optimize=2 \
        --root=$RPM_BUILD_ROOT
 
+install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
+install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
+
+# SPE doesn't work without *.py files so don't remove them
+#%%py_postclean
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -47,4 +72,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.txt
 %attr(755,root,root) %{_bindir}/*
-%{py_sitedir}/*
+%{py_sitescriptdir}/*
+%{_desktopdir}/*.desktop
+%{_pixmapsdir}/*
This page took 0.063625 seconds and 4 git commands to generate.