]> git.pld-linux.org Git - packages/QtCurve.git/blobdiff - QtCurve.spec
- update kde3 to 1.0.0; gtk2 to 1.0.1
[packages/QtCurve.git] / QtCurve.spec
index 11e9544b973924dd0304af7897b654111c9358d4..d8c825ce0a8efd45a16b9cfb67313b087996ca07 100644 (file)
@@ -5,11 +5,11 @@
 # Conditional build:
 %bcond_without gtk     # don't build GTK+ styles
 %bcond_without gtk2    # don't build GTK+2 styles
-%bcond_without kde     # don't build KDE styles
-#
-%define                ver             0.59.2
-%define                kde_ver         0.59.2
-%define                gtk2_ver        0.59.3
+%bcond_without kde3    # don't build KDE styles
+
+%define                ver             1.0.1
+%define                kde3_ver        1.0.0
+%define                gtk2_ver        1.0.1
 %define                gtk1_ver        0.42.2
 Summary:       A free and corrected port of Red Hat's GTK+/Qt theme
 Summary(pl.UTF-8):     Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
@@ -18,22 +18,20 @@ Version:    %{ver}
 Release:       1
 License:       GPL
 Group:         Themes
-Source0:       http://home.freeuk.com/cpdrummond/%{name}-KDE3-%{kde_ver}.tar.bz2
-# Source0-md5: 8a0d6c5f475541853a5e0104400521f7
-Source1:       http://home.freeuk.com/cpdrummond/%{name}-Gtk2-%{gtk2_ver}.tar.bz2
-# Source1-md5: 9a378e6f283379956786d6c599afe28e
+Source0:       http://craigd.wikispaces.com/file/view/%{name}-KDE3-%{kde3_ver}.tar.bz2
+# Source0-md5: b3bd5675fc954a4a01e691e7d5be35ee
+Source1:       http://craigd.wikispaces.com/file/view/%{name}-Gtk2-%{gtk2_ver}.tar.bz2
+# Source1-md5: 8c574b955851e79397805db95ed08b62
 Source2:       http://home.freeuk.com/cpdrummond/%{name}-Gtk1-%{gtk1_ver}.tar.gz
 # Source2-md5: 8219f58493ca4e65a8fe61ee76eca522
-Patch0:                %{name}-Gtk2-userjs.patch
-Patch1:                %{name}-Gtk2-mailto.patch
-Patch2:                %{name}-Gtk1-lib64.patch
+Patch0:                %{name}-Gtk1-lib64.patch
 URL:           http://www.kde-look.org/content/show.php?content=40492
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: cmake
 %{?with_gtk:BuildRequires:     gtk+-devel}
 %{?with_gtk2:BuildRequires:    gtk+2-devel}
-%{?with_kde:BuildRequires:     kdelibs-devel >= 3.1}
+%{?with_kde3:BuildRequires:    kdelibs-devel >= 3.1}
 BuildRequires: libtool
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.293
@@ -49,7 +47,7 @@ Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
 %package -n kde-style-QtCurve
 Summary:       A free and corrected port of Red Hat's GTK+/Qt theme
 Summary(pl.UTF-8):     Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata
-Version:       %{kde_ver}
+Version:       %{kde3_ver}
 Group:         Themes
 Requires:      kdelibs >= 3.1
 
@@ -108,35 +106,31 @@ Darmowa i poprawiona wersja motywu GTK+/Qt zrobionego przez Red Hata.
 Pakiet z dokumentacja i plikami współdzielonymi.
 
 %prep
-%setup -q -c -D %{?with_kde:-a0} %{?with_gtk2:-a1} %{?with_gtk:-a2}
-%if %{with gtk2}
-cd %{name}-Gtk2-%{gtk2_ver}
-%patch0 -p1
-%patch1 -p0
-cd -
-%endif
+%setup -q -c -D %{?with_kde3:-a0} %{?with_gtk2:-a1} %{?with_gtk:-a2}
 
 %if %{with gtk}
 %if "%{_lib}" == "lib64"
 cd %{name}-Gtk1-%{gtk1_ver}
-%patch2 -p1
+%patch0 -p1
 cd -
 %endif
 %endif
 
 
 %build
-%if %{with kde}
-cd %{name}-KDE3-%{kde_ver}
+%if %{with kde3}
+cd %{name}-KDE3-%{kde3_ver}
 %cmake \
        -DCMAKE_INSTALL_PREFIX=%{_prefix} \
        .
+
 %{__make}
 cd -
 %endif
 
 %if %{with gtk}
 cd %{name}-Gtk1-%{gtk1_ver}
+rm -f acinclude.m4
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
@@ -155,6 +149,7 @@ cd %{name}-Gtk2-%{gtk2_ver}
        -DQTC_MODIFY_MOZILLA_USER_JS=true \
        -DCMAKE_INSTALL_PREFIX=%{_prefix} \
        .
+
 %{__make}
 cd -
 %endif
@@ -162,8 +157,8 @@ cd -
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with kde}
-%{__make} -C %{name}-KDE3-%{kde_ver} install \
+%if %{with kde3}
+%{__make} -C %{name}-KDE3-%{kde3_ver} install \
        DESTDIR=$RPM_BUILD_ROOT
 %endif
 
@@ -177,7 +172,6 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 chmod a+x $RPM_BUILD_ROOT%{_datadir}/themes/QtCurve/gtk-2.0/map_kde_icons.pl
-chmod a+x $RPM_BUILD_ROOT%{_datadir}/themes/QtCurve/mozilla/mailto.sh
 %endif
 
 rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
@@ -185,14 +179,15 @@ rm -f $RPM_BUILD_ROOT{%{_libdir}/gtk/themes/engines,%{_libdir}/gtk-2.0/*/*}/*.la
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with kde}
+%if %{with kde3}
 %files -n kde-style-QtCurve
 %defattr(644,root,root,755)
 %{_libdir}/kde3/kstyle_qtcurve_config.la
 %attr(755,root,root) %{_libdir}/kde3/kstyle_qtcurve_config.so
 %attr(755,root,root) %{_libdir}/kde3/plugins/styles/*.so
 %{_datadir}/apps/kstyle/themes/qtcurve*.themerc
-%{_datadir}/apps/kstyle/themes/qtc_klearlooks.themerc
+%{_datadir}/apps/kdisplay/color-schemes/QtCurve.kcsrc
+%{_datadir}/themes/QtCurve/gtk-2.0/kdeglobals
 %{_datadir}/apps/QtCurve
 %endif
 
@@ -214,12 +209,13 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_datadir}/themes/QtCurve/gtk-2.0/map_kde_icons.pl
 %dir %{_datadir}/themes/QtCurve/mozilla
 %{_datadir}/themes/QtCurve/mozilla/QtCurve.css
-%{_datadir}/themes/QtCurve/mozilla/firefox-user.js
+%{_datadir}/themes/QtCurve/mozilla/QtCurve-KDEButtonOrder.css
 %{_datadir}/themes/QtCurve/mozilla/preferences-rev.xml
-%attr(755,root,root) %{_datadir}/themes/QtCurve/mozilla/mailto.sh
 %endif
 
 %files -n theme-QtCurve-common
 %defattr(644,root,root,755)
-%doc %{name}-KDE3-%{kde_ver}/{ChangeLog,README,TODO}
+%doc %{name}-KDE3-%{kde3_ver}/ChangeLog
+%doc %{name}-KDE3-%{kde3_ver}/README
+%doc %{name}-KDE3-%{kde3_ver}/TODO
 %dir %{_datadir}/themes/QtCurve
This page took 0.143824 seconds and 4 git commands to generate.