]> git.pld-linux.org Git - packages/GeoIP-db-City.git/blobdiff - GeoIP-db-City.spec
use newest file date as package version
[packages/GeoIP-db-City.git] / GeoIP-db-City.spec
index 519df233faf9ca5793fdf49a3087c59b50a24254..760d582837d569a1d818f40695fcc2a3877648ee 100644 (file)
@@ -2,14 +2,14 @@ Summary:      GeoLite City - City database for GeoIP
 Summary(pl.UTF-8):     GeoLite City - baza danych miast dla GeoIP
 Name:          GeoIP-db-City
 # Updated every month:
-Version:       2014.08.06
+Version:       2015.07.24
 Release:       2
 License:       CC 3.0 BY-SA
 Group:         Applications/Databases
 Source0:       http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.xz?/GeoLiteCity-%{version}.dat.xz
-# Source0-md5: 3bba960155a4b48aaef1c116735be659
+# Source0-md5: bf521ddc38791505915fe1123f0432c6
 Source1:       http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz?/GeoLiteCityv6-%{version}.dat.gz
-# Source1-md5: f280f9914a8cb199fd2846e8e9a8e42b
+# Source1-md5: 99c90bed6644a2fc55950e121cd18d87
 URL:           http://dev.maxmind.com/geoip/legacy/geolite/
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
@@ -40,7 +40,22 @@ cp -p %{SOURCE1} .
 xz -d GeoLiteCity-%{version}.dat.xz
 gunzip GeoLiteCityv6-%{version}.dat.gz
 
-ver=$(TZ=GMT stat -c '%y' GeoLiteCity-%{version}.dat | awk '{print $1}' | tr - .)
+%build
+# get file DATE in GMT timezone
+filedate() {
+       TZ=GMT stat -c '%y' "$1" | awk '{print $1}'
+}
+
+# use newest file date as version
+d1=$(filedate GeoLiteCity-%{version}.dat)
+d2=$(filedate GeoLiteCityv6-%{version}.dat)
+if [ "$(echo $d1 | tr -d -)" -gt "$(echo $d2 | tr -d -)" ]; then
+       d=$d1
+else
+       d=$d2
+fi
+
+ver=$(echo $d | tr - .)
 if [ "$ver" != %{version} ]; then
        exit 1
 fi
This page took 0.152078 seconds and 4 git commands to generate.