]> git.pld-linux.org Git - packages/FHS.git/blobdiff - FHS.spec
- fix consistecy check
[packages/FHS.git] / FHS.spec
index f92f73720f05aabb335fba24b5446f6901918105..483c7602132d4266384d8aa3a7bad0d08f8934d8 100644 (file)
--- a/FHS.spec
+++ b/FHS.spec
@@ -12,7 +12,7 @@ Summary(pl.UTF-8):    Podstawowy układ katalogów systemu Linux zgodny z FHS 3.0
 Summary(tr.UTF-8):     Temel dosya sistemi yapısı
 Name:          FHS
 Version:       3.0
-Release:       1
+Release:       6
 License:       GPL
 Group:         Base
 URL:           http://refspecs.linuxfoundation.org/fhs.shtml
@@ -43,9 +43,9 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                __spec_clean_body       %{nil}
 
 # doesn't contain any files, but we're not noarch package
-%define        no_install_post_strip   1
-%define        no_install_post_chrpath 1
-%define        no_install_post_compress_modules        1
+%define                no_install_post_strip   1
+%define                no_install_post_chrpath 1
+%define                no_install_post_compress_modules        1
 
 # we have to use numeric uids/groups. see comment above
 %define                gid_uucp        14
@@ -71,6 +71,14 @@ Pakiet ten zawiera informacje o podstawowej strukturze katalogów
 systemu i praw dostępu do nich. Struktura katalogów jest zgodna z FHS
 %{version}.
 
+%package debug
+Summary:       Debug information directory hierarchy
+Group:         Development/Debug
+
+%description debug
+This package provides directory hierarchy for debug information
+contained in debuginfo rpm packages.
+
 %prep
 %setup -qcT
 cp -p %{SOURCE0} .
@@ -83,10 +91,10 @@ install -d \
        $RPM_BUILD_ROOT/etc/{X11,opt} \
        $RPM_BUILD_ROOT/lib/modules \
        $RPM_BUILD_ROOT/{mnt,media,proc,root/tmp,sbin,tmp} \
-       $RPM_BUILD_ROOT/usr/{bin,games,include,lib,sbin,share,src} \
+       $RPM_BUILD_ROOT/usr/{bin,games,include,lib,libexec,sbin,share,src} \
        $RPM_BUILD_ROOT/usr/share/{color/icc,dict,doc,games,info,misc,ppd,tmac,xml} \
        $RPM_BUILD_ROOT/usr/lib/games \
-       $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,sbin,share/{color/icc,doc,info,man},src} \
+       $RPM_BUILD_ROOT/usr/local/{bin,etc,games,include,lib,libexec,sbin,share/{color/icc,doc,info,man},src} \
        $RPM_BUILD_ROOT/var/{cache,crash,db,games,lib/{color/icc,misc},local,lock,log,mail,opt,run,spool,tmp,yp}
 
 %if %{with lib64}
@@ -99,6 +107,10 @@ install -d $RPM_BUILD_ROOT{/libx32,/usr/libx32/games,/usr/local/libx32}
 install -d $RPM_BUILD_ROOT/usr/share/man/man{1,2,3,4,5,6,7,8}
 install -d $RPM_BUILD_ROOT/usr/local/share/man/man{1,2,3,4,5,6,7,8}
 
+for i in $(seq 0 255); do
+       install -d "$RPM_BUILD_ROOT$(printf '/usr/lib/.build-id/%02x' $i)"
+done
+
 > %{name}.lang
 for mloc in $(cat locale-dirs); do
        echo "%%lang($mloc) %dir /usr/share/man/${mloc}" >> %{name}.lang
@@ -112,7 +124,7 @@ done
 cd $RPM_BUILD_ROOT
 
 check_filesystem_dirs() {
-       RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
+       RPMFILES="%{name}-%{version}-%{release}.%{_target_cpu}.rpm %{name}-debug-%{version}-%{release}.%{_target_cpu}.rpm"
        TMPFILE=$(mktemp)
        find | sed -e 's|^\.||g' -e '/^$/d' | LC_ALL=C sort > $TMPFILE
 
@@ -158,13 +170,14 @@ posix.chown("/var/lock", 0, %{gid_uucp})
 %dir /run
 %dir /sbin
 %dir %attr(755,root,root) /srv
-%dir /sys
+%dir %attr(555,root,root) /sys
 %dir %attr(1777,root,root) /tmp
 %dir /usr
 %dir /usr/bin
 %dir /usr/games
 %dir /usr/include
 %dir /usr/lib
+%dir /usr/libexec
 %dir /usr/lib/games
 %dir /usr/sbin
 %dir /usr/share
@@ -187,6 +200,7 @@ posix.chown("/var/lock", 0, %{gid_uucp})
 %dir /usr/local/games
 %dir /usr/local/include
 %dir /usr/local/lib
+%dir /usr/local/libexec
 %dir /usr/local/sbin
 %dir /usr/local/share
 %dir /usr/local/share/color
@@ -226,3 +240,8 @@ posix.chown("/var/lock", 0, %{gid_uucp})
 %dir /usr/libx32/games
 %dir /usr/local/libx32
 %endif
+
+%files debug
+%defattr(644,root,root,755)
+%dir /usr/lib/.build-id
+%dir /usr/lib/.build-id/[0-9af][0-9af]
This page took 0.030471 seconds and 4 git commands to generate.