]> git.pld-linux.org Git - packages/FHS.git/blobdiff - FHS.spec
- check_filesystem_dirs cleanup
[packages/FHS.git] / FHS.spec
index f6f8c5faba1a97ba7a0331da5124bec61450214b..9dc9dd6bbc86e9f94c7a52041b9164e4d5d42391 100644 (file)
--- a/FHS.spec
+++ b/FHS.spec
@@ -48,7 +48,6 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define        no_install_post_compress_modules        1
 
 # we have to use numeric uids/groups. see comment above
-
 %define                gid_uucp        14
 %define                gid_mail        12
 
@@ -115,10 +114,9 @@ cd $RPM_BUILD_ROOT
 check_filesystem_dirs() {
        RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
        TMPFILE=$(mktemp)
-       find | sed -e 's|^\.||g' -e 's|^$||g' | LC_ALL=C sort > $TMPFILE
+       find | sed -e 's|^\.||g' -e '/^$/d' | LC_ALL=C sort > $TMPFILE
 
-       # find finds also '.', so use option -B for diff
-       if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -uB $TMPFILE - ; then
+       if rpm -qpl %{_rpmdir}/$RPMFILE | grep -v '^/$' | LC_ALL=C sort | diff -u $TMPFILE - ; then
                rm -rf $RPM_BUILD_ROOT
        else
                echo -e "\nNot so good, some directories are not included in package\n"
This page took 0.100195 seconds and 4 git commands to generate.