]> git.pld-linux.org Git - packages/ApacheJServ.git/blobdiff - ApacheJServ.spec
- use $JAVACMD from jpackage-utils
[packages/ApacheJServ.git] / ApacheJServ.spec
index 96f7b5f632229693ce7270630545e5ef5504cccc..abf1b1859e138ad493b469a1a2ddced14ca9ad04 100644 (file)
@@ -5,7 +5,7 @@ Summary:        Servlet engine with support for the leading web server
 Summary(pl.UTF-8):     Silnik serwletów ze wsparciem dla wiodącego serwera WWW
 Name:          ApacheJServ
 Version:       1.1.2
-Release:       5
+Release:       7
 License:       freely distributable & usable
 Group:         Networking/Daemons
 Source0:       http://java.apache.org/jserv/dist/%{name}-%{version}.tar.gz
@@ -84,17 +84,18 @@ Moduł JServ dla Apache'a.
 %patch3 -p1
 
 # servlet-2.0 is the highest version the jserv code compiles with
-sed -i -e "
-       s|@JSDK_CLASSES@|$(find-jar servlet-2.0)|g
+servlet_jar=$(find-jar servlet-2.0)
+%{__sed} -i -e "
+       s|@JSDK_CLASSES@|$servlet_jar|g
        s|@JAVA@|%java|g
 " conf/jserv.properties.in
 
 # do not load module in provided jserv.conf; we do this in httpd.conf
-sed -i -e 's|@LOAD_OR_NOT@|#|g' conf/jserv.conf.in
+%{__sed} -i -e 's|@LOAD_OR_NOT@|#|g' conf/jserv.conf.in
 
 # we don't want gcj related deps
-sed -i -e '/^SUBDIRS/s,java,,' src/Makefile.am
-sed -i -e '/^SUBDIRS/s,example,,' Makefile.am
+%{__sed} -i -e '/^SUBDIRS/s,java,,' src/Makefile.am
+%{__sed} -i -e '/^SUBDIRS/s,example,,' Makefile.am
 
 %build
 export JAVA_HOME="%{java_home}"
This page took 0.063679 seconds and 4 git commands to generate.