]> git.pld-linux.org Git - packages/qt4.git/blobdiff - qt4.spec
- icu 67 rebuild
[packages/qt4.git] / qt4.spec
index f59f44151699dd7773eae3ff06443ec69188015c..4150dbf5a06b2d994297ec6441872423a4face4f 100644 (file)
--- a/qt4.spec
+++ b/qt4.spec
@@ -1,22 +1,30 @@
 #
 # TODO:
 #
 # TODO:
+#      - fix moc failures, see e.g. https://bugzilla.redhat.com/show_bug.cgi?id=1396755
+#        at least add some macros to QTBUG-22829 patch (BOOST_PREDEF_VERSION_NUMBER_H, _SYS_SYSMACROS_H_OUTER...)
 #      - more cleanups
 #      - check if translations are available
 #      - check Qt ui tool
 #
 # Conditional build:
 #      - more cleanups
 #      - check if translations are available
 #      - check Qt ui tool
 #
 # Conditional build:
-%bcond_with    nas             # enable NAS audio support
 %bcond_without static_libs     # don't build static libraries
 %bcond_without static_libs     # don't build static libraries
-%bcond_without cups            # disable CUPS support
-%bcond_without mysql           # don't build MySQL plugin
-%bcond_without odbc            # don't build unixODBC plugin
-%bcond_without pgsql           # don't build PostgreSQL plugin
-%bcond_without sqlite3         # don't build SQLite3 plugin
-%bcond_without sqlite          # don't build SQLite2 plugin
-%bcond_without ibase           # don't build ibase (InterBase/Firebird) plugin
-%bcond_without pch             # disable pch in qmake
-%bcond_without gtk             # don't build GTK theme integration
-%bcond_without system_phonon   # don't build phonon libraries
+# -- features
+%bcond_without cups            # CUPS printing support
+%bcond_with    nas             # NAS audio support
+%bcond_without gtk             # GTK+ theme integration
+%bcond_without pch             # pch (pre-compiled headers) in qmake
+%bcond_without system_phonon   # phonon libraries from phonon.spec intead of qt4.spec
+%bcond_with    wkhtml          # WKHTMLTOPDF patch (affects QtGui ABI)
+%bcond_with    openvg          # OpenVG support
+# -- databases
+%bcond_without ibase           # ibase (InterBase/Firebird) plugin
+%bcond_without mysql           # MySQL plugin
+%bcond_with    oci             # OCI (Oracle) support
+%bcond_without odbc            # unixODBC plugin
+%bcond_without pgsql           # PostgreSQL plugin
+%bcond_without sqlite3         # SQLite3 plugin
+%bcond_without sqlite          # SQLite2 plugin
+# -- SIMD CPU instructions
 %bcond_with    mmx             # use MMX instructions
 %bcond_with    3dnow           # use 3Dnow instructions
 %bcond_with    sse             # use SSE instructions in gui/painting module
 %bcond_with    mmx             # use MMX instructions
 %bcond_with    3dnow           # use 3Dnow instructions
 %bcond_with    sse             # use SSE instructions in gui/painting module
@@ -44,9 +52,9 @@
 %endif
 # any SQL
 %define                _withsql        1
 %endif
 # any SQL
 %define                _withsql        1
-%{!?with_sqlite3:%{!?with_sqlite:%{!?with_ibase:%{!?with_mysql:%{!?with_pgsql:%{!?with_odbc:%undefine _withsql}}}}}}
+%{!?with_sqlite3:%{!?with_sqlite:%{!?with_ibase:%{!?with_mysql:%{!?with_pgsql:%{!?with_odbc:%{!?with_oci:%undefine _withsql}}}}}}}
 
 
-%define                icu_abi         49
+%define                icu_abi         67
 %define                next_icu_abi    %(echo $((%{icu_abi} + 1)))
 
 Summary:       The Qt GUI application framework
 %define                next_icu_abi    %(echo $((%{icu_abi} + 1)))
 
 Summary:       The Qt GUI application framework
@@ -54,12 +62,12 @@ Summary(es.UTF-8):  Biblioteca para ejecutar aplicaciones GUI Qt
 Summary(pl.UTF-8):     Biblioteka Qt do tworzenia GUI
 Summary(pt_BR.UTF-8):  Estrutura para rodar aplicações GUI Qt
 Name:          qt4
 Summary(pl.UTF-8):     Biblioteka Qt do tworzenia GUI
 Summary(pt_BR.UTF-8):  Estrutura para rodar aplicações GUI Qt
 Name:          qt4
-Version:       4.8.4
-Release:       3
+Version:       4.8.7
+Release:       28
 License:       LGPL v2.1 or GPL v3.0
 Group:         X11/Libraries
 License:       LGPL v2.1 or GPL v3.0
 Group:         X11/Libraries
-Source0:       http://releases.qt-project.org/qt4/source/qt-everywhere-opensource-src-%{version}.tar.gz
-# Source0-md5: 89c5ecba180cae74c66260ac732dc5cb
+Source0:       http://download.qt-project.org/official_releases/qt/4.8/%{version}/qt-everywhere-opensource-src-%{version}.tar.gz
+# Source0-md5: d990ee66bf7ab0c785589776f35ba6ad
 Source2:       %{name}-qtconfig.desktop
 Source3:       %{name}-designer.desktop
 Source4:       %{name}-assistant.desktop
 Source2:       %{name}-qtconfig.desktop
 Source3:       %{name}-designer.desktop
 Source4:       %{name}-assistant.desktop
@@ -80,18 +88,53 @@ Patch7:             %{name}-x11_fonts.patch
 Patch8:                %{name}-ibase.patch
 Patch9:                qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
 Patch10:       webkit-no_Werror.patch
 Patch8:                %{name}-ibase.patch
 Patch9:                qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
 Patch10:       webkit-no_Werror.patch
-Patch11:       moc-boost148.patch
-Patch12:       fix-crash-in-assistant.patch
-Patch13:       improve-cups-support.patch
-Patch14:       qt4-CVE-2013-0254.patch
+Patch11:       %{name}-wkhtml.patch
+Patch12:       openssl.patch
+Patch13:       qt-asm-volatile.patch
+Patch14:       x32.patch
 # backported from Qt5 (essentially)
 # http://bugzilla.redhat.com/702493
 # https://bugreports.qt-project.org/browse/QTBUG-5545
 Patch15:       qt-everywhere-opensource-src-4.8.4-qgtkstyle_disable_gtk_theme_check.patch
 Patch16:       qt-everywhere-opensource-src-4.8.3-QTBUG-4862.patch
 # backported from Qt5 (essentially)
 # http://bugzilla.redhat.com/702493
 # https://bugreports.qt-project.org/browse/QTBUG-5545
 Patch15:       qt-everywhere-opensource-src-4.8.4-qgtkstyle_disable_gtk_theme_check.patch
 Patch16:       qt-everywhere-opensource-src-4.8.3-QTBUG-4862.patch
-URL:           http://qt.nokia.com/
+Patch17:       %{name}-oracle-instantclient.patch
+# from Debian
+Patch18:       add-lxde-support.patch
+Patch19:       Better-handling-of-invalid-font-tables.patch
+Patch20:       xmlpatterns_stack_overflow_fix.diff
+Patch21:       no_libicu_message.diff
+Patch22:       add-mate-support.patch
+
+# from FC
+Patch28:       qt-x11-opensource-src-4.5.0-fix-qatomic-inline-asm.patch
+Patch29:       qt-everywhere-opensource-src-4.8.6-QTBUG-38585.patch
+Patch30:       qt-everywhere-opensource-src-4.8.6-QTBUG-37380.patch
+Patch31:       qt-everywhere-opensource-src-4.8.6-QTBUG-34614.patch
+Patch32:       qt-everywhere-opensource-src-4.8.5-QTBUG-35459.patch
+Patch33:       qt-everywhere-opensource-src-4.8.5-QTBUG-4862.patch
+Patch34:       qt-everywhere-opensource-src-4.8.5-QTBUG-21900.patch
+Patch35:       qt-4.8-poll.patch
+Patch36:       qt-cupsEnumDests.patch
+Patch37:       qt-everywhere-opensource-src-4.8.4-qmake_pkgconfig_requires_private.patch
+Patch38:       qt-everywhere-opensource-src-4.8.5-QTBUG-14467.patch
+Patch39:       qt-everywhere-opensource-src-4.8.5-tds_no_strict_aliasing.patch
+Patch40:       qt-everywhere-opensource-src-4.8.6-QTBUG-22829.patch
+Patch41:       qt-everywhere-opensource-src-4.8.7-alsa-1.1.patch
+Patch42:       qt-everywhere-opensource-src-4.8.7-gcc6.patch
+Patch43:       qt-everywhere-opensource-src-4.6.2-cups.patch
+Patch44:       qt-everywhere-opensource-src-4.8.0-tp-qtreeview-kpackagekit-crash.patch
+Patch45:       qt-everywhere-opensource-src-4.6.3-glib_eventloop_nullcheck.patch
+Patch46:       qt-everywhere-opensource-src-4.8.3-qdbusconnection_no_debug.patch
+Patch47:       qt-everywhere-opensource-src-4.8.2--assistant-crash.patch
+Patch48:       qt-everywhere-opensource-src-4.8.0-QTBUG-22037.patch
+Patch49:       icu59.patch
+Patch50:       mysql-link.patch
+Patch51:       gcc9.patch
+Patch52:       gcc9-qforeach.patch
+Patch53:       cxx11.patch
+URL:           http://qt-project.org/
 %{?with_ibase:BuildRequires:   Firebird-devel}
 %{?with_ibase:BuildRequires:   Firebird-devel}
-BuildRequires: Mesa-libOpenVG-devel
+%{?with_openvg:BuildRequires:  Mesa-libOpenVG-devel}
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: OpenGL-devel
 BuildRequires: alsa-lib-devel
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: OpenGL-devel
 BuildRequires: alsa-lib-devel
@@ -99,7 +142,7 @@ BuildRequires:       alsa-lib-devel
 BuildRequires: dbus-devel >= 0.93
 BuildRequires: fontconfig-devel
 BuildRequires: freetds-devel
 BuildRequires: dbus-devel >= 0.93
 BuildRequires: fontconfig-devel
 BuildRequires: freetds-devel
-BuildRequires: freetype-devel >= 1:2.0.0
+BuildRequires: freetype-devel >= 2.1.3
 %{?with_pch:BuildRequires:     gcc >= 5:4.0}
 BuildRequires: glib2-devel >= 2.0.0
 BuildRequires: gstreamer0.10-plugins-base-devel
 %{?with_pch:BuildRequires:     gcc >= 5:4.0}
 BuildRequires: glib2-devel >= 2.0.0
 BuildRequires: gstreamer0.10-plugins-base-devel
@@ -113,11 +156,13 @@ BuildRequires:    libpng-devel >= 2:1.0.8
 BuildRequires: libstdc++-devel
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_nas:BuildRequires:     nas-devel}
 BuildRequires: libstdc++-devel
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_nas:BuildRequires:     nas-devel}
+%{?with_oci:BuildRequires:     oracle-instantclient-devel}
 BuildRequires: pkgconfig
 %{?with_pgsql:BuildRequires:   postgresql-backend-devel}
 %{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: pulseaudio-devel >= 0.9.10
 BuildRequires: rpmbuild(macros) >= 1.654
 BuildRequires: pkgconfig
 %{?with_pgsql:BuildRequires:   postgresql-backend-devel}
 %{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: pulseaudio-devel >= 0.9.10
 BuildRequires: rpmbuild(macros) >= 1.654
+BuildRequires: rsync
 BuildRequires: sed >= 4.0
 %{?with_sqlite:BuildRequires:  sqlite-devel}
 %{?with_sqlite3:BuildRequires: sqlite3-devel}
 BuildRequires: sed >= 4.0
 %{?with_sqlite:BuildRequires:  sqlite-devel}
 %{?with_sqlite3:BuildRequires: sqlite3-devel}
@@ -269,8 +314,12 @@ Group:             X11/Libraries
 %ifarch %{x8664} ppc64 sparc64 s390x
 Requires:      libicui18n.so.%{icu_abi}()(64bit)
 %else
 %ifarch %{x8664} ppc64 sparc64 s390x
 Requires:      libicui18n.so.%{icu_abi}()(64bit)
 %else
+%ifarch x32
+Requires:      libicui18n.so.%{icu_abi}()(x32bit)
+%else
 Requires:      libicui18n.so.%{icu_abi}
 %endif
 Requires:      libicui18n.so.%{icu_abi}
 %endif
+%endif
 Obsoletes:     QtAssistant
 
 %description -n QtCore
 Obsoletes:     QtAssistant
 
 %description -n QtCore
@@ -482,7 +531,7 @@ Group:              X11/Development/Libraries
 Requires:      QtCore-devel = %{version}-%{release}
 Requires:      QtGui = %{version}-%{release}
 Requires:      fontconfig-devel
 Requires:      QtCore-devel = %{version}-%{release}
 Requires:      QtGui = %{version}-%{release}
 Requires:      fontconfig-devel
-Requires:      freetype-devel >= 1:2.0.0
+Requires:      freetype-devel >= 2.1.3
 Requires:      libpng-devel >= 2:1.0.8
 Requires:      xorg-lib-libSM-devel
 Requires:      xorg-lib-libXcursor-devel
 Requires:      libpng-devel >= 2:1.0.8
 Requires:      xorg-lib-libSM-devel
 Requires:      xorg-lib-libXcursor-devel
@@ -613,6 +662,7 @@ Requires:   QtCore = %{version}-%{release}
 # the rest for qnmbearer plugin
 Requires:      QtDBus = %{version}-%{release}
 Requires:      QtXml = %{version}-%{release}
 # the rest for qnmbearer plugin
 Requires:      QtDBus = %{version}-%{release}
 Requires:      QtXml = %{version}-%{release}
+%requires_ge_to        openssl openssl-devel
 
 %description -n QtNetwork
 Qt classes for network programming.
 
 %description -n QtNetwork
 Qt classes for network programming.
@@ -887,6 +937,20 @@ danych MySQL poprzez klasy QSql.
 %description -n QtSql-mysql -l pt_BR.UTF-8
 Plugin de suporte a MySQL para Qt.
 
 %description -n QtSql-mysql -l pt_BR.UTF-8
 Plugin de suporte a MySQL para Qt.
 
+%package -n QtSql-oci
+Summary:       Qt Sql driver for Oracle database (using OCI interface)
+Summary(pl.UTF-8):     Sterownik Qt Sql dla bazy danych Oracle (wykorzystujący interfejs OCI)
+Group:         Libraries
+Requires:      QtSql = %{version}-%{release}
+Provides:      QtSql-backend = %{version}-%{release}
+
+%description -n QtSql-oci
+Qt Sql driver for Oracle database (using OCI interface).
+
+%description -n QtSql-oci -l pl.UTF-8
+Sterownik Qt Sql dla bazy danych Oracle (wykorzystujący interfejs
+OCI).
+
 %package -n QtSql-odbc
 Summary:       Database plugin for ODBC Qt support
 Summary(pl.UTF-8):     Wtyczka ODBC do Qt
 %package -n QtSql-odbc
 Summary:       Database plugin for ODBC Qt support
 Summary(pl.UTF-8):     Wtyczka ODBC do Qt
@@ -1294,6 +1358,17 @@ An advanced tool used for GUI designing with Qt library.
 Zaawansowane narzędzie służące do projektowania interfejsu graficznego
 za pomocą biblioteki Qt.
 
 Zaawansowane narzędzie służące do projektowania interfejsu graficznego
 za pomocą biblioteki Qt.
 
+%package devel-private
+Summary:       Private Qt headers files
+Group:         X11/Development/Libraries
+Requires:      QtCore-devel = %{version}-%{release}
+Requires:      QtDeclarative-devel = %{version}-%{release}
+Requires:      QtGui-devel = %{version}-%{release}
+Requires:      QtScript-devel = %{version}-%{release}
+
+%description devel-private
+Private Qt headers files - for calibre
+
 %package linguist
 Summary:       Translation helper for Qt
 Summary(pl.UTF-8):     Aplikacja ułatwiająca tłumaczenie aplikacji opartych o Qt
 %package linguist
 Summary:       Translation helper for Qt
 Summary(pl.UTF-8):     Aplikacja ułatwiająca tłumaczenie aplikacji opartych o Qt
@@ -1418,6 +1493,9 @@ Summary:  Qt Documentation in HTML format
 Summary(pl.UTF-8):     Dokumentacja Qt w formacie HTML
 Group:         X11/Development/Libraries
 Suggests:      %{name}-assistant = %{version}-%{release}
 Summary(pl.UTF-8):     Dokumentacja Qt w formacie HTML
 Group:         X11/Development/Libraries
 Suggests:      %{name}-assistant = %{version}-%{release}
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description doc
 Qt documentation in HTML format.
 
 %description doc
 Qt documentation in HTML format.
@@ -1456,12 +1534,46 @@ Programas exemplo para o Qt versão.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%patch11 -p1
+%{?with_wkhtml:%patch11 -p1}
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
 %patch16 -p1
 %patch12 -p1
 %patch13 -p1
 %patch14 -p1
 %patch15 -p1
 %patch16 -p1
+%patch17 -p1
+
+%patch18 -p1
+%patch19 -p1
+%patch20 -p1
+%patch21 -p1
+%patch22 -p1
+
+%patch28 -p1
+%patch29 -p0
+%patch30 -p1
+%patch31 -p0
+%patch32 -p1
+%patch33 -p1
+%patch34 -p1
+%patch35 -p1
+%patch36 -p1
+%patch37 -p1
+%patch38 -p1
+%patch39 -p1
+%patch40 -p1
+%patch41 -p1
+%patch42 -p1
+%patch43 -p1
+%patch44 -p1
+%patch45 -p1
+%patch46 -p1
+%patch47 -p1
+%patch48 -p1
+%patch49 -p1
+%patch50 -p1
+%patch51 -p1
+%patch52 -p1
+%patch53 -p1
 
 %{__sed} -i -e 's,usr/X11R6/,usr/g,' mkspecs/linux-g++-64/qmake.conf \
        mkspecs/common/linux.conf
 
 %{__sed} -i -e 's,usr/X11R6/,usr/g,' mkspecs/linux-g++-64/qmake.conf \
        mkspecs/common/linux.conf
@@ -1493,7 +1605,7 @@ Programas exemplo para o Qt versão.
        ' mkspecs/common/linux.conf
 
 # disable webkit tests, broken build
        ' mkspecs/common/linux.conf
 
 # disable webkit tests, broken build
-rm -r src/3rdparty/webkit/Source/WebKit/qt/tests
+%{__rm} -r src/3rdparty/webkit/Source/WebKit/qt/tests
 
 %build
 # pass OPTFLAGS to build qmake itself with optimization
 
 %build
 # pass OPTFLAGS to build qmake itself with optimization
@@ -1552,6 +1664,7 @@ COMMONOPT=" \
        %{?with_nas:-system-nas-sound} \
        %{?debug:-debug} \
        %{!?debug:-release} \
        %{?with_nas:-system-nas-sound} \
        %{?debug:-debug} \
        %{!?debug:-release} \
+       -%{!?with_openvg:no-}openvg \
        -qt3support \
        -fontconfig \
        -largefile \
        -qt3support \
        -fontconfig \
        -largefile \
@@ -1578,12 +1691,13 @@ COMMONOPT=" \
 
 %if %{with static_libs}
 OPT=" \
 
 %if %{with static_libs}
 OPT=" \
+       -%{!?with_ibase:no}%{?with_ibase:qt}-sql-ibase \
        -%{!?with_mysql:no}%{?with_mysql:qt}-sql-mysql \
        -%{!?with_odbc:no}%{?with_odbc:qt}-sql-odbc \
        -%{!?with_mysql:no}%{?with_mysql:qt}-sql-mysql \
        -%{!?with_odbc:no}%{?with_odbc:qt}-sql-odbc \
+       -%{!?with_oci:no}%{?with_oci:qt}-sql-oci \
        -%{!?with_pgsql:no}%{?with_pgsql:qt}-sql-psql \
        -%{!?with_sqlite3:no}%{?with_sqlite3:qt}-sql-sqlite \
        -%{!?with_sqlite:no}%{?with_sqlite:qt}-sql-sqlite2 \
        -%{!?with_pgsql:no}%{?with_pgsql:qt}-sql-psql \
        -%{!?with_sqlite3:no}%{?with_sqlite3:qt}-sql-sqlite \
        -%{!?with_sqlite:no}%{?with_sqlite:qt}-sql-sqlite2 \
-       -%{!?with_ibase:no}%{?with_ibase:qt}-sql-ibase \
        -static"
 
 ./configure $COMMONOPT $OPT
        -static"
 
 ./configure $COMMONOPT $OPT
@@ -1603,12 +1717,13 @@ fi
 ##################################
 
 OPT=" \
 ##################################
 
 OPT=" \
+       -%{!?with_ibase:no}%{?with_ibase:plugin}-sql-ibase \
        -%{!?with_mysql:no}%{?with_mysql:plugin}-sql-mysql \
        -%{!?with_odbc:no}%{?with_odbc:plugin}-sql-odbc \
        -%{!?with_mysql:no}%{?with_mysql:plugin}-sql-mysql \
        -%{!?with_odbc:no}%{?with_odbc:plugin}-sql-odbc \
+       -%{!?with_oci:no}%{?with_oci:plugin}-sql-oci \
        -%{!?with_pgsql:no}%{?with_pgsql:plugin}-sql-psql \
        -%{!?with_sqlite3:no}%{?with_sqlite3:plugin}-sql-sqlite \
        -%{!?with_sqlite:no}%{?with_sqlite:plugin}-sql-sqlite2 \
        -%{!?with_pgsql:no}%{?with_pgsql:plugin}-sql-psql \
        -%{!?with_sqlite3:no}%{?with_sqlite3:plugin}-sql-sqlite \
        -%{!?with_sqlite:no}%{?with_sqlite:plugin}-sql-sqlite2 \
-       -%{!?with_ibase:no}%{?with_ibase:plugin}-sql-ibase \
        -shared"
 
 ./configure $COMMONOPT $OPT
        -shared"
 
 ./configure $COMMONOPT $OPT
@@ -1621,8 +1736,12 @@ OPT=" \
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/env.d,%{_bindir},%{_desktopdir},%{_pixmapsdir},%{_pkgconfigdir}}
+install -d $RPM_BUILD_ROOT{/etc/{env.d,qt4},%{_bindir},%{_desktopdir},%{_pixmapsdir},%{_pkgconfigdir}}
 install -d $RPM_BUILD_ROOT%{_qtdir}/plugins/{crypto,network}
 install -d $RPM_BUILD_ROOT%{_qtdir}/plugins/{crypto,network}
+install -d $RPM_BUILD_ROOT%{_qtdir}/imports/org
+
+# for QtSolutions (qtlockedfile, qtsingleapplication, etc)
+install -d $RPM_BUILD_ROOT%{_includedir}/qt4/QtSolutions
 
 echo '#QT_GRAPHICSSYSTEM=raster' > $RPM_BUILD_ROOT/etc/env.d/QT_GRAPHICSSYSTEM
 
 
 echo '#QT_GRAPHICSSYSTEM=raster' > $RPM_BUILD_ROOT/etc/env.d/QT_GRAPHICSSYSTEM
 
@@ -1640,6 +1759,9 @@ install bin/qdoc3 $RPM_BUILD_ROOT%{_qtdir}/bin/qdoc3
        s|uic_location=.*|uic_location=%{_bindir}/uic-qt4|;
        ' $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
 
        s|uic_location=.*|uic_location=%{_bindir}/uic-qt4|;
        ' $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
 
+# kill -std=XYZ, so qmake won't pass it over to other projects
+#%{__sed} -i -e s#^\(.*\) -std=[a-z0-9+]\+\( .*\|$\)#\1 \2#g' $RPM_BUILD_ROOT%{_datadir}/qt4/mkspecs/common/g++-base.conf
+
 # libQtWebKit.la contains '-ljscore' and '-lwebcore', they come
 # from src/3rdparty/webkit/{JavaScriptCore,WebCore}} but those libs aren't installed
 %{__sed} -i -e "s,-lwebcore,,g;s,-ljscore,,g;" $RPM_BUILD_ROOT%{_libdir}/libQtWebKit.la
 # libQtWebKit.la contains '-ljscore' and '-lwebcore', they come
 # from src/3rdparty/webkit/{JavaScriptCore,WebCore}} but those libs aren't installed
 %{__sed} -i -e "s,-lwebcore,,g;s,-ljscore,,g;" $RPM_BUILD_ROOT%{_libdir}/libQtWebKit.la
@@ -1676,7 +1798,7 @@ ln -sf ../%{_lib}/qt4/bin/xmlpatternsvalidator .
 cd -
 
 # multilib
 cd -
 
 # multilib
-mv $RPM_BUILD_ROOT%{_qtdir}/bin/{qdbus,qdbusviewer} $RPM_BUILD_ROOT%{_bindir}
+%{__mv} $RPM_BUILD_ROOT%{_qtdir}/bin/{qdbus,qdbusviewer} $RPM_BUILD_ROOT%{_bindir}
 ln -sf %{_bindir}/qdbus $RPM_BUILD_ROOT%{_qtdir}/bin/qdbus
 ln -sf %{_bindir}/qdbusviewer $RPM_BUILD_ROOT%{_qtdir}/bin/qdbusviewer
 
 ln -sf %{_bindir}/qdbus $RPM_BUILD_ROOT%{_qtdir}/bin/qdbus
 ln -sf %{_bindir}/qdbusviewer $RPM_BUILD_ROOT%{_qtdir}/bin/qdbusviewer
 
@@ -1737,7 +1859,6 @@ done
 cd -
 
 # Ship doc & qmake stuff
 cd -
 
 # Ship doc & qmake stuff
-ln -s %{_docdir}/%{name}-doc $RPM_BUILD_ROOT%{_qtdir}/doc
 ln -s %{_datadir}/qt4/mkspecs $RPM_BUILD_ROOT%{_qtdir}/mkspecs
 
 for f in $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc; do
 ln -s %{_datadir}/qt4/mkspecs $RPM_BUILD_ROOT%{_qtdir}/mkspecs
 
 for f in $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc; do
@@ -1756,6 +1877,20 @@ for f in $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc; do
        sed -i -e "s:-DQT_SHARED:-DQT_SHARED $DEFS:" $f
 done
 
        sed -i -e "s:-DQT_SHARED:-DQT_SHARED $DEFS:" $f
 done
 
+# Ship private headers - ugly hack to build calibre
+install -d $RPM_BUILD_ROOT%{_includedir}/qt4/private
+rsync -aR include/QtCore/private \
+         include/QtDeclarative/private \
+         include/QtGui/private \
+         include/QtScript/private \
+         $RPM_BUILD_ROOT%{_includedir}/qt4/private
+rsync -aR src/corelib/*/*_p.h \
+          src/declarative/*/*_p.h \
+          src/gui/*/*_p.h \
+          src/script/*/*_p.h \
+         $RPM_BUILD_ROOT%{_includedir}/qt4/private
+
+
 # Prepare some files list
 ifecho() {
        RESULT=`echo $RPM_BUILD_ROOT$2 2>/dev/null`
 # Prepare some files list
 ifecho() {
        RESULT=`echo $RPM_BUILD_ROOT$2 2>/dev/null`
@@ -1802,7 +1937,7 @@ mkdevfl QtGui
 mkdevfl QtMultimedia
 mkdevfl QtNetwork
 mkdevfl QtOpenGL
 mkdevfl QtMultimedia
 mkdevfl QtNetwork
 mkdevfl QtOpenGL
-mkdevfl QtOpenVG
+%{?with_openvg:mkdevfl QtOpenVG}
 mkdevfl QtScript
 mkdevfl QtScriptTools
 mkdevfl QtSql
 mkdevfl QtScript
 mkdevfl QtScriptTools
 mkdevfl QtSql
@@ -1950,6 +2085,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQtCore.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtCore.so.4
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQtCore.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtCore.so.4
+%dir /etc/qt4
 %dir %{_qtdir}
 %dir %{_qtdir}/bin
 %dir %{_qtdir}/plugins
 %dir %{_qtdir}
 %dir %{_qtdir}/bin
 %dir %{_qtdir}/plugins
@@ -1964,6 +2100,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(da) %{_localedir}/da/LC_MESSAGES/qt4.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4.qm
 %lang(es) %{_localedir}/es/LC_MESSAGES/qt4.qm
 %lang(da) %{_localedir}/da/LC_MESSAGES/qt4.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4.qm
 %lang(es) %{_localedir}/es/LC_MESSAGES/qt4.qm
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4.qm
 %lang(fa) %{_localedir}/fa/LC_MESSAGES/qt4.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4.qm
 %lang(gl) %{_localedir}/gl/LC_MESSAGES/qt4.qm
 %lang(fa) %{_localedir}/fa/LC_MESSAGES/qt4.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4.qm
 %lang(gl) %{_localedir}/gl/LC_MESSAGES/qt4.qm
@@ -2013,6 +2150,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_qtdir}/imports/QtWebKit
 %attr(755,root,root) %{_qtdir}/imports/QtWebKit/*.so
 %{_qtdir}/imports/QtWebKit/qmldir
 %dir %{_qtdir}/imports/QtWebKit
 %attr(755,root,root) %{_qtdir}/imports/QtWebKit/*.so
 %{_qtdir}/imports/QtWebKit/qmldir
+%dir %{_qtdir}/imports/org
 %dir %{_qtdir}/plugins/qmltooling
 %attr(755,root,root) %{_qtdir}/plugins/qmltooling/libqmldbg_tcp.so
 %attr(755,root,root) %{_qtdir}/plugins/qmltooling/libqmldbg_inspector.so
 %dir %{_qtdir}/plugins/qmltooling
 %attr(755,root,root) %{_qtdir}/plugins/qmltooling/libqmldbg_tcp.so
 %attr(755,root,root) %{_qtdir}/plugins/qmltooling/libqmldbg_inspector.so
@@ -2057,6 +2195,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(cs) %{_localedir}/cs/LC_MESSAGES/qt4-qt_help.qm
 %lang(da) %{_localedir}/da/LC_MESSAGES/qt4-qt_help.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4-qt_help.qm
 %lang(cs) %{_localedir}/cs/LC_MESSAGES/qt4-qt_help.qm
 %lang(da) %{_localedir}/da/LC_MESSAGES/qt4-qt_help.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4-qt_help.qm
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-qt_help.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4-qt_help.qm
 %lang(gl) %{_localedir}/gl/LC_MESSAGES/qt4-qt_help.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-qt_help.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4-qt_help.qm
 %lang(gl) %{_localedir}/gl/LC_MESSAGES/qt4-qt_help.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-qt_help.qm
@@ -2087,16 +2226,19 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libQtOpenGL.so.4
 %attr(755,root,root) %{_qtdir}/plugins/graphicssystems/libqglgraphicssystem.so
 
 %attr(755,root,root) %ghost %{_libdir}/libQtOpenGL.so.4
 %attr(755,root,root) %{_qtdir}/plugins/graphicssystems/libqglgraphicssystem.so
 
+%if %{with openvg}
 %files -n QtOpenVG
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQtOpenVG.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtOpenVG.so.4
 %files -n QtOpenVG
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQtOpenVG.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtOpenVG.so.4
+%endif
 
 %files -n QtScript
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQtScript.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtScript.so.4
 %dir %{_qtdir}/plugins/script
 
 %files -n QtScript
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQtScript.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtScript.so.4
 %dir %{_qtdir}/plugins/script
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-qtscript.qm
 
 %files -n QtScriptTools
 %defattr(644,root,root,755)
 
 %files -n QtScriptTools
 %defattr(644,root,root,755)
@@ -2109,12 +2251,30 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libQtSql.so.4
 %dir %{_qtdir}/plugins/sqldrivers
 
 %attr(755,root,root) %ghost %{_libdir}/libQtSql.so.4
 %dir %{_qtdir}/plugins/sqldrivers
 
+%if %{with ibase}
+%files -n QtSql-ibase
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlibase.so
+%endif
+
 %if %{with mysql}
 %files -n QtSql-mysql
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlmysql.so
 %endif
 
 %if %{with mysql}
 %files -n QtSql-mysql
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlmysql.so
 %endif
 
+%if %{with oci}
+%files -n QtSql-oci
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqloci.so
+%endif
+
+%if %{with odbc}
+%files -n QtSql-odbc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlodbc.so
+%endif
+
 %if %{with pgsql}
 %files -n QtSql-pgsql
 %defattr(644,root,root,755)
 %if %{with pgsql}
 %files -n QtSql-pgsql
 %defattr(644,root,root,755)
@@ -2133,18 +2293,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlite.so
 %endif
 
 %attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlite.so
 %endif
 
-%if %{with ibase}
-%files -n QtSql-ibase
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlibase.so
-%endif
-
-%if %{with odbc}
-%files -n QtSql-odbc
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlodbc.so
-%endif
-
 %files -n QtSql-tds
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqltds.so
 %files -n QtSql-tds
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqltds.so
@@ -2195,6 +2343,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(cs) %{_localedir}/cs/LC_MESSAGES/qt4-assistant.qm
 %lang(da) %{_localedir}/da/LC_MESSAGES/qt4-assistant.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4-assistant.qm
 %lang(cs) %{_localedir}/cs/LC_MESSAGES/qt4-assistant.qm
 %lang(da) %{_localedir}/da/LC_MESSAGES/qt4-assistant.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4-assistant.qm
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-assistant.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4-assistant.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-assistant.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-assistant.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4-assistant.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-assistant.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-assistant.qm
@@ -2244,6 +2393,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/designer-qt4.desktop
 %{_pixmapsdir}/designer-qt4.png
 
 %{_desktopdir}/designer-qt4.desktop
 %{_pixmapsdir}/designer-qt4.png
 
+%files devel-private
+%defattr(644,root,root,755)
+%{_includedir}/qt4/private
+
 %files linguist
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/findtr-qt4
 %files linguist
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/findtr-qt4
@@ -2257,7 +2410,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_qtdir}/bin/lupdate
 %lang(cs) %{_localedir}/cs/LC_MESSAGES/qt4-linguist.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4-linguist.qm
 %attr(755,root,root) %{_qtdir}/bin/lupdate
 %lang(cs) %{_localedir}/cs/LC_MESSAGES/qt4-linguist.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4-linguist.qm
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-linguist.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4-linguist.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4-linguist.qm
+%lang(he) %{_localedir}/he/LC_MESSAGES/qt4-linguist.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-linguist.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-linguist.qm
 %lang(ko) %{_localedir}/ko/LC_MESSAGES/qt4-linguist.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-linguist.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-linguist.qm
 %lang(ko) %{_localedir}/ko/LC_MESSAGES/qt4-linguist.qm
@@ -2291,6 +2446,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qtconfig-qt4
 %attr(755,root,root) %{_qtdir}/bin/qtconfig
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qtconfig-qt4
 %attr(755,root,root) %{_qtdir}/bin/qtconfig
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-qtconfig.qm
+%lang(he) %{_localedir}/he/LC_MESSAGES/qt4-qtconfig.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-qtconfig.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-qtconfig.qm
 %lang(ko) %{_localedir}/ko/LC_MESSAGES/qt4-qtconfig.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-qtconfig.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-qtconfig.qm
 %lang(ko) %{_localedir}/ko/LC_MESSAGES/qt4-qtconfig.qm
@@ -2307,6 +2464,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qvfb
 %attr(755,root,root) %{_qtdir}/bin/qvfb
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qvfb
 %attr(755,root,root) %{_qtdir}/bin/qvfb
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-qvfb.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-qvfb.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-qvfb.qm
 %lang(ko) %{_localedir}/ko/LC_MESSAGES/qt4-qvfb.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-qvfb.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-qvfb.qm
 %lang(ko) %{_localedir}/ko/LC_MESSAGES/qt4-qvfb.qm
@@ -2320,7 +2478,6 @@ rm -rf $RPM_BUILD_ROOT
 %files doc
 %defattr(644,root,root,755)
 %{_docdir}/%{name}-doc
 %files doc
 %defattr(644,root,root,755)
 %{_docdir}/%{name}-doc
-%{_qtdir}/doc
 
 %files -n QtCLucene-devel -f QtCLucene-devel.files
 %defattr(644,root,root,755)
 
 %files -n QtCLucene-devel -f QtCLucene-devel.files
 %defattr(644,root,root,755)
@@ -2332,6 +2489,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n QtCore-devel -f QtCore-devel.files
 %defattr(644,root,root,755)
 
 %files -n QtCore-devel -f QtCore-devel.files
 %defattr(644,root,root,755)
+%dir %{_includedir}/qt4/QtSolutions
 
 %files -n QtDBus-devel -f QtDBus-devel.files
 %defattr(644,root,root,755)
 
 %files -n QtDBus-devel -f QtDBus-devel.files
 %defattr(644,root,root,755)
@@ -2357,8 +2515,10 @@ rm -rf $RPM_BUILD_ROOT
 %files -n QtOpenGL-devel -f QtOpenGL-devel.files
 %defattr(644,root,root,755)
 
 %files -n QtOpenGL-devel -f QtOpenGL-devel.files
 %defattr(644,root,root,755)
 
+%if %{with openvg}
 %files -n QtOpenVG-devel -f QtOpenVG-devel.files
 %defattr(644,root,root,755)
 %files -n QtOpenVG-devel -f QtOpenVG-devel.files
 %defattr(644,root,root,755)
+%endif
 
 %files -n QtScript-devel -f QtScript-devel.files
 %defattr(644,root,root,755)
 
 %files -n QtScript-devel -f QtScript-devel.files
 %defattr(644,root,root,755)
@@ -2434,9 +2594,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libQtOpenGL.a
 
 %defattr(644,root,root,755)
 %{_libdir}/libQtOpenGL.a
 
+%if %{with openvg}
 %files -n QtOpenVG-static
 %defattr(644,root,root,755)
 %{_libdir}/libQtOpenVG.a
 %files -n QtOpenVG-static
 %defattr(644,root,root,755)
 %{_libdir}/libQtOpenVG.a
+%endif
 
 %files -n QtScript-static
 %defattr(644,root,root,755)
 
 %files -n QtScript-static
 %defattr(644,root,root,755)
This page took 0.049442 seconds and 4 git commands to generate.