]> git.pld-linux.org Git - packages/zziplib.git/blob - zziplib.spec
a44bfd2bca19a7f1f398dc520d07ab667493b3f1
[packages/zziplib.git] / zziplib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 #
5 Summary:        ZZipLib - libZ-based ZIP-access Library
6 Summary(pl.UTF-8):      ZZipLib - biblioteka dostępu do archiwów ZIP
7 Name:           zziplib
8 Version:        0.13.68
9 Release:        1
10 Epoch:          1
11 License:        LGPL v2 or MPL 1.1
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/zziplib/%{name}-%{version}.tar.bz2
14 # Source0-md5:  8b0cc7c506b172a4938c3338b122c2f0
15 Patch0:         %{name}-test.patch
16 Patch1:         %{name}-manpages.patch
17 URL:            http://zziplib.sourceforge.net/
18 BuildRequires:  autoconf >= 2.61
19 BuildRequires:  automake >= 1:1.7
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  libtool >= 1:1.4.3
22 BuildRequires:  pkgconfig
23 BuildRequires:  python
24 BuildRequires:  python-modules
25 BuildRequires:  xmlto
26 BuildRequires:  zip
27 BuildRequires:  zlib-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 ZZipLib provides read access to zipped files in a zip-archive, using
32 compression based solely on free algorithms provided by zlib. ZZipLib
33 provides an additional API to transparently access files being either
34 real files or zipped files with the same filepath argument. This is
35 handy to package many files being shared data into a single zip file -
36 as it is sometimes used with gamedata or script repositories. The
37 library itself is fully multithreaded, and it is namespace clean using
38 the zzip_ prefix for its exports and declarations.
39
40 %description -l pl.UTF-8
41 ZZipLib pozwala na odczyt plików skompresowanych w archiwach zip,
42 używając do dekompresji wolnodostępnych algorytmów z biblioteki zlib.
43 ZZipLib dostarcza dodatkowe API do przezroczystego dostępu do plików
44 rzeczywistych lub umieszczonych w archiwach zip przy pomocy takiej
45 samej ścieżki. Jest to przydatne przy trzymaniu wielu plików w jednym
46 archiwum, co bywa stosowane w przypadku danych dla gier lub
47 repozytoriów. Biblioteka jest w pełni wielowątkowa i ma czystą
48 przestrzeń nazw (używa prefiksu zzip_).
49
50 %package devel
51 Summary:        ZZipLib - Development Files
52 Summary(pl.UTF-8):      Pliki dla programistów ZZipLib
53 Group:          Development/Libraries
54 Requires:       %{name} = %{epoch}:%{version}-%{release}
55
56 %description devel
57 These are the header files needed to develop programs using zziplib.
58
59 %description devel -l pl.UTF-8
60 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
61 korzystających z biblioteki zziplib.
62
63 %package static
64 Summary:        ZZipLib static library
65 Summary(pl.UTF-8):      Statyczna biblioteka ZZipLib
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
68
69 %description static
70 ZZipLib static library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka ZZipLib.
74
75 %package apidocs
76 Summary:        API documentation for ZZipLib library
77 Summary(pl.UTF-8):      Dokumentacja API biblioteki ZZipLib
78 Group:          Documentation
79 %{?noarchpackage}
80
81 %description apidocs
82 API documentation for ZZipLib library.
83
84 %description apidocs -l pl.UTF-8
85 Dokumentacja API biblioteki ZZipLib.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         --disable-builddir
100
101 %{__make}
102 %{__make} -j1 check
103 %if %{with apidocs}
104 %{__make} doc
105 %endif
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %if %{with apidocs}
114 %{__make} install-man3 -C docs \
115         DESTDIR=$RPM_BUILD_ROOT
116 %endif
117
118 # we don't need these compat symlinks
119 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libzzip*-0.so.{10,11,12}
120 # obsoleted by pkg-config
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libzzip*.la
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 %doc ChangeLog README TODO docs/COPYING.ZLIB
132 %attr(755,root,root) %{_bindir}/zzcat
133 %attr(755,root,root) %{_bindir}/zzdir
134 %attr(755,root,root) %{_bindir}/zzxor*
135 %attr(755,root,root) %{_bindir}/unzip-mem
136 %attr(755,root,root) %{_bindir}/unzzip*
137 %attr(755,root,root) %{_libdir}/libzzip-0.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libzzip-0.so.13
139 %attr(755,root,root) %{_libdir}/libzzipfseeko-0.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libzzipfseeko-0.so.13
141 %attr(755,root,root) %{_libdir}/libzzipmmapped-0.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libzzipmmapped-0.so.13
143 %attr(755,root,root) %{_libdir}/libzzipwrap-0.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libzzipwrap-0.so.13
145
146 %files devel
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/libzzip.so
149 %attr(755,root,root) %{_libdir}/libzzipfseeko.so
150 %attr(755,root,root) %{_libdir}/libzzipmmapped.so
151 %attr(755,root,root) %{_libdir}/libzzipwrap.so
152 %{_includedir}/zzip
153 %{_includedir}/zzip*.h
154 %if %{with apidocs}
155 %{_mandir}/man3/__zzip_*.3*
156 %{_mandir}/man3/zzip_*.3*
157 %endif
158 %{_pkgconfigdir}/zzip-zlib-config.pc
159 %{_pkgconfigdir}/zzipfseeko.pc
160 %{_pkgconfigdir}/zziplib.pc
161 %{_pkgconfigdir}/zzipmmapped.pc
162 %{_pkgconfigdir}/zzipwrap.pc
163 %{_aclocaldir}/zziplib.m4
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libzzip.a
168 %{_libdir}/libzzipfseeko.a
169 %{_libdir}/libzzipmmapped.a
170 %{_libdir}/libzzipwrap.a
171
172 %if %{with apidocs}
173 %files apidocs
174 %defattr(644,root,root,755)
175 %doc docs/*.{html,css}
176 %endif
This page took 0.261129 seconds and 2 git commands to generate.