]> git.pld-linux.org Git - packages/zziplib.git/blob - zziplib.spec
- new Source0, updated to 0.13.72
[packages/zziplib.git] / zziplib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # API documentation
4 #
5 Summary:        ZZipLib - libZ-based ZIP-access Library
6 Summary(pl.UTF-8):      ZZipLib - biblioteka dostępu do archiwów ZIP
7 Name:           zziplib
8 Version:        0.13.72
9 Release:        1
10 Epoch:          1
11 License:        LGPL v2 or MPL 1.1
12 Group:          Libraries
13 #Source0Download: https://github.com/gdraheim/zziplib/tags
14 Source0:        https://github.com/gdraheim/zziplib/archive/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  43555e7eafc5c1a1178a35e716c40500
16 Patch0:         %{name}-fpe.patch
17 Patch1:         %{name}-manpages.patch
18 URL:            http://zziplib.sourceforge.net/
19 BuildRequires:  autoconf >= 2.61
20 BuildRequires:  automake >= 1:1.7
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  libtool >= 1:1.4.3
23 BuildRequires:  pkgconfig
24 BuildRequires:  python
25 BuildRequires:  python-modules
26 BuildRequires:  xmlto
27 BuildRequires:  zip
28 BuildRequires:  zlib-devel
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 ZZipLib provides read access to zipped files in a zip-archive, using
33 compression based solely on free algorithms provided by zlib. ZZipLib
34 provides an additional API to transparently access files being either
35 real files or zipped files with the same filepath argument. This is
36 handy to package many files being shared data into a single zip file -
37 as it is sometimes used with gamedata or script repositories. The
38 library itself is fully multithreaded, and it is namespace clean using
39 the zzip_ prefix for its exports and declarations.
40
41 %description -l pl.UTF-8
42 ZZipLib pozwala na odczyt plików skompresowanych w archiwach zip,
43 używając do dekompresji wolnodostępnych algorytmów z biblioteki zlib.
44 ZZipLib dostarcza dodatkowe API do przezroczystego dostępu do plików
45 rzeczywistych lub umieszczonych w archiwach zip przy pomocy takiej
46 samej ścieżki. Jest to przydatne przy trzymaniu wielu plików w jednym
47 archiwum, co bywa stosowane w przypadku danych dla gier lub
48 repozytoriów. Biblioteka jest w pełni wielowątkowa i ma czystą
49 przestrzeń nazw (używa prefiksu zzip_).
50
51 %package devel
52 Summary:        ZZipLib - Development Files
53 Summary(pl.UTF-8):      Pliki dla programistów ZZipLib
54 Group:          Development/Libraries
55 Requires:       %{name} = %{epoch}:%{version}-%{release}
56
57 %description devel
58 These are the header files needed to develop programs using zziplib.
59
60 %description devel -l pl.UTF-8
61 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
62 korzystających z biblioteki zziplib.
63
64 %package static
65 Summary:        ZZipLib static library
66 Summary(pl.UTF-8):      Statyczna biblioteka ZZipLib
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
69
70 %description static
71 ZZipLib static library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka ZZipLib.
75
76 %package apidocs
77 Summary:        API documentation for ZZipLib library
78 Summary(pl.UTF-8):      Dokumentacja API biblioteki ZZipLib
79 Group:          Documentation
80 BuildArch:      noarch
81
82 %description apidocs
83 API documentation for ZZipLib library.
84
85 %description apidocs -l pl.UTF-8
86 Dokumentacja API biblioteki ZZipLib.
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92
93 # stick to autotools for now
94 %{__mv} old.configure.ac configure.ac
95 %{__rm} GNUmakefile
96
97 %build
98 %{__libtoolize}
99 %{__aclocal} -I m4
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure
104
105 %{__make}
106 %{__make} -j1 check
107 %if %{with apidocs}
108 %{__make} doc
109 %endif
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT
116
117 %if %{with apidocs}
118 %{__make} -C docs install-man3 \
119         DESTDIR=$RPM_BUILD_ROOT
120 %endif
121
122 # we don't need these compat symlinks
123 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libzzip*-0.so.{10,11,12}
124 # obsoleted by pkg-config
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libzzip*.la
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc ChangeLog README TODO docs/COPYING.ZLIB
136 %attr(755,root,root) %{_bindir}/zzcat
137 %attr(755,root,root) %{_bindir}/zzdir
138 %attr(755,root,root) %{_bindir}/zzxor*
139 %attr(755,root,root) %{_bindir}/unzip-mem
140 %attr(755,root,root) %{_bindir}/unzzip*
141 %attr(755,root,root) %{_libdir}/libzzip-0.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libzzip-0.so.13
143 %attr(755,root,root) %{_libdir}/libzzipfseeko-0.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libzzipfseeko-0.so.13
145 %attr(755,root,root) %{_libdir}/libzzipmmapped-0.so.*.*.*
146 %attr(755,root,root) %ghost %{_libdir}/libzzipmmapped-0.so.13
147 %attr(755,root,root) %{_libdir}/libzzipwrap-0.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libzzipwrap-0.so.13
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libzzip.so
153 %attr(755,root,root) %{_libdir}/libzzipfseeko.so
154 %attr(755,root,root) %{_libdir}/libzzipmmapped.so
155 %attr(755,root,root) %{_libdir}/libzzipwrap.so
156 %{_includedir}/zzip
157 %{_includedir}/zzip*.h
158 %if %{with apidocs}
159 %{_mandir}/man3/__zzip_*.3*
160 %{_mandir}/man3/zzip_*.3*
161 %endif
162 %{_pkgconfigdir}/zzip-zlib-config.pc
163 %{_pkgconfigdir}/zzipfseeko.pc
164 %{_pkgconfigdir}/zziplib.pc
165 %{_pkgconfigdir}/zzipmmapped.pc
166 %{_pkgconfigdir}/zzipwrap.pc
167 %{_aclocaldir}/zziplib.m4
168
169 %files static
170 %defattr(644,root,root,755)
171 %{_libdir}/libzzip.a
172 %{_libdir}/libzzipfseeko.a
173 %{_libdir}/libzzipmmapped.a
174 %{_libdir}/libzzipwrap.a
175
176 %if %{with apidocs}
177 %files apidocs
178 %defattr(644,root,root,755)
179 %doc docs/*.{html,css}
180 %endif
This page took 0.032236 seconds and 3 git commands to generate.