]> git.pld-linux.org Git - packages/zint.git/blob - zint.spec
6a79ffb3639b38cbe076c534155b8261f0faf64f
[packages/zint.git] / zint.spec
1 Summary:        Barcode generator
2 Summary(pl.UTF-8):      Generator kodów kreskowych
3 Name:           zint
4 Version:        2.6.7
5 Release:        2
6 License:        GPL v3+
7 Group:          Applications/Graphics
8 Source0:        http://downloads.sourceforge.net/zint/%{name}-%{version}.tar.gz
9 # Source0-md5:  46c7c22dd1268c66be9293ddbe11506c
10 BuildRequires:  Qt5Core-devel >= 5
11 BuildRequires:  Qt5Gui-devel >= 5
12 BuildRequires:  Qt5UiTools-devel >= 5
13 BuildRequires:  Qt5Widgets-devel >= 5
14 BuildRequires:  Qt5Xml-devel >= 5
15 BuildRequires:  cmake >= 2.6.0
16 BuildRequires:  libpng-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  qt5-build >= 5
19 BuildRequires:  qt5-qmake >= 5
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Zint is a C library for encoding data in several barcode variants. The
24 bundled command-line utility provides a simple interface to the
25 library. Features of the library:
26 - Over 50 symbologies including all ISO/IEC standards, like QR codes.
27 - Unicode translation for symbologies which support Latin-1 and Kanji
28   character sets.
29 - Full GS1 support including data verification and automated insertion
30   of FNC1 characters.
31 - Support for encoding binary data including NULL (ASCII 0)
32   characters.
33 - Health Industry Barcode (HIBC) encoding capabilities.
34 - Output in PNG, EPS and SVG formats with user adjustable sizes and
35   colors.
36 - Verification stage for SBN, ISBN and ISBN-13 data.
37
38 %description -l pl.UTF-8
39 Zint to biblioteka C do kodowania danych w kilku wariantach kodów
40 koreskowych. Dołączone narzędzie linii poleceń udostępnia prosty
41 interfejs do biblioteki. Możliwości biblioteki:
42 - ponad 50 zestawów symboli, w tym wszystkie standardy ISO/IEC, typu
43   kody QR
44 - tłumaczenie unikodowe symboli obsługujących zestawy znaków Latin-1 i
45   Kanji
46 - pełna obsługa GS1, w tym weryfikacja danych i automatyczne
47   wstawianie znaków FNC1
48 - obsługa kodowania danych binarnych wraz ze znakami NULL (ASCII 0)
49 - możliwość kodowania HIBC (Health Industry Barcode)
50 - wyjście w formatach PNG, EPS, SVG z rozmiarami i kolorami
51   wybieranymi przez użytkownika
52 - etap weryfikacji dla danych SBN, ISBN i ISBN-13.
53
54 %package devel
55 Summary:        Header files for zint library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki zint
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59
60 %description devel
61 Header files for zint library.
62
63 %description devel -l pl.UTF-8
64 Pliki nagłówkowe biblioteki zint.
65
66 %package qt
67 Summary:        Zint Barcode Studio
68 Summary(pl.UTF-8):      Zint Barcode Studio
69 Group:          X11/Applications/Graphics
70 Requires:       %{name} = %{version}-%{release}
71
72 %description qt
73 Zint Barcode Studio is a Qt-based GUI which allows desktop users to
74 generate barcodes which can then be embedded in documents or HTML
75 pages.
76
77 %description qt -l pl.UTF-8
78 Zint Barcode Studio jest aplikacją z interfejsem Qt, która umożliwia
79 użytkownikom komputerów generować kody kreskowe. Mogą one później
80 zostać włączone do dokumentów lub stron HTML.
81
82 %package qt-devel
83 Summary:        Header files for QZint library
84 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki QZint
85 Group:          X11/Development/Libraries
86 Requires:       %{name}-devel = %{version}-%{release}
87 Requires:       %{name}-qt = %{version}-%{release}
88 Requires:       Qt5Gui-devel >= 5
89
90 %description qt-devel
91 Header files for QZint library.
92
93 %description qt-devel -l pl.UTF-8
94 Pliki nagłówkowe biblioteki QZint.
95
96 %prep
97 %setup -q
98
99 find -type f -exec chmod 644 {} \;
100
101 %build
102 %cmake \
103         -DDATA_INSTALL_DIR=%{_datadir}
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %{__mv} $RPM_BUILD_ROOT%{_datadir}/cmake/{modules,Modules}
115
116 install zint.png $RPM_BUILD_ROOT%{_pixmapsdir}
117 install zint-qt.desktop $RPM_BUILD_ROOT%{_desktopdir}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %post   qt -p /sbin/ldconfig
126 %postun qt -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %doc README TODO
131 %attr(755,root,root) %{_bindir}/zint
132 %attr(755,root,root) %{_libdir}/libzint.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libzint.so.2.6
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libzint.so
138 %{_includedir}/zint.h
139 %{_datadir}/cmake/Modules/FindZint.cmake
140
141 %files qt
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/zint-qt
144 %attr(755,root,root) %{_libdir}/libQZint.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libQZint.so.2.6
146 %{_pixmapsdir}/zint.png
147 %{_desktopdir}/zint-qt.desktop
148
149 %files qt-devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libQZint.so
152 %{_includedir}/qzint.h
This page took 0.053872 seconds and 2 git commands to generate.