]> git.pld-linux.org Git - packages/zfs.git/blob - zfs.spec
- rebuild wiyth python 3.10, rel 2
[packages/zfs.git] / zfs.spec
1 # TODO:
2 # - PLDify init script
3 #
4 # Conditional build:
5 %bcond_without  kernel          # don't build kernel modules
6 %bcond_without  userspace       # don't build userspace programs
7 %bcond_without  python2         # CPython 2.x module
8 %bcond_without  python3         # CPython 3.x module
9 %bcond_with     verbose         # verbose build (V=1)
10 #
11 # The goal here is to have main, userspace, package built once with
12 # simple release number, and only rebuild kernel packages with kernel
13 # version as part of release number, without the need to bump release
14 # with every kernel change.
15 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
16 %{error:kernel and userspace cannot be built at the same time on PLD builders}
17 exit 1
18 %endif
19
20 %if %{without userspace}
21 # nothing to be placed to debuginfo package
22 %define         _enable_debug_packages  0
23 %endif
24
25 %define         _duplicate_files_terminate_build        0
26
27 %define rel     2
28 %define pname   zfs
29 Summary:        Native Linux port of the ZFS filesystem
30 Summary(pl.UTF-8):      Natywny linuksowy port systemu plików ZFS
31 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
32 Version:        2.1.2
33 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
34 License:        CDDL
35 Group:          Applications/System
36 Source0:        https://github.com/openzfs/zfs/releases/download/zfs-%{version}/%{pname}-%{version}.tar.gz
37 # Source0-md5:  f7061f28aede1a2adf2cab10f2a43a14
38 Patch0:         initdir.patch
39 Patch1:         am.patch
40 URL:            https://zfsonlinux.org/
41 BuildRequires:  autoconf >= 2.50
42 BuildRequires:  automake
43 BuildRequires:  libtool
44 BuildRequires:  rpmbuild(macros) >= 1.714
45 %if %{with kernel}
46 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
47 %endif
48 %if %{with userspace}
49 # only for mmap_libaio test command
50 #BuildRequires: libaio-devel
51 BuildRequires:  libblkid-devel
52 BuildRequires:  libselinux-devel
53 BuildRequires:  libtirpc-devel
54 BuildRequires:  libuuid-devel
55 BuildRequires:  openssl-devel
56 BuildRequires:  pam-devel
57 BuildRequires:  pkgconfig
58 BuildRequires:  udev-devel
59 BuildRequires:  zlib-devel
60 %if %{with python2}
61 BuildRequires:  python-cffi
62 BuildRequires:  python-modules >= 1:2.6
63 BuildRequires:  python-setuptools
64 %endif
65 %if %{with python3}
66 BuildRequires:  python3-cffi
67 BuildRequires:  python3-modules >= 1:3.4
68 BuildRequires:  python3-setuptools
69 %endif
70 %if %{with python2} || %{with python3}
71 BuildRequires:  rpm-pythonprov
72 %endif
73 %endif
74 Requires:       %{pname}-libs = %{version}-%{release}
75 Obsoletes:      spl < 0.7.9-2
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %define         dracutlibdir    %{_prefix}/lib/dracut
79
80 %description
81 ZFS is an advanced file system and volume manager which was originally
82 developed for Solaris and is now maintained by the Illumos community.
83
84 ZFS on Linux, which is also known as ZoL, is currently feature
85 complete. It includes fully functional and stable SPA, DMU, ZVOL, and
86 ZPL layers.
87
88 %description -l pl.UTF-8
89 ZFS to zaawansowany system plików i zarządca wolumenów, oryginalnie
90 stworzony dla Solarisa, obecnie utrzymywany przez społeczność Illumos.
91
92 ZFS dla Linuksa, znany takża jako ZoL (ZFS on Linux), jest obecnie w
93 pełni funkcjonalny. Zawiera w pełni funkcjonalne i stabilne warstwy
94 SPA, DMU, ZVOL i ZPL.
95
96 %package libs
97 Summary:        ZFS on Linux libraries
98 Summary(pl.UTF-8):      Biblioteki ZFS-a dla Linuksa
99 License:        CDDL
100 Group:          Libraries
101 Requires(post,postun):  /sbin/ldconfig
102
103 %description libs
104 ZFS on Linux libraries.
105
106 %description libs -l pl.UTF-8
107 Biblioteki ZFS-a dla Linuksa.
108
109 %package devel
110 Summary:        Header files for ZFS libraries
111 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek ZFS-a
112 License:        CDDL
113 Group:          Development/Libraries
114 Requires:       %{pname}-libs = %{version}-%{release}
115 Requires:       libselinux-devel
116 Requires:       libtirpc-devel
117 Requires:       libuuid-devel
118 Requires:       zlib-devel
119
120 %description devel
121 Header files for ZFS libraries.
122
123 %description devel -l pl.UTF-8
124 Pliki nagłówkowe bibliotek ZFS-a.
125
126 %package static
127 Summary:        Static ZFS libraries
128 Summary(pl.UTF-8):      Statyczne biblioteki ZFS-a
129 License:        CDDL
130 Group:          Development/Libraries
131 Requires:       %{pname}-devel = %{version}-%{release}
132
133 %description static
134 Static ZFS libraries.
135
136 %description static -l pl.UTF-8
137 Statyczne biblioteki ZFS-a.
138
139 %package -n dracut-zfs
140 Summary:        ZFS support for Dracut
141 Summary(pl.UTF-8):      Obsługa ZFS-a dla Dracuta
142 Group:          Applications/System
143 Requires:       %{pname} = %{version}-%{release}
144 Requires:       dracut
145
146 %description -n dracut-zfs
147 ZFS support for Dracut.
148
149 %description -n dracut-zfs -l pl.UTF-8
150 Obsługa ZFS-a dla Dracuta.
151
152 %package -n pam-pam_zfs_key
153 Summary:        PAM module to unlock ZFS datasets for user
154 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika
155 Group:          Libraries
156 Requires:       %{pname}-libs = %{version}-%{release}
157 Requires:       pam
158
159 %description -n pam-pam_zfs_key
160 PAM module to unlock ZFS datasets for user.
161
162 %description -n pam-pam_zfs_key -l pl.UTF-8
163 Moduł PAM do odblokowywania zbiorów danych ZFS dla użytkownika.
164
165 %package -n python-pyzfs
166 Summary:        Python 2 wrapper for libzfs_core C library
167 Summary(pl.UTF-8):      Interfejs Pythona 2 do biblioteki C libzfs_core
168 License:        Apache v2.0
169 Group:          Libraries/Python
170 Requires:       %{pname}-libs = %{version}-%{release}
171
172 %description -n python-pyzfs
173 Python 2 wrapper for libzfs_core C library.
174
175 %description -n python-pyzfs -l pl.UTF-8
176 Interfejs Pythona 2 do biblioteki C libzfs_core.
177
178 %package -n python3-pyzfs
179 Summary:        Python 3 wrapper for libzfs_core C library
180 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki C libzfs_core
181 License:        Apache v2.0
182 Group:          Libraries/Python
183 Requires:       %{pname}-libs = %{version}-%{release}
184
185 %description -n python3-pyzfs
186 Python 3 wrapper for libzfs_core C library.
187
188 %description -n python3-pyzfs -l pl.UTF-8
189 Interfejs Pythona 3 do biblioteki C libzfs_core.
190
191 %package -n kernel-zfs-common-devel
192 Summary:        ZFS Linux kernel headers
193 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa
194 Group:          Development/Building
195 Obsoletes:      kernel-spl-common-devel < 0.7.9-2
196
197 %description -n kernel-zfs-common-devel
198 ZFS Linux kernel headers common for all PLD kernel versions.
199
200 %description -n kernel-zfs-common-devel -l pl.UTF-8
201 ZFS - pliki nagłówkowe jądra Linuksa wspólne na wszystkich
202 wersji jąder PLD.
203
204 %define kernel_pkg()\
205 %package -n kernel%{_alt_kernel}-zfs\
206 Summary:        ZFS Linux kernel modules\
207 Summary(pl.UTF-8):      ZFS - moduły jądra Linuksa\
208 Release:        %{rel}@%{_kernel_ver_str}\
209 Group:          Base/Kernel\
210 Requires(post,postun):  /sbin/depmod\
211 %requires_releq_kernel\
212 Requires(postun):       %releq_kernel\
213 \
214 %description -n kernel%{_alt_kernel}-zfs\
215 ZFS Linux kernel modules.\
216 \
217 %description -n kernel%{_alt_kernel}-zfs -l pl.UTF-8\
218 ZFS - moduły jądra Linuksa.\
219 \
220 %package -n kernel%{_alt_kernel}-zfs-devel\
221 Summary:        ZFS Linux kernel headers\
222 Summary(pl.UTF-8):      ZFS - pliki nagłówkowe jądra Linuksa\
223 Release:        %{rel}@%{_kernel_ver_str}\
224 Group:          Development/Building\
225 Requires:       kernel%{_alt_kernel}-headers\
226 Requires:       kernel-zfs-common-devel\
227 Obsoletes:      kernel-spl-devel < 0.7.9-2\
228 \
229 %description -n kernel%{_alt_kernel}-zfs-devel\
230 ZFS Linux kernel headers configured for PLD kernel%{_alt_kernel},\
231 version %{_kernel_ver}.\
232 \
233 %description -n kernel%{_alt_kernel}-zfs-devel -l pl.UTF-8\
234 ZFS - pliki nagłówkowe jądra Linuksa skonfigurowane dla jądra PLD z\
235 pakietu kernel%{_alt_kernel} w wersji %{_kernel_ver}.\
236 \
237 %files -n kernel%{_alt_kernel}-zfs\
238 %defattr(644,root,root,755)\
239 %dir /lib/modules/%{_kernel_ver}/misc/lua\
240 /lib/modules/%{_kernel_ver}/misc/lua/zlua.ko*\
241 %dir /lib/modules/%{_kernel_ver}/misc/avl\
242 /lib/modules/%{_kernel_ver}/misc/avl/zavl.ko*\
243 %dir /lib/modules/%{_kernel_ver}/misc/icp\
244 /lib/modules/%{_kernel_ver}/misc/icp/icp.ko*\
245 %dir /lib/modules/%{_kernel_ver}/misc/nvpair\
246 /lib/modules/%{_kernel_ver}/misc/nvpair/znvpair.ko*\
247 %dir /lib/modules/%{_kernel_ver}/misc/spl\
248 /lib/modules/%{_kernel_ver}/misc/spl/spl.ko*\
249 %dir /lib/modules/%{_kernel_ver}/misc/unicode\
250 /lib/modules/%{_kernel_ver}/misc/unicode/zunicode.ko*\
251 %dir /lib/modules/%{_kernel_ver}/misc/zcommon\
252 /lib/modules/%{_kernel_ver}/misc/zcommon/zcommon.ko*\
253 %dir /lib/modules/%{_kernel_ver}/misc/zfs\
254 /lib/modules/%{_kernel_ver}/misc/zfs/zfs.ko*\
255 %dir /lib/modules/%{_kernel_ver}/misc/zstd\
256 /lib/modules/%{_kernel_ver}/misc/zstd/zzstd.ko*\
257 \
258 %files -n kernel%{_alt_kernel}-zfs-devel\
259 %defattr(644,root,root,755)\
260 /usr/src/zfs-%{version}/%{_kernel_ver}\
261 \
262 %post   -n kernel%{_alt_kernel}-zfs\
263 %depmod %{_kernel_ver}\
264 \
265 %postun -n kernel%{_alt_kernel}-zfs\
266 %depmod %{_kernel_ver}\
267 %{nil}
268
269 %define build_kernel_pkg()\
270 %configure \\\
271         --disable-silent-rules \\\
272         --with-config="kernel" \\\
273         --with-linux=%{_kernelsrcdir}\\\
274         --with-linux-obj=%{_kernelsrcdir}\
275 \
276 %{__make} clean\
277 %{__make} %{?with_verbose:V=1}\
278 p=`pwd`\
279 %{__make} install DESTDIR=$p/installed INSTALL_MOD_DIR=misc\
280 %{nil}
281
282 %{?with_kernel:%{expand:%create_kernel_packages}}
283
284 %prep
285 %setup -q -n %{pname}-%{version}
286 %patch0 -p1
287 %patch1 -p1
288
289 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' \
290       cmd/arc_summary/arc_summary2
291
292 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
293       cmd/arc_summary/arc_summary3
294
295 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+@PYTHON_SHEBANG@(\s|$),#!%{__python3}\1,' \
296       cmd/arcstat/arcstat.in \
297       cmd/dbufstat/dbufstat.in
298
299 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+bash(\s|$),#!/bin/bash\1,' \
300       contrib/dracut/02zfsexpandknowledge/module-setup.sh.in \
301       contrib/dracut/90zfs/module-setup.sh.in \
302       scripts/zimport.sh \
303       scripts/zloop.sh
304
305 %build
306 %{__libtoolize}
307 %{__aclocal} -I config
308 %{__autoconf}
309 %{__autoheader}
310 %{__automake}
311 %{?with_kernel:%{expand:%build_kernel_packages}}
312
313 %if %{with userspace}
314 %configure \
315         --disable-silent-rules \
316         --enable-pam \
317         --enable-systemd \
318         --with-config="user" \
319         --with-linux=%{_kernelsrcdir} \
320         --with-pammoduledir=/%{_lib}/security \
321         --with-systemdunitdir=%{systemdunitdir} \
322         --with-systemdpresetdir=/etc/systemd/system-preset \
323         --with-systemdmodulesloaddir=/etc/modules-load.d \
324         --with-systemdgeneratordir=/lib/systemd/system-generators \
325         --with-udevdir=/lib/udev
326
327 %{__make} \
328         %{?with_verbose:V=1}
329
330 %if %{with python2}
331 cd contrib/pyzfs
332 %py_build
333 cd ../..
334 %endif
335
336 %if %{with python3}
337 cd contrib/pyzfs
338 %py3_build
339 cd ../..
340 %endif
341 %endif
342
343 %install
344 rm -rf $RPM_BUILD_ROOT
345
346 %if %{with kernel}
347 install -d $RPM_BUILD_ROOT
348 cp -a installed/* $RPM_BUILD_ROOT
349 # Drop unneeded spl compat links
350 %{__rm} -r $RPM_BUILD_ROOT/usr/src/spl-%{version}
351 %endif
352
353 %if %{with userspace}
354 %{__make} install \
355         DESTDIR=$RPM_BUILD_ROOT \
356         DEFAULT_INIT_DIR=/etc/rc.d/init.d
357
358 %if %{with python2}
359 %{__rm} -rf $RPM_BUILD_ROOT%{py_sitescriptdir}
360 cd contrib/pyzfs
361 %py_install
362
363 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
364 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
365
366 %py_postclean
367 cd ../..
368 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/libzfs_core/test
369 %endif
370
371 %if %{with python3}
372 cd contrib/pyzfs
373 %py3_install
374 cd ../..
375 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/libzfs_core/test
376 %endif
377
378 # Debian specific stuff
379 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/initramfs-tools
380
381 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_zfs_key.la
382 # Ubuntu PAM config framework file
383 %{__rm} $RPM_BUILD_ROOT%{_datadir}/pam-configs/zfs_key
384
385 # Package these? These are integration tests of the implementation.
386 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/zfs/{zfs-tests,test-runner,runfiles}
387 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{raidz_test,test-runner}.1*
388 %{__rm} $RPM_BUILD_ROOT%{_bindir}/raidz_test
389 %endif
390
391 %clean
392 rm -rf $RPM_BUILD_ROOT
393
394 %post   libs -p /sbin/ldconfig
395 %postun libs -p /sbin/ldconfig
396
397 %if %{with userspace}
398 %files
399 %defattr(644,root,root,755)
400 %doc AUTHORS COPYRIGHT LICENSE NEWS NOTICE README.md
401 %attr(755,root,root) /sbin/mount.zfs
402 %attr(755,root,root) %{_bindir}/arc_summary
403 %attr(755,root,root) %{_bindir}/arcstat
404 %attr(755,root,root) %{_bindir}/dbufstat
405 %attr(755,root,root) %{_bindir}/zvol_wait
406 %attr(755,root,root) %{_sbindir}/fsck.zfs
407 %attr(755,root,root) %{_sbindir}/zdb
408 %attr(755,root,root) %{_sbindir}/zed
409 %attr(755,root,root) %{_sbindir}/zfs
410 %attr(755,root,root) %{_sbindir}/zfs_ids_to_path
411 %attr(755,root,root) %{_sbindir}/zgenhostid
412 %attr(755,root,root) %{_sbindir}/zhack
413 %attr(755,root,root) %{_sbindir}/zinject
414 %attr(755,root,root) %{_sbindir}/zpool
415 %attr(755,root,root) %{_sbindir}/zstream
416 %attr(755,root,root) %{_sbindir}/zstreamdump
417 %attr(755,root,root) %{_sbindir}/ztest
418 %dir %{_sysconfdir}/zfs
419 # package *.example as %doc? (they cannot act as default configuration)
420 %{_sysconfdir}/zfs/vdev_id.conf.*.example
421 %dir %{_sysconfdir}/zfs/zed.d
422 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/*.sh
423 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zed.d/zed.rc
424 %dir %{_sysconfdir}/zfs/zpool.d
425 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/zfs/zpool.d/*
426 %attr(754,root,root) /etc/rc.d/init.d/zfs-import
427 %attr(754,root,root) /etc/rc.d/init.d/zfs-mount
428 %attr(754,root,root) /etc/rc.d/init.d/zfs-share
429 %attr(754,root,root) /etc/rc.d/init.d/zfs-zed
430 %config(noreplace) %verify(not md5 mtime size) /etc/default/zfs
431 /etc/zfs/zfs-functions
432 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/zfs.conf
433 # for zpool iostat/status -c smart
434 #/ets/sudoers.d/zfs
435 /etc/systemd/system-preset/50-zfs.preset
436 /lib/systemd/system-generators/zfs-mount-generator
437 %{systemdunitdir}/zfs.target
438 %{systemdunitdir}/zfs-import.service
439 %{systemdunitdir}/zfs-import.target
440 %{systemdunitdir}/zfs-import-cache.service
441 %{systemdunitdir}/zfs-import-scan.service
442 %{systemdunitdir}/zfs-mount.service
443 %{systemdunitdir}/zfs-share.service
444 %{systemdunitdir}/zfs-volume-wait.service
445 %{systemdunitdir}/zfs-volumes.target
446 %{systemdunitdir}/zfs-zed.service
447 %attr(755,root,root) /lib/udev/vdev_id
448 %attr(755,root,root) /lib/udev/zvol_id
449 /lib/udev/rules.d/60-zvol.rules
450 /lib/udev/rules.d/69-vdev.rules
451 /lib/udev/rules.d/90-zfs.rules
452 %dir %{_libexecdir}/zfs
453 %dir %{_libexecdir}/zfs/zed.d
454 %attr(755,root,root) %{_libexecdir}/zfs/zed.d/*.sh
455 %dir %{_libexecdir}/zfs/zpool.d
456 %attr(755,root,root) %{_libexecdir}/zfs/zpool.d/*
457 %dir %{_datadir}/zfs
458 %attr(755,root,root) %{_datadir}/zfs/*.sh
459 %attr(755,root,root) %{_libexecdir}/zfs/zpool_influxdb
460 %{_datadir}/zfs/compatibility.d
461 %{_mandir}/man1/arcstat.1*
462 %{_mandir}/man1/zhack.1*
463 %{_mandir}/man1/ztest.1*
464 %{_mandir}/man1/zvol_wait.1*
465 %{_mandir}/man4/spl.4*
466 %{_mandir}/man4/zfs.4*
467 %{_mandir}/man5/vdev_id.conf.5*
468 %{_mandir}/man7/zfsconcepts.7*
469 %{_mandir}/man7/zfsprops.7*
470 %{_mandir}/man7/zpool-features.7*
471 %{_mandir}/man7/zpoolconcepts.7*
472 %{_mandir}/man7/zpoolprops.7*
473 %{_mandir}/man8/fsck.zfs.8*
474 %{_mandir}/man8/mount.zfs.8*
475 %{_mandir}/man8/vdev_id.8*
476 %{_mandir}/man8/zdb.8*
477 %{_mandir}/man8/zed.8*
478 %{_mandir}/man8/zfs.8*
479 %{_mandir}/man8/zfs-allow.8*
480 %{_mandir}/man8/zfs-bookmark.8*
481 %{_mandir}/man8/zfs-change-key.8*
482 %{_mandir}/man8/zfs-clone.8*
483 %{_mandir}/man8/zfs-create.8*
484 %{_mandir}/man8/zfs-destroy.8*
485 %{_mandir}/man8/zfs-diff.8*
486 %{_mandir}/man8/zfs-get.8*
487 %{_mandir}/man8/zfs-groupspace.8*
488 %{_mandir}/man8/zfs-hold.8*
489 %{_mandir}/man8/zfs-inherit.8*
490 %{_mandir}/man8/zfs-jail.8*
491 %{_mandir}/man8/zfs-list.8*
492 %{_mandir}/man8/zfs-load-key.8*
493 %{_mandir}/man8/zfs-mount.8*
494 %{_mandir}/man8/zfs-mount-generator.8*
495 %{_mandir}/man8/zfs-program.8*
496 %{_mandir}/man8/zfs-project.8*
497 %{_mandir}/man8/zfs-projectspace.8*
498 %{_mandir}/man8/zfs-promote.8*
499 %{_mandir}/man8/zfs-receive.8*
500 %{_mandir}/man8/zfs-recv.8*
501 %{_mandir}/man8/zfs-redact.8*
502 %{_mandir}/man8/zfs-release.8*
503 %{_mandir}/man8/zfs-rename.8*
504 %{_mandir}/man8/zfs-rollback.8*
505 %{_mandir}/man8/zfs-send.8*
506 %{_mandir}/man8/zfs-set.8*
507 %{_mandir}/man8/zfs-share.8*
508 %{_mandir}/man8/zfs-snapshot.8*
509 %{_mandir}/man8/zfs-unallow.8*
510 %{_mandir}/man8/zfs-unjail.8*
511 %{_mandir}/man8/zfs-unload-key.8*
512 %{_mandir}/man8/zfs-unmount.8*
513 %{_mandir}/man8/zfs-upgrade.8*
514 %{_mandir}/man8/zfs-userspace.8*
515 %{_mandir}/man8/zfs-wait.8*
516 %{_mandir}/man8/zfs_ids_to_path.8*
517 %{_mandir}/man8/zgenhostid.8*
518 %{_mandir}/man8/zinject.8*
519 %{_mandir}/man8/zpool.8*
520 %{_mandir}/man8/zpool-add.8*
521 %{_mandir}/man8/zpool-attach.8*
522 %{_mandir}/man8/zpool-checkpoint.8*
523 %{_mandir}/man8/zpool-clear.8*
524 %{_mandir}/man8/zpool-create.8*
525 %{_mandir}/man8/zpool-destroy.8*
526 %{_mandir}/man8/zpool-detach.8*
527 %{_mandir}/man8/zpool-events.8*
528 %{_mandir}/man8/zpool-export.8*
529 %{_mandir}/man8/zpool-get.8*
530 %{_mandir}/man8/zpool-history.8*
531 %{_mandir}/man8/zpool-import.8*
532 %{_mandir}/man8/zpool-initialize.8*
533 %{_mandir}/man8/zpool-iostat.8*
534 %{_mandir}/man8/zpool-labelclear.8*
535 %{_mandir}/man8/zpool-list.8*
536 %{_mandir}/man8/zpool-offline.8*
537 %{_mandir}/man8/zpool-online.8*
538 %{_mandir}/man8/zpool-reguid.8*
539 %{_mandir}/man8/zpool-remove.8*
540 %{_mandir}/man8/zpool-reopen.8*
541 %{_mandir}/man8/zpool-replace.8*
542 %{_mandir}/man8/zpool-resilver.8*
543 %{_mandir}/man8/zpool-scrub.8*
544 %{_mandir}/man8/zpool-set.8*
545 %{_mandir}/man8/zpool-split.8*
546 %{_mandir}/man8/zpool-status.8*
547 %{_mandir}/man8/zpool-sync.8*
548 %{_mandir}/man8/zpool-trim.8*
549 %{_mandir}/man8/zpool-upgrade.8*
550 %{_mandir}/man8/zpool-wait.8*
551 %{_mandir}/man8/zpool_influxdb.8*
552 %{_mandir}/man8/zstream.8*
553 %{_mandir}/man8/zstreamdump.8*
554
555 %files libs
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_libdir}/libnvpair.so.*.*.*
558 %attr(755,root,root) %ghost %{_libdir}/libnvpair.so.3
559 %attr(755,root,root) %{_libdir}/libuutil.so.*.*.*
560 %attr(755,root,root) %ghost %{_libdir}/libuutil.so.3
561 %attr(755,root,root) %{_libdir}/libzfs.so.*.*.*
562 %attr(755,root,root) %ghost %{_libdir}/libzfs.so.4
563 %attr(755,root,root) %{_libdir}/libzfs_core.so.*.*.*
564 %attr(755,root,root) %ghost %{_libdir}/libzfs_core.so.3
565 %attr(755,root,root) %{_libdir}/libzfsbootenv.so.*.*.*
566 %attr(755,root,root) %ghost %{_libdir}/libzfsbootenv.so.1
567 %attr(755,root,root) %{_libdir}/libzpool.so.*.*.*
568 %attr(755,root,root) %ghost %{_libdir}/libzpool.so.5
569
570 %files devel
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_libdir}/libnvpair.so
573 %attr(755,root,root) %{_libdir}/libuutil.so
574 %attr(755,root,root) %{_libdir}/libzfs.so
575 %attr(755,root,root) %{_libdir}/libzfs_core.so
576 %attr(755,root,root) %{_libdir}/libzfsbootenv.so
577 %attr(755,root,root) %{_libdir}/libzpool.so
578 %{_libdir}/libnvpair.la
579 %{_libdir}/libuutil.la
580 %{_libdir}/libzfs.la
581 %{_libdir}/libzfs_core.la
582 %{_libdir}/libzfsbootenv.la
583 %{_libdir}/libzpool.la
584 %{_includedir}/libspl
585 %{_includedir}/libzfs
586 %{_pkgconfigdir}/libzfs.pc
587 %{_pkgconfigdir}/libzfs_core.pc
588 %{_pkgconfigdir}/libzfsbootenv.pc
589
590 %files static
591 %defattr(644,root,root,755)
592 %{_libdir}/libnvpair.a
593 %{_libdir}/libuutil.a
594 %{_libdir}/libzfs.a
595 %{_libdir}/libzfs_core.a
596 %{_libdir}/libzfsbootenv.a
597 %{_libdir}/libzpool.a
598
599 %files -n dracut-zfs
600 %defattr(644,root,root,755)
601 %doc contrib/dracut/README.dracut.markdown
602 %dir %{dracutlibdir}/modules.d/02zfsexpandknowledge
603 %attr(755,root,root) %{dracutlibdir}/modules.d/02zfsexpandknowledge/module-setup.sh
604 %dir %{dracutlibdir}/modules.d/90zfs
605 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/export-zfs.sh
606 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/import-opts-generator.sh
607 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/module-setup.sh
608 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/mount-zfs.sh
609 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/parse-zfs.sh
610 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-env-bootfs.service
611 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-generator.sh
612 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-lib.sh
613 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-load-key.sh
614 %attr(755,root,root) %{dracutlibdir}/modules.d/90zfs/zfs-needshutdown.sh
615 %{dracutlibdir}/modules.d/90zfs/zfs-rollback-bootfs.service
616 %{dracutlibdir}/modules.d/90zfs/zfs-snapshot-bootfs.service
617
618 %files -n pam-pam_zfs_key
619 %defattr(644,root,root,755)
620 %attr(755,root,root) /%{_lib}/security/pam_zfs_key.so
621
622 %if %{with python2}
623 %files -n python-pyzfs
624 %defattr(644,root,root,755)
625 %doc contrib/pyzfs/README
626 %{py_sitescriptdir}/libzfs_core
627 %{py_sitescriptdir}/pyzfs-*-py*.egg-info
628 %endif
629
630 %if %{with python3}
631 %files -n python3-pyzfs
632 %defattr(644,root,root,755)
633 %doc contrib/pyzfs/README
634 %{py3_sitescriptdir}/libzfs_core
635 %{py3_sitescriptdir}/pyzfs-*-py*.egg-info
636 %endif
637 %endif
638
639 %if %{with kernel}
640 %files -n kernel-zfs-common-devel
641 %defattr(644,root,root,755)
642 %dir /usr/src/zfs-%{version}
643 /usr/src/zfs-%{version}/include
644 /usr/src/zfs-%{version}/zfs.release
645 /usr/src/zfs-%{version}/zfs_config.h
646 %endif
This page took 0.122501 seconds and 3 git commands to generate.