]> git.pld-linux.org Git - packages/zeromq.git/blob - zeromq.spec
e79da63ab9d8675fa861ba5cbb20a5bb6352456e
[packages/zeromq.git] / zeromq.spec
1 #
2 # Conditional build:
3 %bcond_without  gnutls          # TLS transport (GnuTLS based)
4 %bcond_with     kerberos5       # GSSAPI client support [expects MIT Kerberos]
5 %bcond_with     norm            # NORM extension
6 %bcond_without  pgm             # PGM extension (using OpenPGM library)
7 %bcond_without  tests           # build without tests
8
9 Summary:        0MQ - Zero Message Queue
10 Summary(en.UTF-8):      ØMQ - Zero Message Queue
11 Summary(pl.UTF-8):      ØMQ (Zero Message Queue) - kolejka komunikatów
12 Name:           zeromq
13 Version:        4.3.4
14 Release:        1
15 License:        LGPL v3+ with linking exception
16 Group:          Libraries
17 #Source0Download: https://github.com/zeromq/libzmq/releases/
18 Source0:        https://github.com/zeromq/libzmq/releases/download/v%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  c897d4005a3f0b8276b00b7921412379
20 URL:            http://www.zeromq.org/
21 BuildRequires:  asciidoc
22 BuildRequires:  autoconf >= 2.61
23 BuildRequires:  automake
24 %{?with_gnutls:BuildRequires:   gnutls-devel >= 3.1.4}
25 %{?with_krb5:BuildRequires:     krb5-devel}
26 BuildRequires:  libbsd-devel
27 # 5.1, 5.2, 5.3 are supported
28 %{?with_pgm:BuildRequires:      libpgm-devel >= 5.1}
29 %{?with_pgm:BuildRequires:      libpgm-devel < 5.4}
30 BuildRequires:  libsodium-devel
31 BuildRequires:  libstdc++-devel
32 BuildRequires:  libtool
33 BuildRequires:  libunwind-devel
34 BuildRequires:  libuuid-devel
35 %{?with_norm:BuildRequires:     norm-devel}
36 BuildRequires:  pkgconfig
37 BuildRequires:  sed >= 4.0
38 BuildRequires:  xmlto
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 The 0MQ lightweight messaging kernel is a library which extends the
43 standard socket interfaces with features traditionally provided by
44 specialised messaging middleware products. 0MQ sockets provide an
45 abstraction of asynchronous message queues, multiple messaging
46 patterns, message filtering (subscriptions), seamless access to
47 multiple transport protocols and more.
48
49 %description -l en.UTF-8
50 The ØMQ lightweight messaging kernel is a library which extends the
51 standard socket interfaces with features traditionally provided by
52 specialised messaging middleware products. ØMQ sockets provide an
53 abstraction of asynchronous message queues, multiple messaging
54 patterns, message filtering (subscriptions), seamless access to
55 multiple transport protocols and more.
56
57 %description -l pl.UTF-8
58 Lekkie jądro przekazywania komunikatów ØMQ to biblioteka rozszerzająca
59 standardowe interfejsy gniazd o możliwości zwykle udostępniane przez
60 specjalizowane produkty warstwy pośredniej do przekazywania
61 komunikatów. Gniazda ØMQ udostępniają abstrakcję asynchronicznych
62 kolejek komunikatów, wiele wzorców przekazywania komunikatów,
63 filtrowanie komunikatów (subskrypce), przezroczysty dostęp do wielu
64 protokołów transportowych i wiele innych możliwości.
65
66 %package devel
67 Summary:        0MQ library header files for development
68 Summary(en.UTF-8):      ØMQ library header files for development
69 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ØMQ
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 %{?with_gnutls:Requires:        gnutls >= 3.1.4}
73 Requires:       libbsd-devel
74 %{?with_pgm:Requires:   libpgm-devel >= 5.1}
75 Requires:       libsodium-devel
76 Requires:       libstdc++-devel
77 Requires:       libunwind-devel
78 Obsoletes:      zeromq-pthreads-devel
79
80 %description devel
81 0MQ library header files for development.
82
83 %description devel -l en.UTF-8
84 ØMQ library header files for development.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki ØMQ.
88
89 %package static
90 Summary:        Static 0MQ library
91 Summary(en.UTF-8):      Static ØMQ library
92 Summary(pl.UTF-8):      Statyczna biblioteka ØMQ
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95 Obsoletes:      zeromq-pthreads-static
96
97 %description static
98 Static 0MQ library.
99
100 %description static -l en.UTF-8
101 Static ØMQ library.
102
103 %description static -l pl.UTF-8
104 Statyczna biblioteka ØMQ.
105
106 %package -n cppzmq-devel
107 Summary:        Development files for cppzmq
108 Summary(pl.UTF-8):      Pliki programistyczne cppzmq
109 Group:          Development/Libraries
110 License:        MIT
111 Requires:       %{name}-devel = %{version}-%{release}
112
113 %description -n cppzmq-devel
114 The cppzmq-devel package contains the header file for developing
115 applications that use the C++ interface for 0MQ.
116
117 %description -n cppzmq-devel -l pl.UTF-8
118 Ten pakiet zawiera plik nagłówkowy do tworzenia aplikacji
119 wykorzystujących interfejs C++ do ØMQ.
120
121 %prep
122 %setup -q
123
124 %{__sed} -ne '/SPECIAL EXCEPTION GRANTED/,$p' COPYING.LESSER > COPYING.exception
125
126 # uses some multicast networking, timeouts on some hosts
127 %{__sed} -i -e '/^\s*tests\/test_radio_dish /d' Makefile.am
128
129 %build
130 %{__libtoolize}
131 %{__aclocal}
132 %{__autoconf}
133 %{__automake}
134 %{__autoheader}
135 %configure \
136         --enable-drafts \
137         --disable-silent-rules \
138         %{?with_kerberos5:--with-libgssapi_krb5} \
139         --with-libsodium \
140         %{?with_norm:--with-norm} \
141         %{?with_pgm:--with-pgm} \
142         %{?with_gnutls:--with-tls}
143 %{__make}
144
145 %if %{with tests}
146 %{__make} check -j1
147 %endif
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 # obsoleted by pkg-config
156 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post   -p /sbin/ldconfig
162 %postun -p /sbin/ldconfig
163
164 %files
165 %defattr(644,root,root,755)
166 %doc AUTHORS COPYING.exception ChangeLog NEWS
167 %attr(755,root,root) %{_bindir}/curve_keygen
168 %attr(755,root,root) %{_libdir}/libzmq.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libzmq.so.5
170
171 %files devel
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/libzmq.so
174 %{_includedir}/zmq.h
175 %{_includedir}/zmq_utils.h
176 %{_pkgconfigdir}/libzmq.pc
177 %{_mandir}/man3/zmq*.3*
178 %{_mandir}/man7/zmq*.7*
179
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libzmq.a
This page took 0.131351 seconds and 2 git commands to generate.